PPA for VLC media player

PPA description

sudo add-apt-repository ppa:n-muench/vlc

This PPA has VLC Media Player and it's dependencies. As well as other packages/programs so they build against these newer deps in this repo.

All packages are backported either Debian unstable/experimental or Ubuntu Quantal

-----------------------------------------------
THIS PPA MIGHT BREAK OTHER PACKAGES (it shouldn't (since they're backported with minimal changes), but someone recommended that I should note it anyways)
-----------------------------------------------

Debian/Ubuntu Versioning:
0:
   -Build using existing Ubuntu/Debian packaging (based-on packaging will be listed in changelog)
   -Any MAJOR bugs should be sent to be me directly (don't create a bug report on Launchpad or with developer)
1+:
   -Package has been backported from Debian (depending on program, Ubuntu will autosync release with Debian)
   -Bugs may be reported to Debian, but you should check my changelog to see if I added anything before doing so.
XuX:
   -Package has been backported from the upcoming Ubuntu release (I use this numbering method so when you update to the new Ubuntu release, my packages are replaced with what's in the main Ubuntu release)
   -Bugs may be reported to Ubuntu (using Launchpad), but you should check my changelog to see if I added anything before doing so.

NOTES
*fonts-freefont: Needed for VLC (2.0.3-3 and later)
*gpac: Needed for x264
*opus: Needed for VLC (2.0.4-1 and later)
*libsoxr: Needed for Audacity (2.0.3 and later)

DEPENDENCIES STAYING UP TO DATE (everything else will be added as it's needed):
*lame
*libbluray
*npapi-vlc
*VLC (the main repo is now uploading the updates, but I'll keep uploading because of x264)
*x264
*xvidcore

PACKAGE BUILD FAILURES (STATUS):
-Audacity (raring): Not sure
-VLC 2.1.0: Requires gettext 0.18.3.1

TRUSTY REBUILDS (MY USE ONLY):
+libbluray
+lives

UPCOMING PACKAGE UPLOADS (Just waiting on Debian/Ubuntu):
-(New) Avidemux 2.6.6: Waiting on Ubuntu
-(New) liblivemedia 2013.04.30+: Waiting on Debian
-(New) x264 2:0.130.2282+git1db4621-2: On Hold, for now

Adding this PPA to your system

You can update your system with unsupported packages from this untrusted PPA by adding ppa:n-muench/vlc to your system's Software Sources. (Read about installing)

Technical details about this PPA

This PPA can be added to your system manually by copying the lines below and adding them to your system's software sources.

Display sources.list entries for:
deb http://ppa.launchpad.net/n-muench/vlc/ubuntu YOUR_UBUNTU_VERSION_HERE main 
deb-src http://ppa.launchpad.net/n-muench/vlc/ubuntu YOUR_UBUNTU_VERSION_HERE main 
Signing key:
1024R/EAE0D85C (What is this?)
Fingerprint:
1640708104D2F866129B0E86A6804EA8EAE0D85C

Dependencies:

For questions and bugs with software in this PPA please contact Nate Muench (Mink).

PPA statistics

Activity
3 updates added during the past month.
View package details

Overview of published packages

111 of 11 results
Package Version Uploaded by
audacity 2.0.5-1u1~ppa1 Nate Muench (Mink) (2013-10-24)
flac 1.3.0-2~ppa1 Nate Muench (Mink) (2013-10-16)
libbluray 1:0.5.0-2~ppa1.1 Nate Muench (Mink) (2014-04-14)
libbluray 1:0.5.0-2~ppa1 Nate Muench (Mink) (2014-02-28)
liblivemedia 2014.01.13-1~ppa1 Nate Muench (Mink) (2014-01-17)
libvpx 1.3.0-2~ppa1 Nate Muench (Mink) (2014-03-14)
lives 2.2.2~ds0-3~ppa1.1 Nate Muench (Mink) (2014-04-14)
lives 2.2.2~ds0-3~ppa1 Nate Muench (Mink) (2014-03-13)
opus 1.1-0u1~ppa1 Nate Muench (Mink) (2013-12-10)
vlc 2.1.2-2~ppa2 Nate Muench (Mink) (2014-02-07)
x264 2:0.142.2389+git956c8d8-2~exp1 Nate Muench (Mink) (2014-03-27)
111 of 11 results

Latest updates

  • libbluray 5 days ago
    Successfully built
  • lives 5 days ago
    Successfully built
  • x264 3 weeks ago
    Failed to build: amd64 i386
  • libvpx 5 weeks ago
    Successfully built
  • lives 5 weeks ago
    Successfully built