Publishing details

Changelog

nginx (1.20.1-1+ubuntu18.04.1+deb.sury.org+1) bionic; urgency=medium

  * No-change backport to bionic

nginx (1.20.1-1) unstable; urgency=medium

  * Update d/ for nginx 1.20
  * New upstream version 1.20.1

nginx (1.19.10-1) unstable; urgency=medium

  * New upstream version 1.19.10

nginx (1.19.8-0+deb.sury.org+1) unstable; urgency=medium

  * New upstream version 1.19.8
  * Add nginx-common.pref apt preferences configuration file to
    downgrade the OpenSSL package(s) to the version provided by
    the distribution

nginx (1.19.7-3) unstable; urgency=medium

  * Downgrade debhelper compat level to 10
  * libhiredis-dev is required at least at 0.13 version
  * Add nginx_ct 1.3.2 module
  * Add arm64 and ppc64el to list of luajit platforms
  * Add ngx_brotli 1.0.0rc module

nginx (1.19.7-2) unstable; urgency=medium

  * Add ngx_brotli 1.0.0rc module

nginx (1.19.7-1) unstable; urgency=medium

  * New upstream version 1.19.7

nginx (1.19.5-3) unstable; urgency=medium

  * Downgrade http-lua back to 0.10.13 as the new version breaks the nginx
    when enabled

nginx (1.19.5-2) unstable; urgency=medium

  * Add patch for nchan GCC 10 compatibility
  * Explicitly configure LUAJIT_INC and LUAJIT_LIB

nginx (1.19.5-1) unstable; urgency=medium

  * Update the default PPA to mainline
  * Remove spurious B-D on dpkg-dev
  * New upstream version 1.19.5
  * Update http-echo (0.62), http-lua (0.10.19) and http-fancyindex (0.5.1)

nginx (1.19.0-1) unstable; urgency=medium

  * New upstream version 1.19.0

nginx (1.18.0-6+deb.sury.org+1) unstable; urgency=medium

  * Downgrade debhelper compat level to 10
  * libhiredis-dev is required at least at 0.13 version
  * Add nginx_ct 1.3.2 module
  * Add arm64 and ppc64el to list of luajit platforms
  * Add ngx_brotli 1.0.0rc module

nginx (1.18.0-6) unstable; urgency=medium

  * Fix GCC-10 compatibility (Closes: #957605).

nginx (1.18.0-5) unstable; urgency=medium

  * Prevented request smuggling in LUA
    CVE-2020-11724
    Closes: #964950

nginx (1.18.0-4) unstable; urgency=medium

  * Revert: libnginx-mod-* now depends on nginx-<any flavour> (Closes: #963860).
  * Update ngx_http_auth_pam_module upstream URL.
  * libnginx-mod-* recommends nginx now.
  * http-auth-pam: Upgrade to 1.5.2 (Closes: #963567).
  * d/copyright: Bump year of http-auth-pam.

nginx (1.18.0-3) unstable; urgency=medium

  * Source-only upload to allow migration.

nginx (1.18.0-2) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/copyright:
    - Update for upstream release
    - Add Thomas Ward from Ubuntu for debian/*
  * d/conf/sites-available/default: Update PHP path for PHP 7.4
  * d/conf/nginx.conf:
    - Enable TLSv1.3
    - Remove tcp_nodelay on, which is same as default
    - Remove keepalive_timeout 65 and use default value 75s.
    - Remove trailing whitespaces
  * Introduce nginx-core and make it new default for "nginx"
  * Add stream-geoip and stream-geoip2 modules
  * d/ngx-conf: Convert to Python 3
  * d/control: Add GeoIP2 into description
  * Build dynamic modules only in extras flavour
  * libnginx-mod-* now depends on nginx-<any flavour>
  * Check if port 80 is free before starting during install

  [ Ondřej Surý ]
  * http-geoip2: Add ngx_http_geoip2_module 3.3

nginx (1.18.0-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * New upstream version 1.18.0
  * Add REMOTE_USER fastcgi param
  * Use debhelper-compat instead of debian/compat
  * Replace dh_systemd_enable with dh_installsystemd
  * Set Rules-Requires-Root: no
  * d/rules/dh_installinit: Replace --no-restart-on-upgrade with
    --no-stop-on-upgrade
  * Bump debhelper compat level to 13
  * Use package.maintscript instead of dpkg-maintscript-helper
  * Bump standards version to 4.5.0
  * d/watch: Change to 1.18.x
  * d/patches/CVE-2019-20372.patch: Rebase
  * Convert d/ngxmod to Python 3 (Closes: #953025)
  * nchan: Upgrade to 1.2.7
  * http-fancyindex: Upgrade to 0.4.4
  * d/copyright: Add myself for Debian part
  * Add myself as uploader

  [ Mohamed Akram ]
  * Enable --with-compat configure option (Closes: #897926)

nginx (1.16.1-3) unstable; urgency=high

  * Handle CVE-2019-20372, error page request smuggling
    (Closes: #948579)

nginx (1.16.1-2) unstable; urgency=medium

  * http-lua: Downgrade to 0.10.13 (Closes: #941917)
    Temporary fix FTBFS on architectures where Luajit is not available.

nginx (1.16.1-1) unstable; urgency=medium

  * New upstream version (Closes: #929200)
  * Follow stable 1.16 releases (Closes: #929199)
  * Drop already included debian patches
  * http-ndk: Upgrade to 0.3.1
  * http-lua: Upgrade to 0.10.15

nginx (1.14.2-3) unstable; urgency=high

  * Backport upstream fixes for 3 CVEs (Closes: #935037)
    Those fixes affect Nginx HTTP/2 implementation, which might cause
    excessive memory consumption and CPU usage.
    (CVE-2019-9511, CVE-2019-9513, CVE-2019-9516).

nginx (1.14.2-2) unstable; urgency=medium

  [ Kartik Mistry ]
  * po/tr.po:
    + Added Turkish translation. Thanks Atila KOÇ <email address hidden>
      (Closes: #915728)

  [ Christos Trochalakis ]
  * http-dav-ext: Upgrade to 3.0.0 (Closes: #851651)
  * Use a minimal export of the upstream signing key
  * Bump Standards-Version, no changes needed

nginx (1.14.2-1) unstable; urgency=medium

  [ Olaf van der Spek ]
  * Reference PHP 7.3 (Closes: 913250)

  [ Christos Trochalakis ]
  * Adjust fastcgi_split_path_info snippet to handle the `/example.php/` case
    (Closes: #911398)

nginx (1.14.1-1) unstable; urgency=medium

  [ Kartik Mistry ]
  * Removed unused lintian override.
  * Fixed trailing whitespaces in changelog.

  [ Christos Trochalakis ]
  * New upstream version. (Closes: #913090)
    + CVE-2018-16843 Excessive memory usage in HTTP/2
    + CVE-2018-16844 Excessive CPU usage in HTTP/2
    + CVE-2018-16845 Memory disclosure in the ngx_http_mp4_module

nginx (1.14.0-1) unstable; urgency=medium

  [ Kartik Mistry ]
  * debian/control:
    + Removed duplicate Build-Depends.
    + Use https in Homepage.

  [ Christos Trochalakis ]
  * http-lua: Upgrade to 0.10.13
  * http-lua: Drop our OpenSSL patch, OpenSSL 1.1 is now supported upstream
  * http-fancyindex: Upgrade to 0.4.3
  * Order nginx after nss-lookup.target to synchronize host/network name lookups
    (Closes: #900790)
  * Merge ru translations.
    Thanks to Lev Lamberov (Closes: #883104)

 -- Ondřej Surý <email address hidden>  Tue, 08 Jun 2021 09:07:46 +0200

Available diffs

Builds

Package files

No files published for this package.