***** The main PPA for supported PHP versions with many PECL extensions *****

PPA description

Co-installable PHP versions: PHP 5.6, PHP 7.x and most requested extensions are included. Only Supported Versions of PHP (http://php.net/supported-versions.php) for Supported Ubuntu Releases (https://wiki.ubuntu.com/Releases) are provided. Don't ask for end-of-life PHP versions or Ubuntu release, they won't be provided.

Debian oldstable and stable packages are provided as well: https://deb.sury.org/#debian-dpa

You can get more information about the packages at https://deb.sury.org

BUGS&FEATURES: This PPA now has a issue tracker:
https://deb.sury.org/#bug-reporting

CAVEATS:
1. If you are using php-gearman, you need to add ppa:ondrej/pkg-gearman
2. If you are using apache2, you are advised to add ppa:ondrej/apache2
3. If you are using nginx, you are advise to add ppa:ondrej/nginx-mainline
   or ppa:ondrej/nginx

PLEASE READ: If you like my work and want to give me a little motivation, please consider donating regularly: https://donate.sury.org/

WARNING: add-apt-repository is broken with non-UTF-8 locales, see
https://github.com/oerdnj/deb.sury.org/issues/56 for workaround:

# LC_ALL=C.UTF-8 add-apt-repository ppa:ondrej/php

Adding this PPA to your system

You can update your system with unsupported packages from this untrusted PPA by adding ppa:ondrej/php to your system's Software Sources. (Read about installing)

sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
        
Technical details about this PPA

This PPA can be added to your system manually by copying the lines below and adding them to your system's software sources.

Display sources.list entries for:
deb http://ppa.launchpad.net/ondrej/php/ubuntu YOUR_UBUNTU_VERSION_HERE main 
deb-src http://ppa.launchpad.net/ondrej/php/ubuntu YOUR_UBUNTU_VERSION_HERE main 
Signing key:
1024R/14AA40EC0831756756D7F66C4F4EA0AAE5267A6C (What is this?)
Fingerprint:
14AA40EC0831756756D7F66C4F4EA0AAE5267A6C

Dependencies:

For questions and bugs with software in this PPA please contact Ondřej Surý.

PPA statistics

Activity
100 updates added during the past month.
View package details

Overview of published packages

175 of 262 results
Package Version Uploaded by
argon2 0~20161029-1+ubuntu17.10.1+deb.sury.org+1 Ondřej Surý (2017-08-25)
argon2 0~20161029-1+ubuntu17.04.1+deb.sury.org+1 Ondřej Surý (2017-08-25)
argon2 0~20161029-1+ubuntu16.04.1+deb.sury.org+1 Ondřej Surý (2017-08-25)
argon2 0~20161029-1+ubuntu14.04.1+deb.sury.org+1 Ondřej Surý (2017-08-25)
dh-php 0.28+ubuntu17.10.1+deb.sury.org+1 Ondřej Surý (2017-08-04)
dh-php 0.28+ubuntu17.04.1+deb.sury.org+1 Ondřej Surý (2017-08-04)
dh-php 0.28+ubuntu16.04.1+deb.sury.org+1 Ondřej Surý (2017-08-04)
dh-php 0.28+ubuntu14.04.1+deb.sury.org+1 Ondřej Surý (2017-08-04)
graphicsmagick 1.3.25-8~ubuntu16.04.1+deb.sury.org+2 Ondřej Surý (2017-06-23)
graphicsmagick 1.3.25-8~ubuntu14.04.1+deb.sury.org+2 Ondřej Surý (2017-06-23)
jbigkit 2.1-3.1+deb.sury.org~xenial+1 Ondřej Surý (2016-05-13)
jbigkit 2.1-3.1+deb.sury.org~trusty+1 Ondřej Surý (2016-05-13)
libbsd 0.7.0-2+deb.sury.org~trusty+1 Ondřej Surý (2016-05-10)
libedit 3.1-20140620-2+deb.sury.org~trusty+1 Ondřej Surý (2016-05-10)
libgd2 2.2.5-4+ubuntu17.10.1+deb.sury.org+1 Ondřej Surý (2017-12-01)
libgd2 2.2.5-4+ubuntu17.04.1+deb.sury.org+1 Ondřej Surý (2017-12-01)
libgd2 2.2.5-4+ubuntu16.04.1+deb.sury.org+1 Ondřej Surý (2017-12-01)
libgd2 2.2.5-4+ubuntu14.04.1+deb.sury.org+1 Ondřej Surý (2017-12-01)
libmemcached 1.0.18-5+deb.sury.org~xenial+2 Ondřej Surý (2016-01-10)
libmemcached 1.0.18-5+deb.sury.org~trusty+2 Ondřej Surý (2015-12-31)
libpgm 5.2.122~dfsg-2+deb.sury.org~xenial+1 Ondřej Surý (2016-05-13)
libpgm 5.2.122~dfsg-2+deb.sury.org~trusty+1 Ondřej Surý (2016-05-13)
librabbitmq 0.8.0-1+ubuntu17.10.1+deb.sury.org+1 Ondřej Surý (2017-08-10)
librabbitmq 0.8.0-1+ubuntu17.04.1+deb.sury.org+1 Ondřej Surý (2017-08-10)
librabbitmq 0.8.0-1+ubuntu16.04.1+deb.sury.org+1 Ondřej Surý (2017-08-10)
librabbitmq 0.8.0-1+ubuntu14.04.1+deb.sury.org+1 Ondřej Surý (2017-08-10)
libsodium 1.0.15-2+ubuntu17.10.1+deb.sury.org+2 Ondřej Surý (2017-12-07)
libsodium 1.0.15-2+ubuntu17.04.1+deb.sury.org+2 Ondřej Surý (2017-12-07)
libsodium 1.0.15-2+ubuntu16.04.1+deb.sury.org+2 Ondřej Surý (2017-12-07)
libsodium 1.0.15-2+ubuntu14.04.1+deb.sury.org+2 Ondřej Surý (2017-12-07)
libuv1 1.9.1-3+deb.sury.org~zesty+1 Ondřej Surý (2017-04-19)
libuv1 1.9.1-3+deb.sury.org~xenial+1 Ondřej Surý (2017-04-19)
libuv1 1.9.1-3+deb.sury.org~trusty+1 Ondřej Surý (2017-04-19)
libvirt-php 0.5.2-1+deb.sury.org~zesty+1 Ondřej Surý (2017-04-18)
libvirt-php 0.5.2-1+deb.sury.org~xenial+1 Ondřej Surý (2017-01-01)
libvirt-php 0.5.2-1+deb.sury.org~trusty+1 Ondřej Surý (2017-01-01)
libwebp 0.6.0-4+ubuntu17.10.1+deb.sury.org+1 Ondřej Surý (2017-12-07)
libwebp 0.6.0-4+ubuntu17.04.1+deb.sury.org+1 Ondřej Surý (2017-12-07)
libwebp 0.6.0-4+ubuntu16.04.1+deb.sury.org+1 Ondřej Surý (2017-12-07)
libwebp 0.6.0-4+ubuntu14.04.1+deb.sury.org+1 Ondřej Surý (2017-12-07)
libxml2 2.9.4-1+deb.sury.org~xenial+2 Ondřej Surý (2016-06-13)
libzip 1.3.2-1+ubuntu17.10.1+deb.sury.org+1 Ondřej Surý (2017-12-07)
libzip 1.3.2-1+ubuntu17.04.1+deb.sury.org+1 Ondřej Surý (2017-12-07)
libzip 1.3.2-1+ubuntu16.04.1+deb.sury.org+1 Ondřej Surý (2017-12-07)
libzip 1.3.2-1+ubuntu14.04.1+deb.sury.org+1 Ondřej Surý (2017-12-07)
mdocml 1.14.3-3+ubuntu17.10.1+deb.sury.org+2 Ondřej Surý (2017-12-07)
mdocml 1.14.3-3+ubuntu17.04.1+deb.sury.org+2 Ondřej Surý (2017-12-07)
mdocml 1.14.3-3+ubuntu16.04.1+deb.sury.org+2 Ondřej Surý (2017-12-07)
mdocml 1.14.3-3+ubuntu14.04.1+deb.sury.org+2 Ondřej Surý (2017-12-07)
openssl 1.1.0g-2.1+ubuntu17.10.1+deb.sury.org+1 Ondřej Surý (2017-11-12)
openssl 1.1.0g-2.1+ubuntu17.04.1+deb.sury.org+1 Ondřej Surý (2017-11-12)
openssl 1.1.0g-2.1+ubuntu16.04.1+deb.sury.org+1 Ondřej Surý (2017-11-12)
openssl 1.1.0g-2.1+ubuntu14.04.1+deb.sury.org+1 Ondřej Surý (2017-11-12)
pcre3 2:8.41-1.1+ubuntu17.10.1+deb.sury.org+4 Ondřej Surý (2017-12-07)
pcre3 2:8.41-1.1+ubuntu17.04.1+deb.sury.org+4 Ondřej Surý (2017-12-07)
pcre3 2:8.41-1.1+ubuntu16.04.1+deb.sury.org+4 Ondřej Surý (2017-12-07)
pcre3 2:8.41-1.1+ubuntu14.04.1+deb.sury.org+4 Ondřej Surý (2017-12-07)
php-amqp 1.9.3-1+ubuntu17.10.1+deb.sury.org+1 Ondřej Surý (2017-12-05)
php-amqp 1.9.3-1+ubuntu17.04.1+deb.sury.org+1 Ondřej Surý (2017-12-05)
php-amqp 1.9.3-1+ubuntu16.04.1+deb.sury.org+1 Ondřej Surý (2017-12-05)
php-amqp 1.9.3-1+ubuntu14.04.1+deb.sury.org+1 Ondřej Surý (2017-12-05)
php-apcu 5.1.8+4.0.11-1+ubuntu17.10.1+deb.sury.org+2 Ondřej Surý (2017-09-08)
php-apcu 5.1.8+4.0.11-1+ubuntu17.04.1+deb.sury.org+2 Ondřej Surý (2017-09-08)
php-apcu 5.1.8+4.0.11-1+ubuntu16.04.1+deb.sury.org+2 Ondřej Surý (2017-09-08)
php-apcu 5.1.8+4.0.11-1+ubuntu14.04.1+deb.sury.org+2 Ondřej Surý (2017-09-08)
php-apcu-bc 1.0.3-5+ubuntu17.10.1+deb.sury.org+3 Ondřej Surý (2017-09-08)
php-apcu-bc 1.0.3-5+ubuntu17.04.1+deb.sury.org+3 Ondřej Surý (2017-09-08)
php-apcu-bc 1.0.3-5+ubuntu16.04.1+deb.sury.org+3 Ondřej Surý (2017-09-08)
php-apcu-bc 1.0.3-5+ubuntu14.04.1+deb.sury.org+3 Ondřej Surý (2017-09-08)
php-ast 0.1.5-1+ubuntu17.10.1+deb.sury.org+2 Ondřej Surý (2017-07-31)
php-ast 0.1.5-1+ubuntu17.04.1+deb.sury.org+2 Ondřej Surý (2017-07-31)
php-ast 0.1.5-1+ubuntu16.04.1+deb.sury.org+2 Ondřej Surý (2017-07-31)
php-ast 0.1.5-1+ubuntu14.04.1+deb.sury.org+2 Ondřej Surý (2017-07-31)
php-defaults 55+ubuntu17.10.1+deb.sury.org+1 Ondřej Surý (2017-09-05)
php-defaults 55+ubuntu17.04.1+deb.sury.org+1 Ondřej Surý (2017-09-05)
175 of 262 results

Latest updates

  • php7.2 5 days ago
    Successfully built
  • php7.2 5 days ago
    Successfully built
  • php7.2 5 days ago
    Successfully built
  • php7.1 5 days ago
    Successfully built
  • php7.0 5 days ago
    Successfully built