Debian Blender Maintainers does not use Launchpad. This page was created on 2006-02-27 when the blender package was imported into Edgy.

Is this a team you run?