Debian CUPS Maintainers does not use Launchpad. This page was created on 2005-12-21 when the cupsys package was imported into Dapper.

Is this a team you run?