Puppet Package Maintainers does not use Launchpad. This page was created on 2008-01-04 when the puppet_0.24.1-1 package was uploaded to hardy/RELEASE.

Is this a team you run?