Scribus - desktop publishing (Xenial & newer)

PPA description

Scribus 1.5.6~svn24069 for Focal/Groovy & 1.4.8/1.5.5(NG) for Xenial/Bionic.

Scribus 1.4.8 stable and Scribus NG 1.5.5 "development" for Xenial & Bionic, as well as Scribus 1.5.6~svn24069 for Focal & Groovy (from upstream SVN). As Scribus 1.5.6~svn requires Qt 5.11 there will be no builds for Xenial/Bionic.

+===========================================================================+
               Scribus - stable & development (Xenial & newer)
+===========================================================================+

Focal & Groovy only: scribus (1.5.6~svn24069)

Xenial & Bionic only: fontconfig (2.13.1), freetype (2.10.2), hunspell (1.7.0), libcdr (0.1.6), libpng1.6 (1.6.37), libpodofo (0.9.6), libqxp (0.0.2), libvisio (0.1.7), libwpd (0.10.3), libwpg (0.3.3), scribus (1.4.8 stable), scribus-ng (1.5.5 development), zlib

Xenial only: libfreehand (0.1.2), libmspub (0.1.4), libpagemaker (0.0.4), librevenge (0.0.4), libunistring (0.9.10), libzmf (0.0.2), openssl (1.1.1h), pysimplesoap, python-{boto,httplib2,imaplib2} (compat with new openssl)

+===========================================================================+

*** Install ***

Notes for Xenial & Bionic: There are two versions of Scribus offered here for these series, inspired by the "Scribus friends" PPA [*] that has existed for several years. Scribus 1.4.8 "stable" & 1.5.5 "development" with that version packaged as scribus-ng so that both can be co-installed if desired. Install of 1.4.8 should only require this PPA whereas 1.5.5 requires additional PPAs.

*** Notes for Scribus 1.5+ for all series: The "development" version (though considered to be stable regardless of that designation) has dependencies on additional multimedia packages, with a large chain of dependencies starting with openscenegraph (which depends on GDAL and all of the GDAL depedencies).

To keep this PPA cleaner for Xenial & Bionic users only wanting Scribus 1.4.8 the additional dependencies for Scribus 1.5+ are available at the Blender PPA on this Launchpad site. Why Blender? Due that PPA having openscenegraph (also used by Blender) and all the many dependencies of openscenegraph. Adding the Blender PPA simply gives access to the specific set of packages used by the Scribus 1.5+ "development" version installation. Here are the required steps:

ONLY for Xenial (Scribus 1.5.5 requires Qt >= 5.7)

  sudo add-apt-repository ppa:savoury1/qt-xenial

NOW for ALL series

  sudo add-apt-repository ppa:savoury1/ffmpeg4
  sudo add-apt-repository ppa:savoury1/blender
  sudo add-apt-repository ppa:savoury1/scribus
  sudo apt-get update

THEN for Xenial & Bionic

  sudo apt-get install scribus-ng

OR for Focal & Groovy

  sudo apt-get install scribus

Scribus 1.4.8 is based on Qt 4 (not shipped in Focal & newer), so Scribus 1.5 series is simply packaged as scribus instead of scribus-ng for Focal & newer.

*** As is also strongly stated on the Scribus friends PPA, files created by Scribus 1.5 series are NOT compatible with the older Scribus 1.4 series. YOU WILL NOT BE ABLE TO OPEN FILES WITH SCRIBUS 1.4.x CREATED BY SCRIBUS 1.5.x!!!

*** Build ***

This PPA has build dependencies on:

  ppa:savoury1/build-tools
  ppa:savoury1/backports
  ppa:savoury1/ffmpeg4
  ppa:savoury1/blender

Additionally, for Xenial only:

  ppa:savoury1/qt-xenial

*** Credits ***

- Creators of Scribus: the Scribus Team
  https://www.scribus.net/category/about/

- Package code: Mattia Rizzolo
  https://tracker.debian.org/pkg/scribus

[*] https://launchpad.net/~scribus/+archive/ubuntu/ppa

Adding this PPA to your system

You can update your system with unsupported packages from this untrusted PPA by adding ppa:savoury1/scribus to your system's Software Sources. (Read about installing)

sudo add-apt-repository ppa:savoury1/scribus
sudo apt-get update
        
Technical details about this PPA

This PPA can be added to your system manually by copying the lines below and adding them to your system's software sources.

Display sources.list entries for:
deb http://ppa.launchpad.net/savoury1/scribus/ubuntu YOUR_UBUNTU_VERSION_HERE main 
deb-src http://ppa.launchpad.net/savoury1/scribus/ubuntu YOUR_UBUNTU_VERSION_HERE main 
Signing key:
4096R/E996735927E427A733BB653E374C7797FB006459 (What is this?)
Fingerprint:
E996735927E427A733BB653E374C7797FB006459

Dependencies:

For questions and bugs with software in this PPA please contact Rob Savoury.

PPA statistics

Activity
0 updates added during the past month.
View package details

Overview of published packages

139 of 39 results
Package Version Uploaded by
fontconfig 2.13.1-2ubuntu3~18.04.sav0 Rob Savoury (2020-10-08)
fontconfig 2.13.1-2ubuntu3~16.04.sav0 Rob Savoury (2020-10-08)
freetype 2.10.2+dfsg-3ubuntu1~18.04.sav0 Rob Savoury (2020-10-31)
freetype 2.10.2+dfsg-3ubuntu1~16.04.sav0 Rob Savoury (2020-10-31)
hunspell 1.7.0-2~18.04.sav0 Rob Savoury (2020-10-07)
hunspell 1.7.0-2~16.04.sav0 Rob Savoury (2020-10-07)
libcdr 0.1.6-1~18.04.sav0 Rob Savoury (2020-10-07)
libcdr 0.1.6-1~16.04.sav0 Rob Savoury (2020-10-07)
libfreehand 0.1.2-2~16.04.sav0 Rob Savoury (2020-10-07)
libmspub 0.1.4-1~16.04.sav0 Rob Savoury (2020-10-07)
libpagemaker 0.0.4-1~16.04.sav0 Rob Savoury (2020-10-07)
libpng1.6 1.6.37-3~18.04.sav0 Rob Savoury (2020-10-30)
libpng1.6 1.6.37-3~16.04.sav0 Rob Savoury (2020-10-30)
libpodofo 0.9.6+dfsg-5~18.04.sav0 Rob Savoury (2020-10-07)
libpodofo 0.9.6+dfsg-5~16.04.sav0 Rob Savoury (2020-10-07)
libqxp 0.0.2-1~18.04.sav0 Rob Savoury (2020-10-07)
libqxp 0.0.2-1~16.04.sav0 Rob Savoury (2020-10-07)
librevenge 0.0.4-6ubuntu2~16.04.sav0 Rob Savoury (2020-10-07)
libunistring 0.9.10-4~16.04.sav0 Rob Savoury (2020-10-09)
libvisio 0.1.7-1~18.04.sav0 Rob Savoury (2020-10-07)
libvisio 0.1.7-1~16.04.sav0 Rob Savoury (2020-10-07)
libwpd 0.10.3-1~18.04.sav0 Rob Savoury (2020-10-07)
libwpd 0.10.3-1~16.04.sav0 Rob Savoury (2020-10-07)
libwpg 0.3.3-1~18.04.sav0 Rob Savoury (2020-10-07)
libwpg 0.3.3-1~16.04.sav0 Rob Savoury (2020-10-07)
libzmf 0.0.2-1build2~16.04.sav0 Rob Savoury (2020-10-07)
openssl 1.1.1i-1ubuntu0~16.04.sav0 Rob Savoury (2020-12-17)
pysimplesoap 1.16.2-1~16.04.sav0 Rob Savoury (2020-10-31)
python-boto 2.49.0-2ubuntu1.16.04.sav1 Rob Savoury (2020-10-30)
python-httplib2 0.14.0-1ubuntu1~16.04.sav0 Rob Savoury (2020-10-30)
python-imaplib2 2.57-5+16.04.sav1 Rob Savoury (2020-10-30)
scribus 1.5.6~svn24069+ds-0ubuntu1~20.10.sav0 Rob Savoury (2020-10-24)
scribus 1.5.6~svn24069+ds-0ubuntu1~20.04.sav0 Rob Savoury (2020-10-09)
scribus 1.4.8+ds-0ubuntu1~18.04.sav0 Rob Savoury (2020-10-08)
scribus 1.4.8+ds-0ubuntu1~16.04.sav0 Rob Savoury (2020-10-08)
scribus-ng 1.5.5+ds-0ubuntu1~18.04.sav0 Rob Savoury (2020-10-08)
scribus-ng 1.5.5+ds-0ubuntu1~16.04.sav0 Rob Savoury (2020-10-08)
zlib 1:1.2.11.dfsg-2ubuntu1~18.04.sav0 Rob Savoury (2020-10-30)
zlib 1:1.2.11.dfsg-2ubuntu1~16.04.sav0 Rob Savoury (2020-10-09)
139 of 39 results

Latest updates

  • openssl 5 weeks ago
    Successfully built
  • freetype 12 weeks ago
    Successfully built
  • freetype 12 weeks ago
    Successfully built
  • pysimplesoap 12 weeks ago
    Successfully built
  • libpng1.6 12 weeks ago
    Successfully built