Thunar 1.6.10+patch1 (2016-09-07)

PPA description

***UPDATED (2017-03-12)***
[ENGLISH/INGLÊS] This PPA's DEB packages are intended to fix a bug that causes Thunar 1.6.10 to crash while moving/renaming a local/remote file/folder. The patch was provided by Roy Richardson (https://bugzilla.xfce.org/show_bug.cgi?id=12264#c114). I tested and confirmed its effectiveness in *Ubuntu 16.04 "Xenial Xerus" and other users did the same on *Ubuntu 16.10 "Yakkety Yak". Users of *Ubuntu 15.10 "Wily Werewolf" are encouraged to test the Wily version available here.

In order to add this PPA, trust it and then upgrade Thunar 1.6.10 to the "patched" version, please run this command at the shell terminal:

sudo add-apt-repository ppa:yuri-sucupira/thunar1.6.10-fix ; sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv AF8C7F18 ; sudo apt-get update ; sudo apt-get dist-upgrade -y

If the "patched" Thunar 1.6.10 still doesn't work for you and you're interested in testing the new (proposed) version of Thunar, which is version 1.6.11, first remove this PPA and its associated key by accessing the Linux shell (terminal) and running this command:

sudo apt-get install ppa-purge -y ; sudo ppa-purge ppa:yuri-sucupira/thunar1.6.10-fix ; sudo apt-key del AF8C7F18 ; sudo rm /etc/apt/sources.list.d/yuri-sucupira*

The command above will purge and remove this PPA from your system, along with its authentication key. Also, Thunar will be downgraded to it's "factory" version 1.6.10, which doesn't carry the patch and does carry the bug. Once you do this, run the command below in order to add the "proposed" PPA for the release (xenial, yakkety etc.) of your *Ubuntu distribution:

echo ' ' | sudo tee -a /etc/apt/sources.list ; echo '#Proposed (under testing) packages for the release of your Linux distribution:' | sudo tee -a /etc/apt/sources.list ; echo deb http://archive.ubuntu.com/ubuntu/ `lsb_release -cs`-proposed multiverse universe main restricted | sudo tee -a /etc/apt/sources.list

...and then execute the command below in order to update your system's cache of repositories and then upgrade your Thunar install:

sudo apt-get update ; sudo apt-get install thunar --only-upgrade -f -y

This will cause Thunar to be upgraded to the proposed version "1.6.11".

HOWEVER, you probably don't want your entire system to install proposed (testing) packages: it's more likely that you just wish to upgrade Thunar and Thunar only. Hence, after upgrading Thunar it's ***highly recommended*** that you disable the "proposed" PPA repository by running this command:

proposed='s|'`cat /etc/apt/sources.list |grep -i "proposed multiverse"`'|#'`cat /etc/apt/sources.list |grep -i "proposed multiverse"`'|' ; export proposed ; sudo sed -i -e "$proposed" "/etc/apt/sources.list" ; sudo apt-get update

If you did everything as explained above, now this PPA is deleted from your system, your Thunar install is version 1.6.11 and the "proposed" repository is disabled.

----------------------
***ATUALIZADO (12/03/2017)***
[PORTUGUESE/PORTUGUÊS] Os pacotes DEB deste repositório PPA visam corrigir um bug que faz com que o Thunar 1.6.10 pare de funcionar durante o processo de movimentação/renomeação de um arquivo. O patch de correção do bug foi fornecido por Roy Richardson (https://bugzilla.xfce.org/show_bug.cgi?id=12264#c114). Eu testei e confirmei a eficácia dele somente no *Ubuntu 16.04 "Xenial Xerus", e outros usuários confirmaram essa eficácia no *Ubuntu 16.10 "Yakkety Yak". Os usuários do *Ubuntu 15.10 "Wily Werewolf" estão convidados a testar a versão Wily disponibilizada aqui.

Para adicionar este PPA, confiar nele e então atualizar o Thunar 1.6.10 para a versão "corrigida", por favor execute este comando no terminal do shell:

sudo add-apt-repository ppa:yuri-sucupira/thunar1.6.10-fix ; sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv AF8C7F18 ; sudo apt-get update ; sudo apt-get dist-upgrade -y

Caso o Thunar 1.6.10 "corrigido" também não funcione como esperado e você tenha interesse em testar a nova (proposta) versão do Thunar, que é a versão 1.6.11, primeiramente acesse o terminal do shell e execute o comando abaixo, para remover este PPA e a chave dele:

sudo apt-get install ppa-purge -y ; sudo ppa-purge ppa:yuri-sucupira/thunar1.6.10-fix ; sudo apt-key del AF8C7F18 ; sudo rm /etc/apt/sources.list.d/yuri-sucupira*

O comando acima irá "purgar" e remover este PPA do seu sistema, além de deletar a chave de autenticação deste PPA. Além disso, o aplicativo Thunar será "desatualizado" de volta para a sua versão "de fábrica" (versão 1.6.10, que é a versão "original", ou seja, a que tem o "bug" e não tem o patch de correção). Após executar o comando acima, execute o comando abaixo para adicionar ao seu sistema o repositório PPA "proposed" (proposto/em testes) para a versão (xenial, yakkety etc.) da sua distribuição *Ubuntu:

echo ' ' | sudo tee -a /etc/apt/sources.list ; echo '#Pacotes "propostos"
 (em testes) para a versão da sua distribuição Linux:' | sudo tee -a /etc/apt/sources.list ; echo deb http://br.archive.ubuntu.com/ubuntu/ `lsb_release -cs`-proposed multiverse universe main restricted | sudo tee -a /etc/apt/sources.list

...e então execute o comando abaixo para atualizar o cache de repositórios do seu sistema e em seguida atualizar o Thunar:

sudo apt-get update ; sudo apt-get install thunar --only-upgrade -f -y

Isso fará o Thunar ser atualizado para a versão de testes "1.6.11".

PORÉM, você provavelmente não quer atualizar o seu sistema inteiro com todos os pacotes de testes (propostos): é mais provável que você queira atualizar somente o Thunar. Portanto, após atualizar o Thunar é ***altamente recomendável*** que você execute o comando abaixo, para desativar o repositório PPA "proposed":

proposed='s|'`cat /etc/apt/sources.list |grep -i "proposed multiverse"`'|#'`cat /etc/apt/sources.list |grep -i "proposed multiverse"`'|' ; export proposed ; sudo sed -i -e "$proposed" "/etc/apt/sources.list" ; sudo apt-get update

Se você fez tudo como explicado acima, agora este PPA está excluído do seu sistema, o Thunar está instalado na versão 1.6.11 e o repositório PPA "proposed" está desativado.

Adding this PPA to your system

You can update your system with unsupported packages from this untrusted PPA by adding ppa:yuri-sucupira/thunar1.6.10-fix to your system's Software Sources. (Read about installing)

sudo add-apt-repository ppa:yuri-sucupira/thunar1.6.10-fix
sudo apt-get update
        
Technical details about this PPA

This PPA can be added to your system manually by copying the lines below and adding them to your system's software sources.

Display sources.list entries for:
deb http://ppa.launchpad.net/yuri-sucupira/thunar1.6.10-fix/ubuntu YOUR_UBUNTU_VERSION_HERE main 
deb-src http://ppa.launchpad.net/yuri-sucupira/thunar1.6.10-fix/ubuntu YOUR_UBUNTU_VERSION_HERE main 
Signing key:
4096R/AF8C7F18 (What is this?)
Fingerprint:
AA8D5020C2ED22E6E7C12CD828D99B97AF8C7F18

For questions and bugs with software in this PPA please contact Yuri Ribeiro Sucupira.

PPA statistics

Activity
0 updates added during the past month.
View package details

Overview of published packages

13 of 3 results
Package Version Uploaded by
thunar 1.6.10-2ubuntu1+yakkety-patch1 (Newer version available) Yuri Ribeiro Sucupira (2016-10-07)
thunar 1.6.10-2ubuntu1+wily-patch1 Yuri Ribeiro Sucupira (2016-10-07)
thunar 1.6.10-2ubuntu1+patch1 (Newer version available) Yuri Ribeiro Sucupira (2016-09-07)
13 of 3 results

Latest updates

  • thunar 33 weeks ago
    Successfully built
  • thunar 33 weeks ago
    Successfully built
  • thunar 37 weeks ago
    Successfully built