Change log for belle-sip package in Debian

110 of 10 results
Published in buster-release on 2019-04-23
Published in sid-release on 2019-04-17
belle-sip (1.6.3-5) unstable; urgency=medium

  * Team upload.
  * Cherry-Pick upstream fixes for crash with missing nonce at reg.
    Thanks to Bernhard √úbelacker and Alf for testing (Closes: #921266)

 -- Bernhard Schmidt <email address hidden>  Wed, 17 Apr 2019 19:08:42 +0200

Available diffs

Superseded in buster-release on 2019-04-23
Published in sid-release on 2018-10-11
belle-sip (1.6.3-4) unstable; urgency=medium

  * Team upload.
  * Temporarily downgrade new errors in GCC-8 (Closes: #906452)

 -- Bernhard Schmidt <email address hidden>  Thu, 11 Oct 2018 00:00:59 +0200
Deleted in buster-release (Reason: None provided.)
Superseded in sid-release on 2018-10-11
belle-sip (1.6.3-3) unstable; urgency=medium

  * Team upload.
  * Remove Multi-Arch: same from libbellesip-dev package.
    Thanks to Francois Gouget <email address hidden> (Closes: #897324)
  * Use debhelper v11
  * Switch Vcs-URLs to salsa.d.o
  * Update Standards-Version to 4.1.4, no changes needed

 -- Dr. Tobias Quathamer <email address hidden>  Tue, 01 May 2018 14:37:57 +0200

Available diffs

Superseded in buster-release on 2018-05-06
Superseded in sid-release on 2018-10-16
belle-sip (1.6.3-2) unstable; urgency=medium

  * Try to fix FTBFS on various architectures
    - Disable parallel building
    - Increase JAVA heap space

 -- Bernhard Schmidt <email address hidden>  Thu, 09 Nov 2017 23:03:30 +0100

Available diffs

Superseded in sid-release on 2017-11-10
belle-sip (1.6.3-1) unstable; urgency=medium

  * Team upload.

  [ Felix Lechner ]
  * Fix VCS URLs to point to packaging repository (Closes: #787170).

  [ Daniel Gnoutcheff ]
  * New upstream version 1.5.0
    - Updated symbols, fix-spelling-errors.patch
    - Now build-depends on libbctoolbox instead of polarssl
  * Switch to CMake for builds
  * Conservative upper bound for symbols/shlibs to control for API breakage
  * Point Vcs-* to git repository
  * Update copyright, descriptions

  [ Johannes Schauer ]
  * New upstream version 1.6.1
  * remove version restriction from libbctoolbox-dev
  * refreshed patch for 1.6.1
  * debian/docs: README => README.md
  * refresh debian/libbellesip0.symbols
  * add cmake-zlib.patch using "zlib" instead of "z" in pkg-config
    Requires.private
  * remove debian/libbellesip0.shlibs because of misleading version
    restriction
  * bump debhelper compatibility level to 10
  * debian/rules: Use hardening=+all
  * use CMAKE_SKIP_RPATH=ON to avoid rpath in libraries
  * run wrap-and-sort -abt
  * remove libbellesip-dbg in favour of automatically generated dbgsym package

  [ Dr. Tobias Quathamer ]
  * Use dh_strip --dbgsym-migration for the obsolete debug package
  * Use HTTPS URLs when possible
  * Update to Standards-Version 4.1.1
  * Minor update to debian/watch
  * New upstream version 1.6.3
  * Refresh symbols file for new upstream
  * Remove upstream signing key, as releases are not signed

 -- Dr. Tobias Quathamer <email address hidden>  Mon, 06 Nov 2017 14:09:32 +0100
Superseded in buster-release on 2017-11-15
Published in stretch-release on 2016-01-31
Superseded in sid-release on 2017-11-10
belle-sip (1.4.1-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix FTBFS with GCC 6. (Closes: #812010)
  * Port to mbedTLS since PolarSSL is going away. (Closes: #808067)
    - Add --disable-strict to configure invocation to prevent -Werror from
      failing the build (warning is about polarssl compat layer deprecation).

 -- James Cowgill <email address hidden>  Wed, 20 Jan 2016 14:48:11 +0000

Available diffs

Deleted in stretch-release (Reason: None provided.)
Published in sid-release on 2015-05-23
belle-sip (1.4.1-1) unstable; urgency=medium

  [ Felix Lechner ]
  * New upstream version 1.4.1
  * Added Build-Depends: libcunit1-ncurses-dev
  * Added build option '--disable-tests' as unit tests require network
  * Changed Svn-Browser to GitHub mirror
  * Changed Svn-Git: to upstream, bypassing Savannah
  * Changed url in watch file to run off GitHub tags
  * Removed unnecessary section declaration for libbellesip0 from control
  * Added Multi-Arch: same to libbellesip-dbg
  * Corrected names and paths in copyright
  * Clarified BSD license to say BSD-3-clause
  * Fixed spelling errors in binary
  * Updated Standards-Version to 3.9.6

  [ Tzafrir Cohen ]
  * Added Multi-Arch: same to libbellesip-dev as well.

 -- Tzafrir Cohen <email address hidden>  Sat, 23 May 2015 15:43:37 +0300
Superseded in stretch-release on 2015-05-29
Published in jessie-release on 2014-05-25
Superseded in sid-release on 2015-06-01
belle-sip (1.3.0-1.1) unstable; urgency=medium


  * Non-maintainer upload.
  * Fix FTBFS mips.
    Add increase-antlr-timeout.patch.
    Patch by Dejan Latinovic <email address hidden>.
    Closes: #748232.

 -- Anibal Monsalve Salazar <email address hidden>  Fri, 16 May 2014 11:28:47 +0100

Available diffs

Superseded in jessie-release on 2014-05-25
Superseded in sid-release on 2014-05-21
belle-sip (1.3.0-1) unstable; urgency=medium


  [ Felix Lechner ]
  * New upstream release 
    - Fixes "FTBFS: unexpected token" (Closes: #742852)

  [ Mark Purcell ]
  * Update debian/watch

 -- Mark Purcell <email address hidden>  Wed, 02 Apr 2014 06:39:53 +1100
Superseded in sid-release on 2014-04-18
belle-sip (1.2.4-1) unstable; urgency=medium


  [ Felix Lechner ]
  * Team upload.
  * Initial release (Closes: #737830)
  * Use PolarSSL API v1.3 instead of v1.2 compatibility layer

  [ Mark Purcell ] 
  * Add debian/watch

 -- Mark Purcell <email address hidden>  Sun, 16 Feb 2014 21:29:17 +1100
110 of 10 results