Debian GNU/Linux

Change log for “bpython” package in Debian

117 of 17 results
Published in sid-release on 2014-04-16
bpython (0.12-1.1) unstable; urgency=medium


  * Non-maintainer upload.
  * Adds python3-all as build-depends to avoid FTBFS. (Closes: #741823).
  * Added a debian/gbp.conf to use pristine-tar.

 -- Thomas Goirand <email address hidden>  Thu, 10 Apr 2014 10:56:00 +0000
Published in jessie-release on 2013-11-14
Superseded in sid-release on 2014-04-16
bpython (0.12-1) unstable; urgency=low


  * Acknowledge NMU.
  * New upstream version (Closes: #697053).
  * Suggest python-twisted for bpython-urwid (Closes: #681765)
  * Standards-Version bump to 3.9.5, no changes needed.
  * Use canonical urls for Vcs-* fields.
  * Update debian/ to correctly compile the new version:
    - Build-Depend on python-babel to allow translations building
      (Closes: #700187).
    - Build-Depend on python-sphinx to build the manpages.

 -- David Paleino <email address hidden>  Sun, 03 Nov 2013 13:23:28 +0100

Available diffs

Superseded in jessie-release on 2013-11-14
Superseded in sid-release on 2013-11-03
bpython (0.11-1.1) unstable; urgency=low


  * Non-maintainer upload.
  * Build using just the default python3 version to fix FTBFS when there is
    more than one (Closes: #707309)

 -- Scott Kitterman <email address hidden>  Sun, 04 Aug 2013 17:18:19 -0400
Superseded in jessie-release on 2013-08-15
Published in wheezy-release on 2012-04-18
Superseded in sid-release on 2013-08-05
bpython (0.11-1) unstable; urgency=low


  * New upstream version
  * Add windows.theme to installed example themes
  * Updated debian/copyright
  * debian/patches/03-support_new_urwid.patch removed, merged upstream

 -- David Paleino <email address hidden>  Sat, 07 Apr 2012 19:31:00 +0200

Available diffs

Superseded in wheezy-release on 2012-04-18
Superseded in sid-release on 2012-04-07
bpython (0.10.1-3) unstable; urgency=low


  * Apply patch from upstream to handle newer urwid (Closes: #645658)
  * Add dh-buildinfo

 -- David Paleino <email address hidden>  Mon, 17 Oct 2011 19:08:01 +0200
Superseded in wheezy-release on 2011-10-28
Superseded in sid-release on 2011-10-18
bpython (0.10.1-2) unstable; urgency=low


  * Huge BUG in the conversion from dh_pysupport to dh_python2:
    in 0.9.7.1-1's (pysupport) postrm, I inconditionally removed
    /usr/lib/python*/*-packages/bpython (which was wrong), and
    this removed also files shipped by 0.10.1-1, thus causing an
    ImportError fixable only by re-installation.
    Added preinst nuking old postrms, so that upgrades are clean
    (Closes: #640969)

 -- David Paleino <email address hidden>  Fri, 09 Sep 2011 13:13:51 +0200
Superseded in sid-release on 2011-09-20
bpython (0.10.1-1) unstable; urgency=low


  [ David Paleino ]
  * New upstream version
  * Patches refreshed, 03-fix_manpage.patch removed (merged upstream)
  * Standards-Version bump to 3.9.3, no changes needed

  [ Tanguy Ortolo ]
  * Include sample.theme in installed examples
  * Use "$@" in wrapper scripts for correct argument passing
  * Switch debian/rules in debian/control to dh_python2
  * debian/postrm: deleted as useless and harmful
  * Adapt packaging to support python3 (Closes: #572776)

 -- David Paleino <email address hidden>  Wed, 07 Sep 2011 09:18:27 +0200
Superseded in wheezy-release on 2011-09-21
Published in squeeze-release on 2010-08-14
Superseded in sid-release on 2011-09-20
bpython (0.9.7.1-1) unstable; urgency=low


  * New upstream release (Closes: #590551)
  * debian/patches/:
    - 01-fix_logo_path.patch refreshed
    - 03-fix_manpage.patch added, fixes typo (Closes: #583191)
  * debian/copyright updated
  * debian/source/format: use 3.0 (quilt)
  * debian/control:
    - added bpython-urwid binary package
    - Standards-Version bumped to 3.9.1, no changes needed
  * debian/scripts/bpython-urwid, debian/scripts/bpython-urwid.py added,
    wrapper scripts to provide a separate urwid package
  * debian/bpython-urwid.install, debian/bpython-urwid.links added,
    install the correct files in the new package
  * debian/bpython-urwid.lintian-overrides added, make lintian happy
    also with the new package
  * debian/rules:
    - remove "--with quilt"
    - remove "logo.png" from pyshared directory (use mv instead of cp)
    - remove "urwid.py*" from bpython binary package
    - rename urwid.py to urwid_.py in the bpython-urwid package

 -- David Paleino <email address hidden>  Mon, 02 Aug 2010 23:08:12 +0200
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
bpython (0.9.6.2-2) unstable; urgency=low


  * Reduce delta with Ubuntu, and prepare for near-future Debian:
    support Python >= 2.5:
    - debian/control: bump XS-Python-Version
    - debian/postinst, debian/postrm: remove python*/*-packages/bpython,
      to catch both python2.5/site-packages and python2.6/dist-packages.

 -- David Paleino <email address hidden>  Sat, 16 Jan 2010 17:53:57 +0100
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
bpython (0.9.6.2-1) unstable; urgency=low


  * Upstream broke things with 0.9.6, new release

 -- David Paleino <email address hidden>  Thu, 31 Dec 2009 11:21:13 +0100
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
bpython (0.9.5.2-3) unstable; urgency=low


  * debian/postinst: only do something if an "old-version" is
    passed to the script (Closes: #560229)

 -- David Paleino <email address hidden>  Fri, 11 Dec 2009 18:19:39 +0100
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
bpython (0.9.5.2-2) unstable; urgency=low


  * debian/control:
    - updated my email address
    - DMUA removed
    - add quilt Build-Dependency
    - add python-support Build-Dependency
  * debian/patches/:
    - 01-add_write_to_FakeStdin.patch added (Closes: #558054)
    - 02-add_flush_to_FakeStdin.patch added
  * debian/rules, add --with quilt
  * debian/postinst, debian/postrm added, correctly handle removal of
    .pyc files after the move to /usr/share/pyshared

 -- David Paleino <email address hidden>  Sun, 29 Nov 2009 00:51:56 +0100
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
bpython (0.9.5.2-1) unstable; urgency=low


  * New upstream version

 -- David Paleino <email address hidden>  Fri, 09 Oct 2009 14:39:52 +0200
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
bpython (0.9.5.1-1) unstable; urgency=low


  * New upstream version
  * Removed quilt patchsystem (no more patches here)
  * debian/patches/01-fix_python_history_file.patch removed, merged
    upstream

 -- David Paleino <email address hidden>  Wed, 23 Sep 2009 11:36:13 +0200
Superseded in squeeze-release on 2011-09-13
Superseded in sid-release on 2011-09-20
bpython (0.9.4-1) unstable; urgency=low


  * New upstream version
  * debian/rules, debian/control:
    - adding quilt infrastructure (>= 0.46-7~ for dh7 integration)
  * debian/patches/:
    - 01-fix_python_history_file.patch added, thanks to Philipp Winter
      (Closes: #537504)
  * debian/control:
    - only support python2.5 at the moment (setuptools import fails on
      py2.6, thus FTBFS)
    - Standards-Version bump to 3.8.3, no changes needed
  * debian/examples updated, sample file has been renamed
  * debian/README.source added

 -- David Paleino <email address hidden>  Thu, 03 Sep 2009 13:12:23 +0200
Superseded in sid-release on 2011-09-20
Superseded in squeeze-release on 2011-09-13
bpython (0.9.3-1) unstable; urgency=low


  * New upstream version
  * debian/watch updated
  * debian/control:
    - python-pyparsing is no more needed, removed from dependencies
    - new Homepage, field updated

 -- David Paleino <email address hidden>  Thu, 11 Jun 2009 22:18:33 +0200
Superseded in sid-release on 2011-09-20
bpython (0.7.1-1) unstable; urgency=low


  * Initial Debian release (Closes: #526740)

 -- David Paleino <email address hidden>  Sun, 03 May 2009 12:55:56 +0200
117 of 17 results