Change log for rsyslog package in Debian

175 of 125 results
Published in sid-release on 2017-11-02
rsyslog (8.30.0-2) unstable; urgency=medium

  * Add Build-Depends on flex for generating grammar/lexer.c.
    This ensures we can build twice in a row. The pre-generated files in
    grammar/ are removed on make clean.
  * Revert "Use dh_auto_test instead of calling make check directly"
    Somehow this broke the test suite and made lots of tests fail.
  * Add Build-Depends on autoconf-archive for the AX_COMPILER_FLAGS macro

 -- Michael Biebl <email address hidden>  Thu, 02 Nov 2017 11:48:02 +0100
Superseded in sid-release on 2017-11-02
rsyslog (8.30.0-1) unstable; urgency=medium

  * New upstream version 8.30.0
  * Rebase patches
  * Bump Build-Depends on libfastjson-dev to (>= 0.99.7) as per configure.ac
  * Switch from dh_install --list-missing to dh_missing --list-missing
  * Cherry-pick upstream patches to fix imgssapi build failures
  * Bump Standards-Version to 4.1.1

 -- Michael Biebl <email address hidden>  Wed, 01 Nov 2017 22:51:44 +0100
Published in buster-release on 2017-09-11
Superseded in sid-release on 2017-11-02
rsyslog (8.29.0-2) unstable; urgency=medium

  * Change priority of all extra packages to optional
  * Bump Standards-Version to 4.0.1
  * Cherry-pick upstream patch to fix build failures on platforms without
    64-bit atomics (Closes: #872568)

 -- Michael Biebl <email address hidden>  Tue, 05 Sep 2017 19:09:49 +0200
Superseded in sid-release on 2017-09-06
rsyslog (8.29.0-1) unstable; urgency=medium

  * New upstream version 8.29.0
  * Rebase patches

 -- Michael Biebl <email address hidden>  Tue, 08 Aug 2017 21:35:12 +0200
Superseded in buster-release on 2017-09-11
Superseded in sid-release on 2017-09-06
rsyslog (8.28.0-1) unstable; urgency=medium

  * New upstream version 8.28.0
  * Bump Build-Depends on librelp-dev to (>= 1.2.14) as per configure.ac
  * Drop versioned Build-Depends on dpkg-dev (>= 1.17.14)
    No longer required as even jessie ships a newer version.
  * Bump Standards-Version to 4.0.0
  * Enable mmfields module (Closes: #852269)
  * Enable but do not install omstdout module.
    This module is required to successfully run the test suite.

 -- Michael Biebl <email address hidden>  Sun, 09 Jul 2017 23:52:51 +0200
Superseded in sid-release on 2017-07-10
rsyslog (8.27.0-4) unstable; urgency=medium

  * Fix PID file to actually be /run/rsyslogd.pid (Closes: #865276)
  * Don't rely on SysV init script in logrotate config.
    Add a small helper to send SIGHUP to rsyslogd to close open log files.
    Use systemctl directly if systemd is the active PID 1. Keep the SysV
    init script as fallback only.

 -- Michael Biebl <email address hidden>  Sun, 25 Jun 2017 18:27:04 +0200
Superseded in sid-release on 2017-06-26
rsyslog (8.27.0-3) unstable; urgency=medium

  * Change PID file to use /run/rsyslog.pid instead of /var/run/rsyslog.pid

 -- Michael Biebl <email address hidden>  Mon, 19 Jun 2017 00:46:43 +0200
Superseded in sid-release on 2017-06-20
rsyslog (8.27.0-2) unstable; urgency=medium

  * Upload to unstable

 -- Michael Biebl <email address hidden>  Sun, 18 Jun 2017 18:17:40 +0200
Deleted in experimental-release (Reason: None provided.)
rsyslog (8.27.0-1) experimental; urgency=medium

  * New upstream version 8.27.0
  * Rebase patches
  * Bump Build-Depends on liblognorm-dev to (>= 2.0.3)
  * Enable imkafka input plugin

 -- Michael Biebl <email address hidden>  Sat, 03 Jun 2017 22:18:39 +0200
Superseded in experimental-release on 2017-06-04
rsyslog (8.25.0-1) experimental; urgency=medium

  * New upstream release
  * Update Vcs-* following the latest recommendation
  * Rebase patches

 -- Michael Biebl <email address hidden>  Tue, 21 Feb 2017 18:08:16 +0100
Published in stretch-release on 2017-01-29
Superseded in sid-release on 2017-06-20
rsyslog (8.24.0-1) unstable; urgency=medium

  [ Michael Biebl ]
  * New upstream release.
  * Rebase patches.
  * Add Depends on init-system-helpers (>= 1.47~) to rsyslog.
    This ensures we have a version of invoke-rc.d that supports try-restart.

  [ Ondřej Nový ]
  * Trigger restart on configuration changes.
    Register a dpkg trigger on /etc/rsyslog.d that calls restart on
    configuration changes. (Closes: #791337)
  * Update dpkg trigger to use try-restart.
    Add try-restart action to SysV initscript for that, systemd supports
    this natively.

 -- Michael Biebl <email address hidden>  Wed, 18 Jan 2017 23:14:38 +0100
Superseded in stretch-release on 2017-01-29
Superseded in sid-release on 2017-01-19
rsyslog (8.23.0-2) unstable; urgency=medium

  * Fix empty-hostname.sh test and change support for empty hostname
    (Closes: #844914)

 -- Michael Biebl <email address hidden>  Thu, 24 Nov 2016 11:33:43 +0100
Superseded in sid-release on 2016-11-24
rsyslog (8.23.0-1) unstable; urgency=medium

  * New upstream release.
  * Rebase patches.
  * Bump Build-Depends on libfastjson-dev to (>= 0.99.3).
  * Use the new default-mysql-* metapackages.
  * Remove logging rules for news.{crit,err,notice} (INN).

 -- Michael Biebl <email address hidden>  Fri, 18 Nov 2016 07:43:24 +0100
Superseded in stretch-release on 2016-11-30
Superseded in sid-release on 2016-11-18
rsyslog (8.22.0-2) unstable; urgency=medium

  * Bump debhelper compat level to 10.

 -- Michael Biebl <email address hidden>  Sun, 16 Oct 2016 01:13:12 +0200
Superseded in stretch-release on 2016-10-21
Superseded in sid-release on 2016-10-17
rsyslog (8.22.0-1) unstable; urgency=medium

  [ Michael Biebl ]
  * New upstream release.

  [ Matt Zahorik ]
  * Enable hiredis output plugin (Closes: #833535)

 -- Michael Biebl <email address hidden>  Tue, 04 Oct 2016 21:07:21 +0200
Superseded in sid-release on 2016-10-07
rsyslog (8.21.0-1) unstable; urgency=medium

  * New upstream release.
  * Rebase patches.

 -- Michael Biebl <email address hidden>  Tue, 23 Aug 2016 18:49:35 +0200
Superseded in sid-release on 2016-08-24
rsyslog (8.20.0-1) unstable; urgency=medium

  * New upstream release.
  * Rebase patches.
  * Bump Standards-Version to 3.9.8.
  * Switch from libjson-c-dev to libfastjson-dev.
  * Bump Build-Depends on librelp-dev to (>= 1.2.12) as per configure.ac.
  * Bump Build-Depends on liblognorm-dev to (>= 2.0.0) to ensure we have a
    version which was built against libfastjson.
  * Add Build-Depends on procps. The test suite requires the ps utility.
  * Use dh-exec to install arch specific modules.
  * Bump debhelper compatibility level to 9.
  * Install module libraries into multiarch paths.

 -- Michael Biebl <email address hidden>  Fri, 12 Aug 2016 22:46:32 +0200
Superseded in stretch-release on 2016-10-12
Published in sid-release on 2016-01-27
rsyslog (8.16.0-1) unstable; urgency=medium

  * New upstream release.
  * Rebase patches.
  * Enable more hardening flags via DEB_BUILD_MAINT_OPTIONS = hardening=+all.

 -- Michael Biebl <email address hidden>  Wed, 27 Jan 2016 19:59:20 +0100
Published in jessie-release on 2016-01-23
rsyslog (8.4.2-1+deb8u2) jessie; urgency=medium

  * Fix crash in imfile module when using inotify mode.
    Patch cherry-picked from upstream Git. (Closes: #770998)
  * Prevent a segfault in dynafile creation.
    Patch cherry-picked from upstream Git. (Closes: #807908)

 -- Michael Biebl <email address hidden>  Mon, 14 Dec 2015 13:34:01 +0100
Superseded in stretch-release on 2016-02-02
Superseded in sid-release on 2016-01-29
rsyslog (8.15.0-1) unstable; urgency=medium

  * New upstream release.
  * Drop debian/patches/Skip-broken-mmnormalize-tests.patch, fixed upstream.
  * Add tests which are missing in the dist tarball and which are required to
    run the test suite.

 -- Michael Biebl <email address hidden>  Sun, 20 Dec 2015 17:36:00 +0100
Superseded in stretch-release on 2015-12-28
Superseded in sid-release on 2015-12-28
rsyslog (8.14.0-2) unstable; urgency=medium

  * Remove logging to /dev/xconsole from the default rsyslog configuration.
    It is a rarely used feature and causes rsyslog to repeatedly retry if
    there is noone reading from /dev/xconsole. Instead ship the configuration
    as example files and add instructions to README.Debian how one can
    re-enable support for xconsole. (Closes: #745492, #783687)
  * Remove section about sysklogd from README.Debian, sysklogd is not really
    relevant anymore nowadays.
  * Ship an example file for logging to the console on tty8 which can be
    dropped into /etc/rsyslog.d instead of having it as comment in
    /etc/rsyslog.conf.

 -- Michael Biebl <email address hidden>  Thu, 12 Nov 2015 22:11:11 +0100
Superseded in sid-release on 2015-11-13
rsyslog (8.14.0-1) unstable; urgency=medium

  * New upstream release.
  * Rebase patches.

 -- Michael Biebl <email address hidden>  Sat, 07 Nov 2015 20:23:05 +0100
Superseded in stretch-release on 2015-11-18
Superseded in sid-release on 2015-11-13
rsyslog (8.13.0-1) unstable; urgency=medium

  * New upstream release.
  * Bump Build-Depends on liblognorm-dev to (>= 1.1.2) as per configure.ac.
  * Rebase patches.
  * Skip tests which are currently broken by the liblognorm update. According
    to upstream those failing tests point at a bug in liblognorm, not rsyslog
    itself. (Closes: #800873)

 -- Michael Biebl <email address hidden>  Sun, 25 Oct 2015 22:14:41 +0100
Superseded in stretch-release on 2015-10-31
Superseded in sid-release on 2015-10-26
rsyslog (8.12.0-3) unstable; urgency=medium

  [ Louis Bouchard ]
  * Fix FTBFS on various architectures caused by a buffer overflow in tcpflood
    when running the test suite.

 -- Michael Biebl <email address hidden>  Wed, 16 Sep 2015 18:09:49 +0200
Superseded in sid-release on 2015-09-16
rsyslog (8.12.0-2) unstable; urgency=medium

  [ Michael Biebl ]
  * Drop versioned Depends on initscripts. This dependency was added for the
    /run transition in wheezy and is no longer required.

  [ Luca Boccassi ]
  * Enable CZMQ plugins. (Closes: #798223)
  * Fix NULL pointer dereference in imczmq and omczmq.

 -- Michael Biebl <email address hidden>  Tue, 15 Sep 2015 19:43:12 +0200
Superseded in jessie-release on 2016-01-23
rsyslog (8.4.2-1+deb8u1) jessie; urgency=medium

  * Disable transactions in ompgsql as they were not working properly.
    Patch cherry-picked from upstream Git. (Closes: #788183)

 -- Michael Biebl <email address hidden>  Sat, 29 Aug 2015 13:52:34 +0200
Superseded in stretch-release on 2015-09-22
Superseded in sid-release on 2015-09-16
rsyslog (8.12.0-1) unstable; urgency=medium

  * New upstream release.
  * Refresh patches.

 -- Michael Biebl <email address hidden>  Sun, 16 Aug 2015 18:45:59 +0200
Superseded in stretch-release on 2015-08-31
Superseded in sid-release on 2015-08-27
rsyslog (8.11.0-2) unstable; urgency=medium

  * Properly handle transactions in ompgsql. Patch cherry-picked from upstream
    Git. (Closes: #788183)

 -- Michael Biebl <email address hidden>  Wed, 15 Jul 2015 02:49:48 +0200
Superseded in sid-release on 2015-07-24
rsyslog (8.11.0-1) unstable; urgency=medium

  * New upstream release.

 -- Michael Biebl <email address hidden>  Tue, 30 Jun 2015 17:57:45 +0200
Superseded in stretch-release on 2015-07-24
Superseded in sid-release on 2015-07-27
rsyslog (8.9.0-3) unstable; urgency=medium

  * Upload to unstable.

 -- Michael Biebl <email address hidden>  Mon, 11 May 2015 23:13:31 +0200
Deleted in experimental-release (Reason: None provided.)
rsyslog (8.9.0-2) experimental; urgency=medium

  [ Marc Fournier ]
  * Build omkafka module which provides support for publishing log messages to
    Apache Kafka. Split that module into a separate package called
    rsyslog-kafka. (Closes: #780365)

 -- Michael Biebl <email address hidden>  Thu, 09 Apr 2015 15:34:25 +0200
Deleted in experimental-release (Reason: None provided.)
rsyslog (8.9.0-1) experimental; urgency=medium


  * New upstream release.
  * Update gbp.conf to not use patch numbers to reduce the patch noise created
    by gbp-pq.
  * Rebase patches.
  * Drop obsolete section about compatibility levels from README.Debian.
  * Start modernizing rsyslog.conf and use the new style syntax.
  * Add virtual-mysql-client and virtual-mysql-server as alternatives to
    mysql-client and mysql-server. (Closes: #781972)

 -- Michael Biebl <email address hidden>  Tue, 07 Apr 2015 22:14:07 +0200
Superseded in experimental-release on 2015-05-08
rsyslog (8.8.0-4) experimental; urgency=medium


  * Cherry-pick upstream patch which is supposed to fix $MaxMessageSize on
    various architectures.

 -- Michael Biebl <email address hidden>  Wed, 25 Mar 2015 17:33:26 +0100
Superseded in experimental-release on 2015-05-10
rsyslog (8.8.0-3) experimental; urgency=medium


  * Dump test-suite.log to stdout if test suite fails.

 -- Michael Biebl <email address hidden>  Wed, 11 Mar 2015 12:28:31 +0100
Superseded in experimental-release on 2015-03-11
rsyslog (8.8.0-2) experimental; urgency=medium


  * Enable and run test suite during build.
  * Add files from upstream Git repository which are missing in the dist
    tarball and are necessary to run the test suite.
  * Don't link tcpflood test binary against -lgcrypt. It's not necessary with
    current versions of GnuTLS.

 -- Michael Biebl <email address hidden>  Tue, 10 Mar 2015 23:09:59 +0100
Deleted in experimental-release (Reason: None provided.)
rsyslog (8.8.0-1) experimental; urgency=medium


  * New upstream release.
  * Bump Build-Depends on liblognorm-dev to (>= 1.0.2).
  * Explicitly enable liblogging-stdlog feature, which is now optional.
  * Remove obsolete --enable-pmrfc3164sd configure switch. This module has
    been removed by upstream.
  * Enable support for reading from and writing to the systemd journal
    directly via the imjournal and omjournal module.
    The default rsyslog configuration still uses the imuxsock module though,
    which receives the syslog messages via a socket that is passed from
    systemd to rsyslog.

 -- Michael Biebl <email address hidden>  Mon, 09 Mar 2015 22:18:14 +0100
Superseded in experimental-release on 2015-03-10
rsyslog (8.6.0-1) experimental; urgency=medium


  * New upstream release.
  * Update Vcs-Browser URL to use cgit and https.
  * Bump Standards-Version to 3.9.6. No further changes.

 -- Michael Biebl <email address hidden>  Thu, 29 Jan 2015 02:02:29 +0100
Published in wheezy-release on 2014-10-18
rsyslog (5.8.11-3+deb7u2) wheezy-security; urgency=high


  * debian/patches/05-pri-vulnerability-fix.patch:
    - CVE-2014-3683: Followup fix for CVE-2014-3634. The initial patch was
      incomplete. It did not cover cases where PRI values > MAX_INT caused
      integer overflows resulting in negative values.

 -- Michael Biebl <email address hidden>  Tue, 07 Oct 2014 23:30:24 +0200
Superseded in stretch-release on 2015-05-17
Superseded in jessie-release on 2015-09-05
Published in sid-release on 2014-10-02
rsyslog (8.4.2-1) unstable; urgency=high


  * New upstream release.
    - CVE-2014-3683: The fix for CVE-2014-3634 incomplete. It did not cover
      cases where PRI values > MAX_INT caused integer overflows resulting in
      negative values.
  * Urgency high for the security fix.

 -- Michael Biebl <email address hidden>  Thu, 02 Oct 2014 15:27:25 +0200
Superseded in sid-release on 2014-10-02
rsyslog (8.4.1-1) unstable; urgency=high


  * New upstream release.
   - CVE-2014-3634: Fix remote syslog vulnerability due to improper
     handling of invalid PRI values.
  * Drop patches which have been merged upstream.
  * Urgency high for the security fix.

 -- Michael Biebl <email address hidden>  Tue, 30 Sep 2014 12:35:33 +0200
Superseded in jessie-release on 2014-10-05
Superseded in sid-release on 2014-10-01
rsyslog (8.4.0-2) unstable; urgency=medium


  * Tweak rsyslog systemd service file. Add Documentation field and restart
    the rsyslogd daemon on failures.
  * Cherry-pick upstream patch to fix build failures on platforms without
    atomic instructions.

 -- Michael Biebl <email address hidden>  Wed, 20 Aug 2014 19:36:33 +0200
Superseded in sid-release on 2014-08-21
rsyslog (8.4.0-1) unstable; urgency=medium


  * New upstream release.
  * Update patches:
    - Refresh 0001-Don-t-create-a-database.patch.
    - Drop 0002-Fix-pidfile-location.patch, merged upstream.
  * Add --disable-generate-man-pages to configure flags to avoid a build
    dependency on python-docutils. We don't ship the generated man pages
    anyway.
  * Add support for external message modification modules which are bound via
    the new native mmexternal module.

 -- Michael Biebl <email address hidden>  Mon, 18 Aug 2014 18:28:20 +0200
Superseded in sid-release on 2014-08-21
rsyslog (8.2.2-5) unstable; urgency=medium


  * Make sure to actually only create the temporary syslog.service symlink on
    upgrades and avoid the usage of readlink.

 -- Michael Biebl <email address hidden>  Mon, 18 Aug 2014 02:43:31 +0200
Superseded in sid-release on 2014-08-18
rsyslog (8.2.2-4) unstable; urgency=medium


  * Fix wheezy → jessie upgrade failure when running under systemd due to the
    syslog.service symlink temporarily being missing.

 -- Michael Biebl <email address hidden>  Mon, 18 Aug 2014 00:39:03 +0200
Superseded in jessie-release on 2014-08-26
Superseded in sid-release on 2014-08-18
rsyslog (8.2.2-3) unstable; urgency=low


  * Upload to unstable.

 -- Michael Biebl <email address hidden>  Sun, 29 Jun 2014 14:40:56 +0200
Superseded in jessie-release on 2014-08-05
Superseded in sid-release on 2014-06-30
rsyslog (7.6.3-3) unstable; urgency=medium


  * Build against libgnutls28-dev. (Closes: #752304)
  * Use canonical URIs for Vcs-* fields.

 -- Michael Biebl <email address hidden>  Mon, 23 Jun 2014 13:44:55 +0200
Deleted in experimental-release (Reason: None provided.)
rsyslog (8.2.2-2) experimental; urgency=medium


  * Merge changes from unstable branch.

 -- Michael Biebl <email address hidden>  Mon, 23 Jun 2014 13:52:12 +0200
Superseded in experimental-release on 2014-06-24
rsyslog (8.2.2-1) experimental; urgency=medium


  * New major upstream release.
    - Rewritten core engine providing higher performance and better
      scalability with complex configurations.
    - Simplified script execution.
    - Global variable support.
    - Output part was revamped completely and required changes to all output
      modules.
    - Support for external plugins which can be written in any language.
  * Switch watch file to track v8 stable branch.
  * Update Build-Depends:
    - Bump librelp-dev to (>= 1.2.5).
    - Bump liblogging-stdlog-dev to (>= 1.0.3).
    - Bump liblognorm-dev to (>= 1.0.0).
    - Drop libee-dev.
  * Drop the omruleset module which has been deprecated and replaced by the
    much more efficient RainerScript "call" statement.
  * Remove the rsyslog-doc package which is now built from a separate source
    package.
  * Fix pidfile location. The pidfile should be stored in /var/run, not /etc.

 -- Michael Biebl <email address hidden>  Mon, 09 Jun 2014 21:16:19 +0200
Superseded in jessie-release on 2014-06-29
Superseded in sid-release on 2014-06-23
rsyslog (7.6.3-2) unstable; urgency=medium


  * Update Build-Depends:
    - Bump librelp-dev to (>= 1.2.5).
  * Build omelasticsearch module which provides support for logging to an
    Elasticsearch server. Split that module into a separate package called
    rsyslog-elasticsearch. (Closes: #744951)

 -- Michael Biebl <email address hidden>  Fri, 16 May 2014 22:37:05 +0200
Superseded in jessie-release on 2014-05-23
Superseded in sid-release on 2014-05-22
rsyslog (7.6.3-1) unstable; urgency=medium


  * New upstream release.
    - Fixes ompipe to properly handle retries and not cause unnecessary
      suspension messages. (Closes: #742113)
  * Update watch file, track v7 stable branch.

 -- Michael Biebl <email address hidden>  Fri, 28 Mar 2014 12:36:45 +0100
Superseded in sid-release on 2014-03-28
rsyslog (7.6.2-1) unstable; urgency=medium


  * New upstream release.
  * Update patches.
  * Update Build-Depends:
    - Bump librelp-dev to (>= 1.2.4).
    - Add liblogging-stdlog-dev (>= 1.0.1).
  * Fix typo in rsyslog.postrm: dissappear → disappear
  * Drop useless "exit 0" from maintainer scripts.
  * Enable and install the mmutf8fix, mmpstrucdata and mmsequence message
    modification modules.
  * Stop installing debian/sample.conf. Upstream ships a more up-to-date
    example configuration file.

 -- Michael Biebl <email address hidden>  Mon, 17 Mar 2014 17:26:08 +0100
Superseded in jessie-release on 2014-04-03
Superseded in sid-release on 2014-03-18
rsyslog (7.4.8-1) unstable; urgency=medium


  [ Michael Biebl ]
  * New upstream release.
  * Update Build-Depends:
    - Bump libestr-dev to (>= 0.1.9).
    - Tighten liblognorm-dev to (<< 1.0.0).
    - Replace libjson0-dev with libjson-c-dev, we no longer need the
      transitional package.
  * Bump Standards-Version to 3.9.5. No further changes.

  [ Daniel Pocock ]
  * Make template parameter not mandatory in mongodb output plugin. Patch
    cherry-picked from upstream Git. (Closes: #740869, #721277)
  * Ensure JSON templates are NUL terminated. Patch cherry-picked from
    upstream Git.

 -- Michael Biebl <email address hidden>  Tue, 11 Mar 2014 19:52:49 +0100
Superseded in jessie-release on 2014-03-17
Superseded in sid-release on 2014-03-12
rsyslog (7.4.4-1) unstable; urgency=low


  * New upstream release.

 -- Michael Biebl <email address hidden>  Tue, 03 Sep 2013 22:42:49 +0200
Superseded in jessie-release on 2013-09-15
Superseded in sid-release on 2013-09-06
rsyslog (7.4.3-1) unstable; urgency=low


  * New upstream release.

 -- Michael Biebl <email address hidden>  Tue, 23 Jul 2013 01:01:40 +0200
Superseded in jessie-release on 2013-08-02
Superseded in sid-release on 2013-07-24
rsyslog (7.4.2-1) unstable; urgency=low


  * New upstream release.

 -- Michael Biebl <email address hidden>  Sat, 06 Jul 2013 00:14:19 +0200
Superseded in sid-release on 2013-07-06
rsyslog (7.4.1-3) unstable; urgency=low


  * Bump Build-Depends on dh-systemd to (>= 1.4) to ensure we have a recent
    enough version of init-system-helpers which properly deals with a missing
    state directory. (Closes: #714265)

 -- Michael Biebl <email address hidden>  Thu, 27 Jun 2013 19:21:04 +0200
Superseded in sid-release on 2013-06-28
rsyslog (7.4.1-2) unstable; urgency=low


  * Use dh-systemd to setup the systemd service properly.

 -- Michael Biebl <email address hidden>  Wed, 26 Jun 2013 21:13:33 +0200
Superseded in sid-release on 2013-06-27
rsyslog (7.4.1-1) unstable; urgency=low


  * New upstream release.

 -- Michael Biebl <email address hidden>  Mon, 17 Jun 2013 23:38:51 +0200
Superseded in jessie-release on 2013-07-16
Superseded in sid-release on 2013-06-18
rsyslog (7.4.0-1) unstable; urgency=low


  * New upstream release.

 -- Michael Biebl <email address hidden>  Thu, 06 Jun 2013 18:51:11 +0200
Superseded in jessie-release on 2013-06-17
Superseded in sid-release on 2013-06-09
rsyslog (7.3.15-1) unstable; urgency=low


  * New upstream release.

 -- Michael Biebl <email address hidden>  Wed, 15 May 2013 18:21:02 +0200
Superseded in sid-release on 2013-05-16
rsyslog (7.3.14-2) unstable; urgency=low


  * Upload to unstable.

 -- Michael Biebl <email address hidden>  Fri, 10 May 2013 01:41:23 +0200
Deleted in experimental-release (Reason: None provided.)
rsyslog (7.3.14-1) experimental; urgency=low


  * New upstream release.
  * Remove 02-fix-non-libgcrypt-build.patch, merged upstream.

 -- Michael Biebl <email address hidden>  Mon, 06 May 2013 23:44:17 +0200
Deleted in experimental-release (Reason: None provided.)
rsyslog (7.3.12-3) experimental; urgency=low


  * Only build and install the imkmsg module on Linux.

 -- Michael Biebl <email address hidden>  Fri, 26 Apr 2013 16:46:19 +0200
Superseded in experimental-release on 2013-04-27
rsyslog (7.3.12-2) experimental; urgency=low


  * Fix build when libgcrypt support is disabled to not pick up an unnecessary
    libgcrypt dependency.

 -- Michael Biebl <email address hidden>  Thu, 25 Apr 2013 23:44:03 +0200
Superseded in experimental-release on 2013-04-26
rsyslog (7.3.12-1) experimental; urgency=low


  * New upstream release.
  * Disable log file encryption support for now.

 -- Michael Biebl <email address hidden>  Thu, 25 Apr 2013 15:14:37 +0200
Deleted in experimental-release (Reason: None provided.)
rsyslog (7.3.10-1) experimental; urgency=low


  * New upstream release.
  * Bump Build-Depends on librelp-dev to (>= 1.0.3).

 -- Michael Biebl <email address hidden>  Wed, 10 Apr 2013 12:31:15 +0200
Superseded in experimental-release on 2013-04-16
rsyslog (7.3.9-1) experimental; urgency=low


  * New upstream release.
  * Remove patches which have been applied upstream.
  * Bump Build-Depends on libestr-dev to (>= 0.1.5).

 -- Michael Biebl <email address hidden>  Wed, 27 Mar 2013 13:14:44 +0100
Superseded in experimental-release on 2013-03-28
rsyslog (7.3.8-4) experimental; urgency=low


  * Add Build-Depends on bison so we can build twice in a row. "make clean"
    removes the generated grammar/grammer.[ch].
  * Another patch to fix build failures on architectures where prctl is not
    available. (Closes: #703429)

 -- Michael Biebl <email address hidden>  Thu, 21 Mar 2013 16:45:17 +0100
Superseded in experimental-release on 2013-03-22
rsyslog (7.3.8-3) experimental; urgency=low


  * The previous fix was incomplete. Cherry-pick another upstream patch to fix
    the build failure on non-Linux. (Closes: #703429)

 -- Michael Biebl <email address hidden>  Wed, 20 Mar 2013 11:44:10 +0100
Superseded in experimental-release on 2013-03-22
rsyslog (7.3.8-2) experimental; urgency=low


  * Cherry pick patch from upstream which fixes the build on architectures
    which don't have SYS_gettid. (Closes: #703429)

 -- Michael Biebl <email address hidden>  Tue, 19 Mar 2013 16:40:58 +0100
Superseded in experimental-release on 2013-03-20
rsyslog (7.3.8-1) experimental; urgency=low


  * New upstream development release from the v7-devel branch.
  * Update watch file to track development releases.
  * The imrelp module now properly supports listening on IPv4 resp. IPv6 only.
    This requires librelp >= 1.0.2, so bump the Build-Depends accordingly.
    (Closes: #649355)
  * Enable the mmanon module which adds support for anonymizing IPv4
    addresses.

 -- Michael Biebl <email address hidden>  Mon, 18 Mar 2013 16:21:35 +0100
Superseded in jessie-release on 2013-05-26
Superseded in wheezy-release on 2014-10-18
Superseded in sid-release on 2013-05-11
rsyslog (5.8.11-3) unstable; urgency=low


  * debian/patches/04-systemd_journal.patch: The journal has replaced
    systemd-kmsg-syslogd and systemd-stdout-bridge. Stopping a non-existing
    service will generate an error in newer versions of systemd, so remove
    that from ExecStartPre.

 -- Michael Biebl <email address hidden>  Tue, 05 Mar 2013 23:06:57 +0100
Superseded in experimental-release on 2013-03-21
rsyslog (7.2.6-1) experimental; urgency=low


  * New upstream release.
  * Bump Standards-Version to 3.9.4. No further changes.

 -- Michael Biebl <email address hidden>  Tue, 05 Mar 2013 17:36:18 +0100
Superseded in experimental-release on 2013-03-06
rsyslog (7.2.5-1) experimental; urgency=low


  * New upstream release.

 -- Michael Biebl <email address hidden>  Wed, 09 Jan 2013 00:04:39 +0100
Superseded in experimental-release on 2013-01-10
rsyslog (7.2.4-1) experimental; urgency=low


  * New upstream release.

 -- Michael Biebl <email address hidden>  Fri, 07 Dec 2012 16:01:00 +0100
175 of 125 results