Debian GNU/Linux

Change logs for “alex” source package in Squeeze

  • alex (2.3.3-1) unstable; urgency=low
    
    
      [ Erik de Castro Lopo ]
      * New upstream version.
    
      [ Joachim Breitner ]
      * Source format 3.0 (quilt)
    
     -- Erik de Castro Lopo <email address hidden>  Wed, 31 Mar 2010 21:10:35 +1100
  • alex (2.3.2-1) unstable; urgency=low
    
    
      * New upstream version.
    
     -- Erik de Castro Lopo <email address hidden>  Fri, 12 Mar 2010 20:25:20 +1100
  • alex (2.3.1-3) unstable; urgency=low
    
    
      * debian/control: Change Priority: to extra.
      * debian/watch: Use format that works for --download-current-version.
      * debian/watch: Add .tar.gz to downloaded filename.
      * debian/watch: Include package name in downloaded .tar.gz.
      * debian/watch: Remove spaces, since they're not allowed by uscan.
      * debian/control: Use Vcs-Browser: field.
      * debian/control: Bump Standards-Version: to 3.8.4, no changes needed.
      * debian/control: Bump version of Build-Depends: on haskell-devscripts
        to 0.7 and remove versioned Build-Depends: on ghc6.
    
     -- Marco Túlio Gontijo e Silva <email address hidden>  Sun, 21 Feb 2010 09:30:03 -0300
  • alex (2.2-0.2) unstable; urgency=low
    
    
      * Non-maintainer upload.
      * Fix "FTBFS: Not in scope: `buildVerbose'", thanks to Matt Kraai for the
        patch (Closes: #516277)
    
     -- Joachim Breitner <email address hidden>  Wed, 18 Mar 2009 19:01:37 +0100
  • alex (2.2-0.1) unstable; urgency=low
    
    
      * Non-maintainer upload.
      * New upstream release (Closes: #464360)
        - Cabal 1.2 is now required. (Closes: #460388)
        - ByteString wrappers: use Alex to lex ByteStrings directly.
        - Fixes a spelling mistake. (Closes: #419671)
      * debian/control:
        - Added Homepage field.
        - Bump the build dependency on ghc6 to 6.8.2 as the packages needs
          Cabal 1.2 to build.
        - Bump the Standards-Version to 3.7.3. No changes needed.
      * debian/copyright:
        - Fix debian-copyright-file-uses-obsolete-national-encoding lintian
          warning.
        - Update debian/copyright file with info from upstream LICENSE file.
      * debian/get_version.hs: Updated for Cabal 1.2
      * debian/rules: 
        - Fix debian-rules-ignores-make-clean-error lintian warning.
        - Remove the LICENSE installed by ./setup copy
      * Add debian/watch file.
    
     -- Arjan Oosting <email address hidden>  Sun, 27 Apr 2008 15:31:08 +0200