apparmor 2.11.0-2ubuntu1 source package in Ubuntu

Changelog

apparmor (2.11.0-2ubuntu1) zesty; urgency=medium

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - debian/apparmor.init: Call handle_system_policy_package_updates as we
      need it for Click, snappy, and system-images. Note that this prevents
      using a remote /var.
    - debian/patches/series: Apply
      profiles-grant-access-to-systemd-resolved.patch
    - debian/patches/series: Apply add-chromium-browser.patch
    - debian/apparmor-profiles.install, debian/apparmor-profiles.postinst:
      Install chromium-browser profile and abstraction
  * Drop the following change:
    - debian/rules: Create a new empty file, needed for the test added by this
      patch, since quilt is unable to do so.
      + This is no longer required since the empty file is now distributed as
        part of the upstream tar.
  * debian/patches/r3615-profiles-sshd-drop-local-include.patch: Drop the
    local includes in the sshd profile since it causes a parser error due to
    the missing includes file
  * debian/patches/utils-fix-failing-tests-in-aa-py.patch: Adjust expected
    output to account for the base abstraction changes to accommodate the /usr
    merge
  * debian/patches/utils-allow-unordered-dbus-attribs.patch: Don't
    unnecessarily enforce attribute ordering in D-Bus rules (LP: #1628286)

apparmor (2.11.0-2) unstable; urgency=medium

  * Drop the apparmor-docs package (Closes: #851118).

apparmor (2.11.0-1) unstable; urgency=medium

  * Import upstream 2.11.0 release (Closes: #809649).
  * Don't try to install non-existing file
    to /etc/apparmor.d/abstractions/ubuntu-browsers.d/chromium-browser.
  * Drop all backported patches, that are now obsolete.
  * Drop aa-utils_are_bilingual.patch, that is obsolete since upstream
    switched to Python 3.
  * Refresh all remaining quilt patches.
  * debian/apparmor.manpages: follow upstream wrt. moving the manpages
    for aa-enabled and aa-exec to section 1.
  * Reintroduce building parser/techdoc.pdf from source while building
    the binary package.
  * Build PDFs from documentation/*, and include them in the apparmor-docs
    package. Accordingly add build-dependency on libreoffice-writer and unoconv.
  * README.source: document how to import a new upstream release from
    the tarball.

apparmor (2.10.95-8) unstable; urgency=medium

  * Stop applying add-chromium-browser.patch: it's been broken for years
    on Debian, and nobody ever bothered to upstream this profile in a way
    that makes it work cross-distro (Closes: #742829).
  * r3441-sshd-blacklist.patch: new patch, cherry-picked from upstream
    (Closes: #821881).
  * r3497-add-ld.so.preload-to-abstractions-base.patch: new patch,
    cherry-picked from upstream.
  * r3600-usrmerge.patch: new patch, cherry-picked from upstream
    (resolves the parts of #843461 that can be handled in this package).

apparmor (2.10.95-7) unstable; urgency=medium

  * r3582-build-with-recent-swig.patch: new patch, cherry-picked
    from upstream (Closes: #844929).
  * r3588-update-gnome-abstraction-with-versioned-gtk-paths.patch:
    new patch, cherry-picked from upstream (Closes: #845005).
  * r3590-add-more-wayland-paths.patch: new patch, cherry-picked from upstream.
  * r3591-yet-another-location-for-Xauthority.patch: new patch, cherry-picked
    from upstream (Closes: #845250).
  * Merge from Ubuntu citrain up to revision 1604.
  * Disable profiles-grant-access-to-systemd-resolved.patch: it's dangerous
    without fine-grained AppArmor mediation of D-Bus traffic.

apparmor (2.10.95-6) unstable; urgency=medium

  * New patches, cherry-picked from upstream:
    - debian/patches/r3577-gnome-abstraction-gtk3-config.patch:
      gnome abstraction: grant read access to ~/.config/gtk-3.0/*.
    - debian/patches/r3578-dnsmasq-libvirt_leaseshelper.patch:
      dnsmasq: allow libvirt_leaseshelper "m" permission on itself.

apparmor (2.10.95-5) unstable; urgency=medium

  * Merge from ubuntu-citrain up to revision 1600. Remaining Debian changes:
    - debian/apparmor.init: don't call handle_system_policy_package_updates.
  * r3566-wayland.patch: new patch, to support Wayland in at least Evince
    (Closes: #827335).
  * r3487-add-firefox-esr-to-ubuntu-browsers.patch: new patch, to support
    firefox-esr in abstractions/ubuntu-browsers (Closes: #821945).
  * Drop "Replaces: apparmor-parser": that package has never been part of
    Debian, and if has ever been included in Ubuntu, that must have been
    ages ago.
  * Drop Breaks: lxc (<< 1.1.0~alpha1-0ubuntu5~).
    - Wrt. Ubuntu: Xenial ships a newer lxc.
    - Wrt. Debian: this Breaks was added in Ubuntu in order to "restrict
      signal, ptrace and unix mediation to the container" (LP: #1373555).
      These features require third-party Linux kernel patches, that we
      haven't in Debian, so even though Jessie has lxc 1.0, we don't need
      this Breaks relationship.
  * Drop Breaks: lightdm (<< 1.11.8-0ubuntu2~).
    - Wrt. Debian: it was added in Ubuntu because lightdm 1.11.8-0ubuntu2
      brings "updates for unix socket mediation". But Unix socket mediation
      requires third-party Linux kernel patches, that we haven't in Debian.
    - Wrt. Ubuntu: even Vivid includes a newer lightdm.
  * Drop Breaks+Replaces on a version of debhelper older than the one included
    in Precise and Wheezy.
  * Drop Breaks+Replaces on versions of our own binary packages that are older
    than the ones included in Jessie and Xenial.
  * Drop Breaks: rsyslog (<< 7.4.4-1ubuntu9~). Bot Jessie and Xenial ship
    a newer one.
  * Drop Breaks: apparmor-easyprof-ubuntu (<< 1.2.22). Xenial ships
    a newer one.
  * Drop Breaks: libvirt-bin (<< 1.2.6-0ubuntu6~). Jessie and Xenial
    have a newer one.
  * Drop Breaks+Replaces: apparmor-utils << 2.8.0: Jessie and Trusty ship
    a newer one.
  * Drop Breaks+Replaces: libapache2-mod-apparmor (<< 2.5.1-0ubuntu3):
    Precise and Wheezy shipped with something newer.
  * Version dependency on lsb-base to >= 3.0-6, as advised by Lintian's
    init.d-script-needs-depends-on-lsb-base tag.

apparmor (2.10.95-4ubuntu6) UNRELEASED; urgency=medium

  * debian/patches/r3556-drop-CMD_CONTINUE.patch: Fix test failure in utils/
    that is caught by newer versions pyflakes. The test failure was caused by
    CMD_CONTINUE being defined twice.

 -- Tyler Hicks <email address hidden>  Thu, 09 Feb 2017 06:57:45 +0000

Upload details

Uploaded by:
Tyler Hicks on 2017-02-09
Uploaded to:
Zesty
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
admin
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
apparmor_2.11.0.orig.tar.gz 4.8 MiB b1c489ea11e7771b8e6b181532cafbf9ebe6603e3cb00e2558f21b7a5bdd739a
apparmor_2.11.0-2ubuntu1.debian.tar.xz 81.4 KiB 2fa40498fc2fe0df54a2953c8185ab529d02f86cb8418b5f089b06d38864b9f7
apparmor_2.11.0-2ubuntu1.dsc 3.1 KiB f8580d2deefb42e9988d85d6356e3e305027a9111d96fbe5dd73a70072c42424

View changes file

Binary packages built by this source

apparmor: No summary available for apparmor in ubuntu zesty.

No description available for apparmor in ubuntu zesty.

apparmor-dbgsym: No summary available for apparmor-dbgsym in ubuntu zesty.

No description available for apparmor-dbgsym in ubuntu zesty.

apparmor-easyprof: No summary available for apparmor-easyprof in ubuntu zesty.

No description available for apparmor-easyprof in ubuntu zesty.

apparmor-notify: No summary available for apparmor-notify in ubuntu zesty.

No description available for apparmor-notify in ubuntu zesty.

apparmor-profiles: No summary available for apparmor-profiles in ubuntu zesty.

No description available for apparmor-profiles in ubuntu zesty.

apparmor-utils: No summary available for apparmor-utils in ubuntu zesty.

No description available for apparmor-utils in ubuntu zesty.

dh-apparmor: No summary available for dh-apparmor in ubuntu zesty.

No description available for dh-apparmor in ubuntu zesty.

libapache2-mod-apparmor: No summary available for libapache2-mod-apparmor in ubuntu zesty.

No description available for libapache2-mod-apparmor in ubuntu zesty.

libapache2-mod-apparmor-dbgsym: No summary available for libapache2-mod-apparmor-dbgsym in ubuntu zesty.

No description available for libapache2-mod-apparmor-dbgsym in ubuntu zesty.

libapparmor-dev: No summary available for libapparmor-dev in ubuntu zesty.

No description available for libapparmor-dev in ubuntu zesty.

libapparmor-perl: No summary available for libapparmor-perl in ubuntu zesty.

No description available for libapparmor-perl in ubuntu zesty.

libapparmor-perl-dbgsym: No summary available for libapparmor-perl-dbgsym in ubuntu zesty.

No description available for libapparmor-perl-dbgsym in ubuntu zesty.

libapparmor1: No summary available for libapparmor1 in ubuntu zesty.

No description available for libapparmor1 in ubuntu zesty.

libapparmor1-dbgsym: No summary available for libapparmor1-dbgsym in ubuntu zesty.

No description available for libapparmor1-dbgsym in ubuntu zesty.

libpam-apparmor: No summary available for libpam-apparmor in ubuntu zesty.

No description available for libpam-apparmor in ubuntu zesty.

libpam-apparmor-dbgsym: No summary available for libpam-apparmor-dbgsym in ubuntu zesty.

No description available for libpam-apparmor-dbgsym in ubuntu zesty.

python-apparmor: No summary available for python-apparmor in ubuntu zesty.

No description available for python-apparmor in ubuntu zesty.

python-libapparmor: No summary available for python-libapparmor in ubuntu zesty.

No description available for python-libapparmor in ubuntu zesty.

python3-apparmor: No summary available for python3-apparmor in ubuntu zesty.

No description available for python3-apparmor in ubuntu zesty.

python3-libapparmor: No summary available for python3-libapparmor in ubuntu zesty.

No description available for python3-libapparmor in ubuntu zesty.