Change log for bcel package in Ubuntu

125 of 25 results
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-01-17
Deleted in bionic-proposed (Reason: moved to release)
bcel (6.2-1) unstable; urgency=medium

  * Team upload.
  * New upstream version 6.2.
  * Use compat level 11.
  * Declare compliance with Debian Policy 4.1.3.

 -- Markus Koschany <email address hidden>  Wed, 17 Jan 2018 00:05:34 +0100

Available diffs

Superseded in bionic-release on 2018-01-17
Deleted in bionic-proposed on 2018-01-18 (Reason: moved to release)
bcel (6.1-1) unstable; urgency=medium

  * Team upload.
  * New upstream version 6.1
  * Switch to compat level 10.
  * Declare compliance with Debian Policy 4.1.1.
  * Use https for Format field.

 -- Markus Koschany <email address hidden>  Tue, 17 Oct 2017 23:34:56 +0200

Available diffs

Superseded in bionic-release on 2017-11-02
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
bcel (6.0-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - New build dependencies on libcommons-lang3-java and libjna-platform-java
  * Relocated the org.apache.bcel:bcel:5.x artifact
    to org.apache.bcel:bcel:debian
  * Enabled the OSGi metadata
  * Build with the DH sequencer instead of CDBS
  * Standards-Version updated to 3.9.8
  * Use secure Vcs-* URLs

 -- Emmanuel Bourg <email address hidden>  Fri, 15 Jul 2016 01:07:32 +0200
Superseded in yakkety-release on 2016-07-15
Published in xenial-release on 2016-04-08
Superseded in xenial-release on 2016-04-08
Deleted in xenial-proposed (Reason: moved to release)
bcel (6.0~rc3-2ubuntu1) xenial; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Switch to using maven-ant-helper for build, avoiding inclusion
      of Maven in Ubuntu main.

Superseded in xenial-release on 2016-03-07
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
bcel (6.0~rc3-1ubuntu1) vivid; urgency=medium

  * Switch to using maven-ant-helper for build, avoiding inclusion
    of Maven in Ubuntu main.
 -- James Page <email address hidden>   Tue, 27 Jan 2015 13:35:22 +0000
Superseded in vivid-proposed on 2015-01-27
bcel (6.0~rc3-1) unstable; urgency=medium


  * New upstream release supporting the Java 8 features (Closes: #448868)
  * Build with maven-debian-helper
  * Removed the patches
  * Link /usr/share/ant/lib/bcel.jar to the versionless jar in /usr/share/java
  * Standards-Version updated to 3.9.6 (no changes)
  * Moved the package to Git
  * debian/watch: Updated to watch the release tags on Github

 -- Emmanuel Bourg <email address hidden>  Fri, 24 Oct 2014 16:03:26 +0200
Superseded in vivid-release on 2015-01-27
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
bcel (5.2-10) unstable; urgency=medium


  * Removed the duplicate API documentation in libbcel-java-doc
  * debian/control:
    - Standards-Version updated to 3.9.5 (no changes)
    - Removed Michael Koch from the uploaders (Closes: #653995)
    - Use a canonical URL for the Vcs-Svn field
    - Updated the Homepage field
  * Switch to debhelper level 9
  * debian/copyright: Updated to the Copyright Format 1.0

 -- Emmanuel Bourg <email address hidden>  Wed, 23 Apr 2014 23:31:05 +0200
Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
bcel (5.2-9build1) quantal; urgency=low

  * No-change rebuild with openjdk-7 as default-jdk.
 -- James Page <email address hidden>   Fri, 18 May 2012 11:34:50 +0100

Available diffs

Superseded in quantal-release on 2012-05-18
Published in precise-release on 2012-02-09
bcel (5.2-9) unstable; urgency=low


  * Team upload.

  [Ludovic Claude]
  * Add version constraint on newer maven-repo-helper
  * d/rules: use mh_install instead of mh_installpoms + mh_installjar
  * Add --has-package-version switch in libbcel-java.poms and other
    options for mh_install

  [tony mancill]
  * Apply patch to address FTBFS on JDK7 (Closes: #651146)
    - Thank you to James Page.
  * Fix Vcs-Browser field (Closes: #634835)
  * Add d/libbcel-java.links (workaround for #651901)
  * Bumped Standards-Version to 3.9.2 - no changes required.
  * Upload to unstable.

 -- tony mancill <email address hidden>  Mon, 12 Dec 2011 21:42:34 -0800
Superseded in precise-release on 2012-02-09
bcel (5.2-7ubuntu1) precise; urgency=low

  * Fix FTBFS with Java 7 (LP: #888120):
    - d/patches/encoding.patch: Fix encoding for javac and javadoc calls
      to ensure compatibility with Java 7.
    - d/ant.properties: Set Java source and target to 1.5 for backwards
      compatibility.
 -- James Page <email address hidden>   Mon, 05 Dec 2011 17:47:22 +0000

Available diffs

Superseded in precise-release on 2011-12-05
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
bcel (5.2-7) unstable; urgency=low

  * Change the (Build-)Depends for the jdk's doc package to default-jdk-doc.
    (Closes: 567267)
  * Downgrade the Depends on the jdk's doc package to Recommends.
  * Remove Stefan, Arnaud, Wolfgang, and Paul from Uploaders list. Thanks to
    your contribution in the past!
  * Update Standards-Version: 3.8.4.
  * Switch to source format 3.0.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  15 Oct 2010 09:25:28 +0000

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
bcel (5.2-6) unstable; urgency=low

  * Upload to unstable.

Available diffs

Obsolete in karmic-updates on 2013-03-04
Deleted in karmic-proposed on 2013-03-04 (Reason: moved to -updates)
bcel (5.2-3ubuntu4) karmic-proposed; urgency=low

  * Add maven POM to the package. LP: #461090.

 -- Matthias Klose <email address hidden>   Mon, 26 Oct 2009 15:30:11 +0100

Available diffs

Superseded in lucid-release on 2009-10-30
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
bcel (5.2-3ubuntu3) jaunty; urgency=low

  * debian/control: Added libxerces2-java-doc back to "Depends:".
    (LP: #190247)

 -- Savvas Radevic <email address hidden>   Fri, 20 Feb 2009 19:22:25 +0100

Available diffs

Superseded in jaunty-release on 2009-03-02
Obsolete in intrepid-release on 2013-02-20
bcel (5.2-3ubuntu2) intrepid; urgency=low

  * Build-depend on default-jdk instead of java-gcj-compat-dev.

 -- Matthias Klose <email address hidden>   Wed, 30 Jul 2008 13:41:38 +0000

Available diffs

Superseded in intrepid-release on 2008-07-30
Obsolete in hardy-release on 2015-04-24
bcel (5.2-3ubuntu1) hardy; urgency=low

  * Merge from debian unstable, remaining changes:
    - libbcel-java-doc: Add alternative dependency on libgcj-doc.
    - debian/control: Drop libbcel-java-doc's dependency to
      libxerces2-java-doc to a suggestion, since that is in multiverse.

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
bcel (5.2-2ubuntu2) gutsy; urgency=low

  * debian/control: Drop libbcel-java-doc's dependency to libxerces2-java-doc
    to a suggestion, since that is in multiverse.
  * debian/control: Set Ubuntu maintainer.

 -- Martin Pitt <email address hidden>   Mon, 04 Jun 2007 11:30:12 +0200
Superseded in gutsy-release on 2007-06-04
bcel (5.2-2ubuntu1) gutsy; urgency=low

  * libbcel-java-doc: Add alternative dependency on libgcj-doc.

 -- Matthias Klose <email address hidden>   Thu, 24 May 2007 09:44:22 +0200
Superseded in gutsy-release on 2007-05-24
bcel (5.2-2) unstable; urgency=low

  * Migrate experimental version to unstable.
  * Remove downloading of a Jar from build.xml.

Superseded in gutsy-release on 2007-05-23
Obsolete in feisty-release on 2009-08-20
bcel (5.1-6ubuntu2) feisty; urgency=low

  * Fix build failures with recent gcj.

 -- Matthias Klose <email address hidden>   Mon,  5 Feb 2007 00:20:28 +0100
Superseded in feisty-release on 2007-02-05
Obsolete in edgy-release on 2008-06-19
bcel (5.1-6ubuntu1) edgy; urgency=low

  * Merge from debian unstable, remaining changes:
   - build using java-gcj-compat.

Superseded in edgy-release on 2006-07-06
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
bcel (5.1-5ubuntu1) dapper; urgency=low


  * Resync with debian 

 -- Charles Majola <email address hidden>  Thu, 17 Nov 2005 13:55:27 +0000
Obsolete in breezy-release on 2008-03-25
bcel (5.1-4ubuntu3) breezy; urgency=low


  * Change compiler from modern to org.eclipse.jdt.core.JDTCompilerAdapter
    as this lets us actually compile using ecj.

 -- Tollef Fog Heen <email address hidden>  Thu,  8 Sep 2005 14:03:06 +0200
Obsolete in hoary-release on 2008-03-19
bcel (5.1-4ubuntu1) hoary; urgency=low


  * Resynchronize with Debian.
  * Converted build to java-gcj-compat.

 -- Jerry Haltom <email address hidden>  Mon, 28 Mar 2005 22:56:53 -0600
Obsolete in warty-release on 2008-01-09
bcel (5.1-1) unstable; urgency=low


  * New upstream release
    + This version is compatible with JDK 1.4 (closes: #174977)
  * Added myself to Uploaders
  * Standards-Version: 3.6.0 (no changes required)
    + Don't use Ant in the clean target to avoid Build-Depends:
  * Build with debhelper >= 4.1.0 to get rid of /usr/doc compatibility
    symlinks
  * Updated long description and added a link to the home page.
  * Fixed build dependencies (closes: #174980)
  * Build using j2sdk1.4
  * Moved libbcel-java-doc from contrib/libs to contrib/doc
  * Updated download location and upstream authors debian/copyright
  * Fixed package dependencies according to the Java policy (closes: #174984)
  * Only build the API documentation, building the real documentaion requires
    addisional files from the Jakarta project

 -- Stefan Gybas <email address hidden>  Mon, 14 Jul 2003 20:43:51 +0200
125 of 25 results