Change log for bsh package in Ubuntu

131 of 31 results
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-11-30
Deleted in bionic-proposed (Reason: moved to release)
bsh (2.0b4-19) unstable; urgency=medium

  * Fixed the build failure with Java 9 (Closes: #875340)
  * Applied Jonathan Bustillos' patch to make the build reproducible
    (Closes: #877470)
  * Build with the DH sequencer instead of CDBS
  * Moved the package to Git
  * Standards-Version updated to 4.1.1
  * Switch to debhelper level 10

 -- Emmanuel Bourg <email address hidden>  Thu, 30 Nov 2017 00:39:30 +0100

Available diffs

Superseded in bionic-release on 2017-11-30
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
bsh (2.0b4-18) unstable; urgency=medium

  * Team upload.
  * Transition to the Servlet API 3.1
  * Standards-Version updated to 3.9.8 (no changes)

 -- Emmanuel Bourg <email address hidden>  Mon, 30 May 2016 19:13:58 +0200
Superseded in yakkety-release on 2016-07-12
Published in xenial-release on 2016-04-08
Superseded in xenial-release on 2016-04-08
Deleted in xenial-proposed (Reason: moved to release)
bsh (2.0b4-17ubuntu1) xenial; urgency=medium

  * Merged from Debian. Remaining changes:
    - Move to Servlet API 3.1

Obsolete in wily-updates on 2018-01-22
Obsolete in wily-security on 2018-01-22
bsh (2.0b4-15ubuntu0.15.10.1) wily-security; urgency=medium

  * SECURITY UPDATE: remote code execution vulnerability via
    deserialization
    - debian/patches/CVE-2016-2510.patch: prevent deserialization of
      Handler in src/bsh/XThis.java.
    - CVE-2016-2510

 -- Marc Deslauriers <email address hidden>  Thu, 03 Mar 2016 13:59:16 -0500
Published in trusty-updates on 2016-03-08
Published in trusty-security on 2016-03-08
bsh (2.0b4-15ubuntu0.14.04.1) trusty-security; urgency=medium

  * SECURITY UPDATE: remote code execution vulnerability via
    deserialization
    - debian/patches/CVE-2016-2510.patch: prevent deserialization of
      Handler in src/bsh/XThis.java.
    - CVE-2016-2510

 -- Marc Deslauriers <email address hidden>  Thu, 03 Mar 2016 14:02:14 -0500
Published in precise-updates on 2016-03-08
Published in precise-security on 2016-03-08
bsh (2.0b4-12ubuntu0.1) precise-security; urgency=medium

  * SECURITY UPDATE: remote code execution vulnerability via
    deserialization
    - debian/patches/CVE-2016-2510.patch: prevent deserialization of
      Handler in src/bsh/XThis.java.
    - CVE-2016-2510

 -- Marc Deslauriers <email address hidden>  Thu, 03 Mar 2016 14:03:03 -0500
Superseded in xenial-release on 2016-03-08
Deleted in xenial-proposed on 2016-03-10 (Reason: moved to release)
bsh (2.0b4-15ubuntu1) xenial; urgency=medium

  * Move to Servlet API 3.1 (LP: #1539903)

 -- Martin Pitt <email address hidden>  Mon, 22 Feb 2016 15:15:58 +0100
Superseded in xenial-release on 2016-02-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-11-29
Deleted in trusty-proposed (Reason: moved to release)
bsh (2.0b4-15) unstable; urgency=low


  * Added the poms missing in the previous upload (Closes: #730008)
  * Transition to the Servlet API 3.0 (Closes: #729972)

 -- Emmanuel Bourg <email address hidden>  Thu, 21 Nov 2013 17:16:04 +0100
Superseded in trusty-proposed on 2013-11-26
bsh (2.0b4-14ubuntu1) trusty; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Transition libservlet2.5-java -> libservlet3.0-java.

Superseded in trusty-release on 2013-11-29
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
bsh (2.0b4-12ubuntu1) quantal; urgency=low

  * Transition libservlet2.5-java -> libservlet3.0-java (LP: #1023405).
 -- James Page <email address hidden>   Thu, 12 Jul 2012 15:02:13 +0100
Superseded in quantal-release on 2012-07-12
Published in precise-release on 2011-12-03
bsh (2.0b4-12build1) precise; urgency=low

  * No-change rebuild to drop spurious libsfgcc1 dependency on armhf.
 -- Adam Conrad <email address hidden>   Fri, 02 Dec 2011 17:31:18 -0700

Available diffs

Superseded in precise-release on 2011-12-03
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
bsh (2.0b4-12) unstable; urgency=low

  * Build-depend on libservlet2.5-java instead of libservlet2.4-java.
 -- Benjamin Drung <email address hidden>   Fri, 11 Jun 2010 16:20:23 +0200

Available diffs

Superseded in maverick-release on 2010-07-16
bsh (2.0b4-11ubuntu1) maverick; urgency=low

  * Merge from debian unstable. Remaining changes:
    - debian/control, debian/rules: Build-depend on libservlet2.5-java instead
      of libservlet2.4-java
    - debian/control: Suggest bsh-gcj instead of recommending it

Superseded in maverick-release on 2010-06-04
Obsolete in lucid-release on 2016-10-26
bsh (2.0b4-10ubuntu2) lucid; urgency=low

  * debian/control, debian/rules: Build-depend on libservlet2.5-java instead
    of libservlet2.4-java (LP: #534913)
 -- Thierry Carrez <email address hidden>   Tue, 09 Mar 2010 09:37:54 +0100
Superseded in lucid-release on 2010-03-09
Obsolete in karmic-release on 2013-03-04
bsh (2.0b4-10ubuntu1) karmic; urgency=low

  * Merge with Debian.
  * Suggest bsh-gcj instead of recommending it; should be reverted after
    the karmic release.

Superseded in karmic-release on 2009-10-19
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
bsh (2.0b4-8ubuntu3) intrepid; urgency=low

  * bsh: Suggest libservlet2.4-java instead of libservlet2.3-java,
    suggest default-jre | java-runtime instead of libgcj8-1-awt.
    LP: #257402.

 -- Matthias Klose <email address hidden>   Mon, 08 Sep 2008 14:56:14 +0000

Available diffs

Superseded in intrepid-release on 2008-09-08
bsh (2.0b4-8ubuntu2) intrepid; urgency=low

  * debian/control
    - Replace build dependency libservlet2.3-java with libservlet2.4-java.
    - Remove unneeded build dependency lynx.
    - Replace suggests libservlet2.3-java with libservlet2.4-java.
    - Remove libgcj8-1-awt from recommends to suggests.
  * debian/rules
    - Add appropriate jar file name for servlet api 2.4.

 -- Onkar Shinde <email address hidden>   Wed, 13 Aug 2008 00:43:22 +0530

Available diffs

Superseded in intrepid-release on 2008-08-14
bsh (2.0b4-8ubuntu1) intrepid; urgency=low

  * Depend on default-jre-headless.
  * Set Ubuntu maintainer address.

 -- Matthias Klose <email address hidden>   Thu, 31 Jul 2008 10:46:33 +0000

Available diffs

Superseded in intrepid-release on 2008-07-31
bsh (2.0b4-8) unstable; urgency=low

  * Build-Depends on default-jdk-builddep. Closes: #477849
  * Clarified debian/copyright.
  * Put bsh-doc.doc-base.1 into Programming/Java section.
  * Added Homepage, Vcs-Svn and Vcs-Browser fields.
  * Updated Standards-Version to 3.7.3.
  * Added watch file.

 -- Onkar Shinde <email address hidden>   Fri,  20 Jun 2008 10:56:46 +0100

Available diffs

Superseded in intrepid-release on 2008-06-20
Obsolete in hardy-release on 2015-04-24
bsh (2.0b4-7ubuntu1) hardy; urgency=low

  * Merge from Debian, remaining changes:
    - bsh: Add an alternative dependency on gij.

Superseded in hardy-release on 2007-12-05
Obsolete in gutsy-release on 2011-09-16
bsh (2.0b4-6ubuntu1) gutsy; urgency=low

  * bsh: Add an alternative dependency on gij.
  * Set Ubuntu maintainer address.

 -- Matthias Klose <email address hidden>   Thu, 13 Sep 2007 08:04:29 +0000
Superseded in gutsy-release on 2007-09-13
bsh (2.0b4-6) unstable; urgency=low

  * bsh: Removed Recommends on xlibs. Closes: #372852.
  * bsh: Recommend libgcj7-1-awt. Closes: #401461.

Superseded in gutsy-release on 2007-07-10
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
bsh (2.0b4-4ubuntu4) edgy; urgency=low

  * Rename Build-Depends-Indep to Build-Depends.

 -- Matthias Klose <email address hidden>   Tue,  3 Oct 2006 13:21:33 +0000
Superseded in edgy-release on 2006-10-03
bsh (2.0b4-4ubuntu3) edgy; urgency=low

  * Fix binary-arch only build.

 -- Matthias Klose <email address hidden>   Tue,  3 Oct 2006 11:33:17 +0000
Superseded in edgy-release on 2006-10-03
bsh (2.0b4-4ubuntu2) edgy; urgency=low

  * Build a bsh-gcj package.

 -- Matthias Klose <email address hidden>   Tue, 26 Sep 2006 17:57:31 +0000
Superseded in edgy-release on 2006-10-01
bsh (2.0b4-4ubuntu1) edgy; urgency=low

  * Add gij as an alternative depenency.

 -- Matthias Klose <email address hidden>   Tue, 26 Sep 2006 09:37:59 +0000
Superseded in edgy-release on 2006-09-29
bsh (2.0b4-4) unstable; urgency=low

  * depends on java-gcj-compat (closes: #370411)
  * updated Standards Version to 3.7.2, nothing to do.
  * build with java-gcj-compat, kaffe removed from build-dep.

Superseded in edgy-release on 2006-07-05
Obsolete in dapper-release on 2011-09-06
bsh (2.0b4-2ubuntu2) dapper; urgency=low

  * Remove build-dependency on libant1.6-java, as ant now includes it.

 -- Adam Conrad <email address hidden>   Mon, 20 Mar 2006 18:29:54 +1100
Superseded in dapper-release on 2006-03-20
Superseded in dapper-release on 2006-02-03
bsh (2.0b4-2ubuntu1) dapper; urgency=low


  * Merge with debian (Closes #18998)
  * Fix Build-depend on ant
  * Fix ANT_HOME to point to the right ant directory

 -- Charles Majola <email address hidden>  Fri, 11 Nov 2005 09:35:23 +0200
Obsolete in breezy-release on 2008-03-25
bsh (2.0b4-1ubuntu1) breezy; urgency=low


  * Build-depend on java-gcj-compat-dev, depend on java-gcj-compat.

 -- Matthias Klose <email address hidden>  Mon, 22 Aug 2005 20:16:06 +0000
Obsolete in hoary-release on 2008-03-19
Obsolete in warty-release on 2008-01-09
bsh (1.3.0-2) unstable; urgency=low


  * debian/bsh.1: changed the location of the 'more documentation'
    location. Thanks to Alex Malinovich (closes: #226955).

 -- Arnaud Vandyck <email address hidden>  Sat, 10 Jan 2004 01:00:13 +0100
131 of 31 results