cups-filters 1.0.40-0ubuntu1.1 source package in Ubuntu

Changelog

cups-filters (1.0.40-0ubuntu1.1) saucy-security; urgency=medium

  * SECURITY UPDATE: arbitrary code execution via overflows in urftopdf
    - debian/patches/CVE-2013-647x.patch: check sizes in
      filter/urftopdf.cpp.
    - CVE-2013-6473
  * SECURITY UPDATE: arbitrary code execution via overflows in pdftoopvp
    - debian/patches/CVE-2013-647x.patch: use gmallocn and gmallocn3 in
      filter/pdftoopvp/{oprs/OPVPSplash.cxx,OPVPOutputDev.cxx}.
    - CVE-2013-6474
    - CVE-2013-6475
  * SECURITY UPDATE: arbitrary code execution via driver in pdftoopvp
    - debian/patches/CVE-2013-647x.patch: restrict driver path in
      filter/pdftoopvp/oprs/OPVPWrapper.cxx.
    - CVE-2013-6476
 -- Marc Deslauriers <email address hidden>   Tue, 11 Mar 2014 10:52:15 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2014-03-11
Uploaded to:
Saucy
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
any
Section:
net
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
cups-filters_1.0.40.orig.tar.bz2 1.1 MiB 176d9bec6f8da4effe2a9669e391260d
cups-filters_1.0.40-0ubuntu1.1.debian.tar.gz 50.5 KiB 4f48d95537b8f4d93fdfcfe16efc5de6
cups-filters_1.0.40-0ubuntu1.1.dsc 2.8 KiB 62c19c5aa1e3a343c53b97fbb885a2ef

View changes file

Binary packages built by this source

cups-browsed: No summary available for cups-browsed in ubuntu saucy.

No description available for cups-browsed in ubuntu saucy.

cups-filters: No summary available for cups-filters in ubuntu saucy.

No description available for cups-filters in ubuntu saucy.

libcupsfilters-dev: No summary available for libcupsfilters-dev in ubuntu saucy.

No description available for libcupsfilters-dev in ubuntu saucy.

libcupsfilters1: No summary available for libcupsfilters1 in ubuntu saucy.

No description available for libcupsfilters1 in ubuntu saucy.

libfontembed-dev: No summary available for libfontembed-dev in ubuntu saucy.

No description available for libfontembed-dev in ubuntu saucy.

libfontembed1: No summary available for libfontembed1 in ubuntu saucy.

No description available for libfontembed1 in ubuntu saucy.