debhelper 10.2.2ubuntu1~ubuntu16.10.1 source package in Ubuntu

Changelog

debhelper (10.2.2ubuntu1~ubuntu16.10.1) yakkety-backports; urgency=medium

  * No-change backport to yakkety

debhelper (10.2.2ubuntu1) zesty; urgency=medium

  * Merge from Debian unstable.  Remaining changes:
    - dh_installchangelogs: Do not install upstream changelog in compat
      level 7. This floods packages with huge upstream changelogs which
      are unnecessary on an installed system.
    - dh_strip: Revert commit f1a803456 to disable ddebs generation by
      default.  This first needs adjustments in Launchpad and ddebs.u.c., and
      dropping pkg-create-dbgsym.

debhelper (10.2.2) unstable; urgency=medium

  * Fix typo in changelog entry for release 10.2.  Thanks to
    Peter Pentchev for reporting it.
  * Deprecate all compat levels lower than 9.
  * dh: Discard override log files before running the override
    rather than after.
  * dh_compress,dh_fixperms: Remove references to long
    obsolete directories such as usr/info, usr/man and
    usr/X11*/man.
  * autoreconf.pm: Apply patch from Helmut Grohne to fix
    autoconf/cross regression from #836988.  The autoreconf
    build-system is now also used directly for "clean" and
    "build" (while still usin the "make" build-system for the
    heavy lifting).  (Closes: #839681)
  * dh_installdirs: In compat 11, avoid creating debian/<pkg>
    directories except when required to do so.  This fixes a
    corner case, where an arch:all build would behave
    differently than an arch:all+arch:any when dh_installdir is
    optimised out only for the arch:all build.
  * Dh_Lib.pm: Fix typo of positive.  Thanks to Matthias Klose
    for spotting it.

debhelper (10.2.1) unstable; urgency=medium

  * d/rules: Add a ./run in front of dh_auto_install.  It is
    technically not needed, but it prevents lintian from assuming
    that we need to Build-Depend debhelper.

debhelper (10.2) unstable; urgency=medium

  * Apply patch from Peter Pentchev to fix some typos.
  * Apply patch from Michael Biebl to undo a major
    regression where all of debhelpers functionality was
    missing (introduced in 10.1).  (Closes: #839557)
  * dh_installinit,dh_systemd_start: Introduce a new
    --no-stop-on-upgrade as an alternative to
    --no-restart-on-upgrade.  This new option should
    reduce the confusion of what it does.  Thanks to
    Michael Biebl for the suggestion.

debhelper (10.1) unstable; urgency=medium

  * Apply patch from Michael Biebl to take over dh-systemd
    package to ease backporting to jessie-backports.
    (Closes: #837585)
  * Apply patch from Helmut Grohne and Julian Andres Klode
    to improve cross-building support in the cmake build
    system.  (Closes: #833789)
  * Make the makefile.pm buildsystem (but not subclasses thereof)
    pass the CC and CXX variables set to the host compilers when
    cross-building.  Thanks to Helmut Grohne for the idea and
    the initial patch.  (Closes: #836988)
  * dh_md5sums.1: Mention dpkg --verify as a consumer of the
    output file.  Thanks to Guillem Jover for reporting it.
  * debhelper-obsolete-compat.pod: Add a manpage for the
    upgrade checklist for all obsolete/removed compat levels.
    Thanks to Jakub Wilk for the suggestion.
  * Dh_Getopt,dh_*: Rename --onlyscripts to --only-scripts and
    --noscripts to --no-scripts for consistency with other
    options.  The old variants are accepted for compatibility.
    Thanks to Raphaƫl Hertzog for the suggestion.
    (Closes: #838446)
  * cmake.pm: If cmake fails, also dump CMakeFiles/CMakeOutput.log
    and CMakeFiles/CMakeError.log if they are present.  Thanks to
    Michael Banck for the suggestion.  (Closes: #839389)
  * d/copyright: Correct copyright and license of dh_systemd*
    tools.

 -- Iain Lane <email address hidden>  Fri, 11 Nov 2016 09:48:55 +0000

Upload details

Uploaded by:
Iain Lane on 2016-11-11
Uploaded to:
Yakkety
Original maintainer:
Ubuntu Developers
Architectures:
all
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Yakkety backports on 2016-11-11 main devel

Builds

Yakkety: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
debhelper_10.2.2ubuntu1~ubuntu16.10.1.tar.xz 346.3 KiB 9f3479bef44ad88dbf0c7ba372ff560ba831af4443be01e65f9078d2f9afd0d7
debhelper_10.2.2ubuntu1~ubuntu16.10.1.dsc 1.8 KiB cf0e3afac41595a30ed4513365db2d1bb68d089da539eddc596975de78cb9079

View changes file

Binary packages built by this source

debhelper: helper programs for debian/rules

 A collection of programs that can be used in a debian/rules file to
 automate common tasks related to building Debian packages. Programs
 are included to install various files into your package, compress
 files, fix file permissions, integrate your package with the Debian
 menu system, debconf, doc-base, etc. Most Debian packages use debhelper
 as part of their build process.

dh-systemd: debhelper add-on to handle systemd unit files - transitional package

 This package is for transitional purposes and can be removed safely.