Change log for easymock package in Ubuntu

124 of 24 results
Published in disco-release on 2018-12-03
Deleted in disco-proposed (Reason: moved to release)
easymock (4.0.2-1) unstable; urgency=medium

  * New upstream version 4.0.2.

 -- Markus Koschany <email address hidden>  Sun, 02 Dec 2018 23:05:08 +0100

Available diffs

Superseded in disco-release on 2018-12-03
Deleted in disco-proposed on 2018-12-04 (Reason: moved to release)
easymock (4.0.1-1) unstable; urgency=medium

  * New upstream version 4.0.1.
  * Declare compliance with Debian Policy 4.2.1.
  * Rebase no-android.patch.

 -- Markus Koschany <email address hidden>  Tue, 30 Oct 2018 12:42:47 +0100

Available diffs

Superseded in disco-release on 2018-11-09
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-04-21
Deleted in bionic-proposed (Reason: moved to release)
easymock (3.6-1) unstable; urgency=medium

  * New upstream version 3.6.
  * Update copyright years.
  * Declare compliance with Debian Policy 4.1.4.
  * Use compat level 11.
  * Build-depend on libmaven-enforcer-plugin-java.
  * Rebase no-android.patch.

 -- Markus Koschany <email address hidden>  Thu, 12 Apr 2018 19:58:32 +0200

Available diffs

Superseded in bionic-release on 2018-04-21
Deleted in bionic-proposed on 2018-04-22 (Reason: moved to release)
easymock (3.5.1+ds-1) unstable; urgency=medium

  * New upstream version 3.5.1+ds.
  * Declare compliance with Debian Policy 4.1.1.

 -- Markus Koschany <email address hidden>  Sun, 19 Nov 2017 15:28:46 +0100

Available diffs

Superseded in bionic-release on 2017-11-23
Published in artful-release on 2017-09-18
Deleted in artful-proposed (Reason: moved to release)
easymock (3.5+ds-1) unstable; urgency=medium

  * New upstream version 3.5+ds.
  * Declare compliance with Debian Policy 4.1.0.
  * libeasymock-java.poms: Remove --has-package-version flag.
  * Drop maven-jar-plugin-compatibility.patch.
  * Refresh no-android.patch.
  * Ignore new dexmaker artifact.
  * Ignore test-testng module.
  * Add testng to Build-Depends.

 -- Markus Koschany <email address hidden>  Fri, 15 Sep 2017 07:15:45 +0200

Available diffs

Superseded in artful-release on 2017-09-18
Deleted in artful-proposed on 2017-09-19 (Reason: moved to release)
easymock (3.4+ds-2) unstable; urgency=medium

  * Fix FTBFS with the latest version of the maven-jar-plugin.
    Thanks to Lucas Nussbaum for the report. (Closes: #869018)
  * Declare compliance with Debian Policy 4.0.0.
  * Use https for Format field.
  * Remove Jan-Pascal van Best from Uploaders because he is not active anymore.

 -- Markus Koschany <email address hidden>  Sat, 22 Jul 2017 15:18:11 +0200

Available diffs

Superseded in artful-release on 2017-07-24
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
easymock (3.4+ds-1) unstable; urgency=medium

  * New upstream version 3.4+ds.
  * Switch to compat level 10.
  * debian/control: Use Build-Depends only.
  * Update get-orig-source target and use Files-Excluded mechanism.
  * Switch to maven-debian-helper because the build system is now Maven based.
  * Use correct Maven substvars in debian/control.
  * Remove libeasymock-java-doc.docs
  * Drop README.source.
  * Rebase no-android.patch and remove AndroidClassProxyFactory class.
  * Add maven.properties file.
  * Remove ant and ant-optional from Build-Depends.
  * Add libmaven-javadoc-plugin-java to Build-Depends.
  * Add libmaven-bundle-plugin-java to Build-Depends.
  * Add libeasymock-java-doc.doc-base.api
  * Add libeasymock-java-doc.install
  * Suggest Junit4 instead of depending on it because it is optional.

 -- Markus Koschany <email address hidden>  Fri, 07 Oct 2016 18:59:24 +0200

Available diffs

Superseded in zesty-release on 2016-11-02
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
easymock (3.3.1+ds-4) unstable; urgency=medium

  * Team upload.
  * Depend on libcglib-java instead of libcglib3-java
  * debian/watch: Track the new release tags on GitHub

 -- Emmanuel Bourg <email address hidden>  Mon, 26 Sep 2016 16:56:59 +0200

Available diffs

Superseded in yakkety-release on 2016-09-27
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
easymock (3.3.1+ds-3) unstable; urgency=medium

  * Team upload.
  * Added the missing Maven rule to rewrite the asm version in the pom

 -- Emmanuel Bourg <email address hidden>  Thu, 30 Apr 2015 16:46:53 +0200

Available diffs

Superseded in wily-release on 2015-05-06
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
easymock (3.2+ds-4) unstable; urgency=medium


  * Team upload.
  * Added the missing Maven rule to rewrite the cglib version in the pom
    (Closes: #763646)

 -- Emmanuel Bourg <email address hidden>  Wed, 01 Oct 2014 17:11:31 +0200

Available diffs

Superseded in vivid-release on 2014-10-24
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
Superseded in utopic-proposed on 2014-05-28
easymock (3.2+ds-2) unstable; urgency=medium


  * Team upload.
  * Upload to unstable

 -- Emmanuel Bourg <email address hidden>  Thu, 13 Mar 2014 17:08:51 +0100

Available diffs

Superseded in utopic-release on 2014-05-28
Superseded in utopic-release on 2014-05-19
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
easymock (2.5.2+ds-1) unstable; urgency=low


  * New upstream release. (Closes: #713751)
  * Bump Standards-Version to 3.9.4, no changes.
  * Bump compat level to 9 and require debhelper >= 9.
  * debian/rules:
    - Add a new get-orig-source and get-orig-pom target.
    - Use dh sequencer instead of cdbs and simplify debian/rules.
    - Build with javahelper and jh_maven_repo_helper.
  * Remove the following files, no longer needed.
    - get-orig-source script.
    - ant.properties.
    - uscan helper files.
  * debian/control:
    - Add myself to Uploaders.
    - Remove obsolete DM-Upload-allowed flag.
    - Use canonical Vcs-URI.
    - Add javahelper and ant to Build-Depends, remove cdbs.
    - Move junit4 and default-jdk to Build-Depends-Indep.
    - libeasymock-java: Suggest junit4.
  * Update debian/watch file to detect the latest upstream release.
  * debian/patches:
    - Refresh java7-compat.patch.
    - Drop 10_create_link_to_samples_and_javadocs_in_Documentation.dpatch
      because the rest of the documentation is easy to find in the same place
      as Documentation.html.
  * Update debian/copyright to copyright format 1.0. The new upstream license
    for EasyMock is Apache-2.0.
  * Update pom.xml for easymock 2.5.2.
  * Update build.xml and extend classpath locations, so that compile and test
    targets can be run successfully.

 -- Markus Koschany <email address hidden>  Tue, 06 Aug 2013 19:33:38 +0200

Available diffs

Superseded in saucy-release on 2013-09-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
easymock (2.4+ds1-7) unstable; urgency=low


  * Team upload.
  * Apply patch from James Page to fix FTBFS with OpenJDK-7
    as default-java.  (Closes: #678170, LP: #888122)

 -- Niels Thykier <email address hidden>  Wed, 20 Jun 2012 00:19:13 +0200
Superseded in quantal-release on 2012-06-22
easymock (2.4+ds1-6ubuntu1) quantal; urgency=low

  * Fix FTBFS ith openjdk-7 (LP: #888122):
    - d/patches/java7-compat.patch: Adapted patch from upstream trunk
      to support compilation under Java 7 which has tighter checks on
      conflicting erasures for methods.
 -- James Page <email address hidden>   Mon, 21 May 2012 12:09:59 +0100

Available diffs

Superseded in quantal-release on 2012-05-21
Published in precise-release on 2011-10-19
Superseded in precise-release on 2011-10-19
easymock (2.4+ds1-6) unstable; urgency=low

  * Team upload.
  * Add a publish rule for the old groupId 'easymock'.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 09:14:43 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
Superseded in oneiric-release on 2011-08-18
easymock (2.4+ds1-5) unstable; urgency=low

  * Team upload.

  [ Matthias Schmitz ]
  * Install the pom.xml (Closes:#593160):
    - Remove unneeded d/libeasymock-java.dirs.

  [ Damien Raude-Morvan ]
  * Drop Depends on JRE packages since it's a library (as per Debian Java
    Policy).
  * Update Standards-Version: 3.9.2:
    - Rename d/README.Debian-source to debian/README.source
 -- Jean-Louis Dupond <email address hidden>   Tue,  03 May 2011 10:27:55 +0000

Available diffs

Superseded in oneiric-release on 2011-05-03
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
easymock (2.4+ds1-4ubuntu1) maverick; urgency=low

  * FTBFS Amended Build-Depends to include libhamcrest-java (LP: #651155)
 -- James Page <email address hidden>   Wed, 29 Sep 2010 15:53:00 +0100

Available diffs

Superseded in maverick-release on 2010-09-30
easymock (2.4+ds1-4) unstable; urgency=low

  * Team upload.
  * Switch to default-jdk and default-jre-headless. Thanks to Thierry Carrez.
  * Switch to source format 3.0.
  * Update Standards-Version: 3.8.4.
 -- Thierry Carrez <email address hidden>   Tue,  08 Jun 2010 22:07:43 +0100

Available diffs

Superseded in maverick-release on 2010-06-08
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
Superseded in karmic-release on 2009-08-26
easymock (2.4+ds1-3ubuntu2) karmic; urgency=low

  * debian/rules: Set JAVA_HOME to match with default-jdk

 -- Thierry Carrez <email address hidden>   Fri, 21 Aug 2009 11:36:53 +0200
Superseded in karmic-release on 2009-08-21
easymock (2.4+ds1-3ubuntu1) karmic; urgency=low

  * debian/control:
    - Build depend on default-jdk (LP: #416387)
    - Runtime depend on default-jre-headless | java5-runtime-headless

 -- Thierry Carrez <email address hidden>   Thu, 20 Aug 2009 15:05:21 +0200

Available diffs

Superseded in karmic-release on 2009-08-20
easymock (2.4+ds1-3) unstable; urgency=low

  * Updated dependency version of junit4 (Closes: #534017).
  * Bump standards-version to 3.8.1 (no changes needed).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  25 Jun 2009 07:43:44 +0100

Available diffs

Superseded in karmic-release on 2009-06-25
Obsolete in jaunty-release on 2013-02-28
easymock (2.4+ds1-2) unstable; urgency=low

  * Updated debian/watch to work again with upstream version numbering
  * Added DM-Upload-Allowed: yes to debian/control
  * Moved build.xml to debian/ to silence Lintian about it

Available diffs

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
easymock (2.3+ds1-2) unstable; urgency=low

  * Updated Vcs-* and Homepage fields in control file
  * Updated watch file to match upstream version correctly (M. Koch)
  * Updated dependency to current gcj-java-compat-dev (Closes: #450422)
  * Updated standards version to 3.7.3

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 01:57:30 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
easymock (2.3+ds1-1) unstable; urgency=low

  * Initial release. (Closes: #441839)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  28 Oct 2007 18:39:24 +0000
124 of 24 results