Ubuntu

“foo2zjs” 20090908dfsg-1ubuntu1 source package in Ubuntu

Changelog

foo2zjs (20090908dfsg-1ubuntu1) lucid; urgency=low

  * Merge from Debian testing, remaining changes:
    - debian/foo2zjs.postinst: Automatically update the PPD files for
      existing queues to the versions supplied with this package.
    - debian/foo2zjs.preinst: handle moving 85-hplj10xx.rules from
      /etc/udev/rules.d to /lib/udev/rules.d, needed for upgrades from hardy.
    - debian/control, debian/rules: Do not include msexpand, as it is already
      in the mscompress package. Add a dependency on mscompress instead.
    - debian/control: Require foomatic-filters 4.x
    - debian/control: Add dependency on cups and cups-client to ensure that
      automatic update of the PPDs of existing print queues works.
    - debian/control: Drop tix recommends to a suggests.
    - debian/control: Breaks: udev (<< 136-1) to ensure the correct udev
      version is used.
    - debian/rules: Add /etc/papersize support, and modify all
      /usr/bin/foo2*-wrapper scripts to handle custom page sizes correctly in
      the PDF-based printing workflow.
    - debian/rules: Add "*cupsFilter" line to accept PDF input data to the
      PPDs.
    - debian/rules, debian/85-hplj10xx.rules: move the rules from
      11-hplj10xx.rules to 85-hplj10xx.rules per /etc/udev/rules.d/README,
      and include a number of updates, superseding 30-udev-rules.dpatch:
      + Make automatic firmware loading work for the HP LaserJet 1000, 1005,
        1018, 1020, P100x and 1505 printers.
      + 'BUS=="usb"' is deprecated, replaced with 'SUBSYSTEMS=="usb"'.
      + Removed deprecated '%e' tags from UDEV rules.
      + Removed UDEV rule items which conflict with the general UDEV rules
        for USB printers: 'NAME="usb/%k"', 'MODE="0666"'.
      + Change SYSFS to ATTRS.
    - debian/rules: Hide menu entry for the paper-out resetter for the HP
      LaserJet 1018/1020 and improve UI text for this menu entry.
    - debian/local/apport-hook.py, debian/rules: Add apport hook.
  * Dropped changes:
    - Replaces/Provides/Conflicts: foo2zjs-ppds: this package is not present
      in any supported release.
    - No hannah-foo2zjs package: this has been dropped in Debian as well.

foo2zjs (20090908dfsg-1) unstable; urgency=low

  * New upstream release.
    - supports Minolta mc1690MF (Closes: #545950)
  * debian/patches/60-hplj1000.dpatch: Removed last hunk as it is
    applied upstream.
  * debian/patches/70-printer-profile.dpatch: Added to work around
    deleting of printer-profile script in upstream Makefile.
  * debian/patches/90-manpages.dpatch: Updated to also fix manpage
    of printer-profile.
  * debian/README.source: Renamed from debian/README.Debian-source.

foo2zjs (20090301dfsg-5) unstable; urgency=low

  * Remove hannah-foo2zjs package as its now in its own source package.
  * debian/README.Debian-source: New file to describe usage of dpatch.
  * debian/control: Updated Standards-Version to 3.8.3.
  * debian/control: Add Vcs-Browser field.

foo2zjs (20090301dfsg-4) unstable; urgency=low

  * debian/hannah-package/gui.cpp: Fix list of argument names for getweb
    (Closes: #537325).
  * debian/patches/40-hplj1000.dpatch: Updated to also guard globbered
    names in find call (Closes: #526781).
  * debian/README.Debian: Clarify how hannah-foo2zjs and getweb are used
    (Closes: #503373, #529300).
  * debian/copyright: Link to /usr/share/common-licenses/GPL-2
    instead of /usr/share/common-licenses/GPL.
  * debian/control:
    + hannah-foo2zjs: Tighten Depends on kdebase-bin to (<< 4:4.4.0-1)
      (Closes: #460480).
    + Updated Standards-Version to 3.8.2.
  * debian/patches/60-getweb.in.dpatch: Exit with failure when called
    as non-root.
  * debian/patches/90-manpages.dpatch: New dpatch to fix manpage errors.
 -- Steve Langasek <email address hidden>   Mon, 30 Nov 2009 16:25:00 -0800

Upload details

Uploaded by:
Steve Langasek on 2009-12-01
Uploaded to:
Lucid
Original maintainer:
Ubuntu Development Team
Component:
main
Architectures:
any
Section:
text
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
foo2zjs_20090908dfsg.orig.tar.gz 1.1 MiB 07cec361324ebf6880ca9b950e45eecc
foo2zjs_20090908dfsg-1ubuntu1.diff.gz 20.9 KiB 6fd0a03cf9e9079c411ff41e544ffaa3
foo2zjs_20090908dfsg-1ubuntu1.dsc 2.0 KiB aadc14a7823c9db4edf523ad83dc0c30

Binary packages built by this source

foo2zjs: Support for printing to ZjStream-based printers

 foo2zjs is an open source printer driver for printers that use the
 Zenographics ZjStream wire protocol for their print data, such as the
 Minolta magicolor 2200/2300/2430 DL, Minolta Color PageWorks/Pro L and
 HP LaserJet 1000/1005/1018/1020/1022. These printers are often
 erroneously referred to as "winprinters" or "GDI printers".
 .
 The foomatic-db-engine package is recommended to simplify configuring
 this printer driver. The psutils package is needed to enable n-up
 printing support.