Change log for freebsd-libs package in Ubuntu

117 of 17 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-04-24
Published in focal-release on 2019-10-18
Obsolete in eoan-release on 2020-12-29
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
freebsd-libs (10.3~svn296373-10) unstable; urgency=medium

  * Pre-define MACHINE_ARCH with the host architecture we are building
    for, otherwise freebsd-make naively assumes it is the same as the
    build architecture.  Fixes a cross-build issue reported by Helmut
    Grohne, thanks!

 -- Steven Chamberlain <email address hidden>  Fri, 03 Feb 2017 15:35:02 +0000
Superseded in zesty-release on 2017-02-04
Deleted in zesty-proposed on 2017-02-05 (Reason: moved to release)
freebsd-libs (10.3~svn296373-9) unstable; urgency=medium

  [ Aurelien Jarno ]
  * libusb2-dev: fix libusb-1.0-0-dev versioned provided, set the version to
    1.0.6.

  [ Steven Chamberlain ]
  * Update my email address in Uploaders
  * Use HTTPS for Vcs-Browser URI

 -- Steven Chamberlain <email address hidden>  Thu, 29 Sep 2016 23:29:00 +0100
Superseded in zesty-release on 2016-11-02
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
freebsd-libs (10.3~svn296373-8) unstable; urgency=medium

  * Upload to unstable

 -- Steven Chamberlain <email address hidden>  Sat, 07 May 2016 17:39:48 +0100
Superseded in yakkety-release on 2016-06-03
Published in xenial-release on 2016-03-23
Deleted in xenial-proposed (Reason: moved to release)
freebsd-libs (10.1~svn273304-1ubuntu1) xenial; urgency=medium

  * debian/patches/replace_fgetln.diff: Grab patch from Debian to replace
    fgetln with getline and fix FTBFS on rebuild.

 -- Logan Rosen <email address hidden>  Wed, 23 Mar 2016 10:55:06 -0500
Superseded in xenial-release on 2016-03-23
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
freebsd-libs (10.1~svn273304-1) unstable; urgency=medium


  * New upstream snapshot of 10.1-RC3~
  * Build-Depend on freebsd-mk >= 10.0-5 for MK_TESTS
  * No longer try to set MK_TESTS in debian/rules;  use WITH_TESTS
    instead (Closes: #764956)

 -- Steven Chamberlain <email address hidden>  Fri, 17 Oct 2014 13:36:01 +0000

Available diffs

Superseded in vivid-release on 2014-11-12
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
freebsd-libs (10.0-7) unstable; urgency=medium


  [ Steven Chamberlain ]
  * Add empty LIBUSB_CALL macro, to be compatible to the libusb 1.0-API
    From upstream 10-STABLE.  Thanks, Scott Howard.  (Closes: #749157)

 -- Christoph Egger <email address hidden>  Sun, 31 Aug 2014 11:11:57 -0700

Available diffs

Superseded in utopic-release on 2014-09-07
Deleted in utopic-proposed on 2014-09-08 (Reason: moved to release)
freebsd-libs (10.0-6) unstable; urgency=medium


  * Add <stdint.h> include to kvm.h to fix header buildability.

 -- Robert Millan <email address hidden>  Thu, 22 May 2014 23:37:57 +0200

Available diffs

Superseded in utopic-release on 2014-05-23
Deleted in utopic-proposed on 2014-05-24 (Reason: moved to release)
freebsd-libs (10.0-5) unstable; urgency=low


  * Upload to unstable.

 -- Robert Millan <email address hidden>  Sat, 22 Mar 2014 20:39:25 +0100

Available diffs

Superseded in utopic-release on 2014-04-27
Published in trusty-release on 2014-02-08
Deleted in trusty-proposed (Reason: moved to release)
freebsd-libs (9.2+ds2-4) unstable; urgency=medium


  * Fix shlibs info in libusb3-udeb. (Closes: #736599)

 -- Robert Millan <email address hidden>  Sat, 25 Jan 2014 22:45:34 +0100
Deleted in natty-release on 2011-04-04 (Reason: blacklisted; bug #749050)
freebsd-libs (8.1-5) unstable; urgency=low

  * libusb2: fix USB devices detection. Closes: bug#594330.

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
freebsd-libs (8.0-4) unstable; urgency=low

  * libusb2-dev: add a libusb-1.0.so -> libusb.so symlink to make
    configure scripts happy.
  * Add patches/13_libusb-update.diff from upstream to update the API.
  * Add udeb package to libusb2's shlib.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  22 Jan 2010 11:24:57 +0000

Available diffs

Superseded in lucid-release on 2010-01-22
freebsd-libs (8.0-3) unstable; urgency=low

  [ Petr Salinger ]
  * bump build-depends on kfreebsd-kernel-headers to (>= 0.45)
  * add libusb2 and libusb2-dev packages

  [ Aurelien Jarno ]
  * Make libusb2-dev conflict with libusb-dev.
  * Add a libusb2-udev package. 
  * Add pkg-config files matching libusb 0.1/libusb 1.0.
  * Add a libusb-config script matching libusb 0.1.
  * Make libusb2-dev provides libusb-1.0-0-dev.

Available diffs

Superseded in lucid-release on 2009-12-14
freebsd-libs (7.2-4) unstable; urgency=low

  [ Aurelien Jarno ]
  * Fix description of libgeom-dev. 
  * libkvm0: use our own copy of getbootfile().
  * Fix dependency between lib and -dev packages.
  * Add README.source.
  * Bumped Standards-Version to 3.8.3.

  [ Petr Salinger ]
  * Build-depends on libc0.1-dev (>= 2.10) instead of libfreebsd-dev.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  10 Nov 2009 00:03:01 +0000

Available diffs

Superseded in lucid-release on 2009-11-10
freebsd-libs (7.2-3) unstable; urgency=low

  * Remove unnecessary linkages with libfreebsd.
  * Bumped Standards-Version to 3.8.2 (no changes).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  05 Nov 2009 05:58:22 +0000

Available diffs

Superseded in lucid-release on 2009-11-05
Obsolete in karmic-release on 2013-03-04
freebsd-libs (7.2-2) unstable; urgency=low

  *  Tighten build-depends on kfreebsd-kernel-headers.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  18 Jun 2009 08:32:23 +0100

Available diffs

Superseded in karmic-release on 2009-06-18
freebsd-libs (7.2-1) unstable; urgency=low

  [ Guillem Jover ]
  * Use $(filter ...) instead of $(findstring ...) to extract space separated
    options from DEB_BUILD_OPTIONS.
  * Line wrap Build-Depends and Depends fields longer than 80 chars.

  [ Petr Salinger ]
  * based on FreeBSD 7.2
  * add Vcs-* fields into debian/control.

  [ Aurelien Jarno ]
  * Tighten build-depends on libbsd-dev.
  * Use SVN server instead of the deprecated CVS server in get-orig-source.
  * Add -D'__FBSDID(string)=' to CFLAGS, drop debian/patches/00_fbsdid.diff

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  08 Jun 2009 10:59:42 +0100

Available diffs

Superseded in karmic-release on 2009-06-08
freebsd-libs (7.1-2) unstable; urgency=low

  * Upload to unstable. 
  * Don't use a tar in tar build system:
    - Remove fetch
    - Add a get-orig-source target.
    - Use quilt to manage patches.
    - Remove build-depends on kfreebsd-source-7.1.
    - Update patches accordingly.
  * Change patch level to -p1.
  * Fix a few bashisms in debian/rules.
  * Fix parallel build support in debian/rules. 
  * Install more manpages.
  * Switch to debhelper 5.
  * Bumped Standards-Version to 3.8.1 (no changes).
  * Update debian/copyright.

117 of 17 results