glib2.0 2.56.1-2ubuntu1 source package in Ubuntu

Changelog

glib2.0 (2.56.1-2ubuntu1) bionic; urgency=medium

  * Merge with debian, remaining changes:
    - exp_git_default_per_desktop*.patch:
      + cherry-pick per-desktop overrides from GNOME #786496
        Allison confirmed the patches will be committed to glib soon

glib2.0 (2.56.1-2) unstable; urgency=medium

  [ Tim Lunn ]
  * libglib2.0-0.triggers:use interest-await trigger for schemas

  [ Iain Lane ]
  * debian/patches/tests-network-monitor-Always-use-the-dummy-proxy-res.patch:
    Take patch from upstream to ignore the system's proxy settings for the
    network-monitor test - it's testing an "abstract" network unrelated to the
    system's network, and these settings interfere with that. This fixes a
    failure in the Ubuntu autopkgtest machines, which have a proxy set.

glib2.0 (2.56.1-1) unstable; urgency=medium

  [ Tim Lunn ]
  * New upstream release
  * Drop patches included in new release
  * libglib2.0-0.triggers: Use interest-noawait triggers, generating caches
    doesn't need to block configuration. flagged by lintian
    uses-implicit-await-trigger warning.

  [ Simon McVittie ]
  * Explicitly use autoconf build system, even with debhelper 11.2
    (see #895174)

glib2.0 (2.56.0-6) unstable; urgency=medium

  * Team upload
  * d/p/0002-gapplication-Tighten-up-application-ID-validation.patch:
    Transliterate commit message into ASCII so git-buildpackage doesn't
    export it as a blob of base64
  * d/p/g_test_dbus_down-Ensure-next-test-does-not-use-old-c.patch:
    Add patch to address a race condition that sometimes makes D-Bus-based
    tests fail (Closes: #894677)
  * d/patches: Improve metadata on various patches

glib2.0 (2.56.0-5) unstable; urgency=medium

  [ Simon McVittie ]
  * Use `set -e` in the (empty) prerm to avoid a Lintian warning
  * Add Lintian override for the empty prerm used to work around
    #887629

  [ Michael Biebl ]
  * Stop installing libglib to /lib.
    Late mounting of /usr is no longer supported, so this is not necessary
    anymore.
  * Drop maintscript migration code from pre-jessie.
  * Drop obsolete Breaks.

 -- Iain Lane <email address hidden>  Tue, 10 Apr 2018 19:03:42 +0100

Upload details

Uploaded by:
Iain Lane on 2018-04-10
Uploaded to:
Bionic
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Bionic release on 2018-04-13 main libs

Downloads

File Size SHA-256 Checksum
glib2.0_2.56.1.orig.tar.xz 7.7 MiB 40ef3f44f2c651c7a31aedee44259809b6f03d3d20be44545cd7d177221c0b8d
glib2.0_2.56.1-2ubuntu1.debian.tar.xz 77.6 KiB a9f07ab2bf8d43e154eafe55739b157b96dfff39ca19f44265e1f38e0322863e
glib2.0_2.56.1-2ubuntu1.dsc 3.3 KiB a6fb93181d5c26b31896a03c68a2e149241cff48f4561d46ebf207b43190cdde

View changes file

Binary packages built by this source

libglib2.0-0: GLib library of C routines

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains the shared libraries.

libglib2.0-0-dbgsym: debug symbols for libglib2.0-0
libglib2.0-bin: Programs for the GLib library

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains the program files which is used for the libraries
 and others.

libglib2.0-bin-dbgsym: debug symbols for libglib2.0-bin
libglib2.0-data: Common files for GLib library

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package is needed for the runtime libraries to display messages in
 languages other than English.

libglib2.0-dev: Development files for the GLib library

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package is needed to compile programs against libglib2.0-0,
 as only it includes the header files and static libraries (optionally)
 needed for compiling.

libglib2.0-dev-bin: Development utilities for the GLib library

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package is needed to compile programs against libglib2.0-0. It contains
 development utilities typically run during compilation and should not be
 installed directly. Use libglib2.0-dev instead.

libglib2.0-dev-bin-dbgsym: debug symbols for libglib2.0-dev-bin
libglib2.0-doc: Documentation files for the GLib library

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains the HTML documentation for the GLib library
 in /usr/share/doc/libglib2.0-doc/ .

libglib2.0-tests: GLib library of C routines - installed tests

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains test programs, designed to be run as part of a
 regression testsuite.

libglib2.0-tests-dbgsym: debug symbols for libglib2.0-tests
libglib2.0-udeb: GLib library of C routines - minimal runtime

 This is a udeb, or a microdeb, for the debian-installer.
 .
 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains the minimal runtime library needed by the Debian
 installer.