glib2.0 2.58.1-2 source package in Ubuntu

Changelog

glib2.0 (2.58.1-2) unstable; urgency=medium

  * Fix dh_missing rule for arch:all build with compat 11

 -- Jeremy Bicha <email address hidden>  Fri, 21 Sep 2018 23:53:00 -0400

Upload details

Uploaded by:
Debian GNOME Maintainers on 2018-09-22
Uploaded to:
Sid
Original maintainer:
Debian GNOME Maintainers
Architectures:
any all
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Cosmic release on 2018-09-25 main libs

Downloads

File Size SHA-256 Checksum
glib2.0_2.58.1-2.dsc 3.2 KiB ba933c6e8de5d6340ac02ea2a87236c4c30fec13adf1477032ca9ace150b6b6d
glib2.0_2.58.1.orig.tar.xz 4.7 MiB 97d6a9d926b6aa3dfaadad3077cfb43eec74432ab455dff14250c769d526d7d6
glib2.0_2.58.1-2.debian.tar.xz 74.9 KiB a21d05f9e3b19b325d8f129fcd74ea0c566ceed4b5aabdbc9078e5db13bce944

Available diffs

No changes file available.

Binary packages built by this source

libglib2.0-0: GLib library of C routines

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains the shared libraries.

libglib2.0-0-dbgsym: debug symbols for libglib2.0-0
libglib2.0-bin: Programs for the GLib library

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains the program files which is used for the libraries
 and others.

libglib2.0-bin-dbgsym: debug symbols for libglib2.0-bin
libglib2.0-data: Common files for GLib library

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package is needed for the runtime libraries to display messages in
 languages other than English.

libglib2.0-dev: Development files for the GLib library

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package is needed to compile programs against libglib2.0-0,
 as only it includes the header files and static libraries (optionally)
 needed for compiling.

libglib2.0-dev-bin: Development utilities for the GLib library

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package is needed to compile programs against libglib2.0-0. It contains
 development utilities typically run during compilation and should not be
 installed directly. Use libglib2.0-dev instead.

libglib2.0-dev-bin-dbgsym: debug symbols for libglib2.0-dev-bin
libglib2.0-doc: Documentation files for the GLib library

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains the HTML documentation for the GLib library
 in /usr/share/doc/libglib2.0-doc/ .

libglib2.0-tests: GLib library of C routines - installed tests

 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains test programs, designed to be run as part of a
 regression testsuite.

libglib2.0-tests-dbgsym: debug symbols for libglib2.0-tests
libglib2.0-udeb: GLib library of C routines - minimal runtime

 This is a udeb, or a microdeb, for the debian-installer.
 .
 GLib is a library containing many useful C routines for things such
 as trees, hashes, lists, and strings. It is a useful general-purpose
 C library used by projects such as GTK+, GIMP, and GNOME.
 .
 This package contains the minimal runtime library needed by the Debian
 installer.