gnome-python 2.27.1-0ubuntu1 source package in Ubuntu

Changelog

gnome-python (2.27.1-0ubuntu1) karmic; urgency=low

  * New upstream version:
    - gnome: GOption support in gnome_program_init
  * debian/control.in:
    - updated pygobject requirement

gnome-python (2.26.1-1ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/control.in:
      + Add python-gnome2-dbg, python-gnomecanvas and python-gnomecanvas-dbg
        packages
      + build-dep on python-all-dbg for debug packages
      + Re-generate debian/control
    - add some files:
      + debian/python-gnomecanvas.{install, examples}
      + debian/python-gconf.examples file
      + debian/python-gnome2.examples
    - debian/python-gnome2.install adapted as gnomecanvas are in another
      package and adapted to python 2.6 package layout
    - debian/python-gconf.install adapted to python 2.6 package layout
    - debian/rules:
      - dbg-* targets
      - dbg related extra install/cleanage
    - debian/watch takes into account unstable version
    - debian/patches converted to quilt:
      + 01-dont-build-with-lpython.patch: don't create a depends on a
        python version
      + regenerate 70_autoreconf.patch

gnome-python (2.26.1-1) unstable; urgency=low

  * New upstream release.
  * debian/control.in:
    - Bump Standards-Version to 3.8.1 (no changes needed).
  * debian/patches/70_relibtoolize.patch:
    - Remove, lintian doesn't complain about rpath on amd64.

gnome-python (2.26.1-0ubuntu1) jaunty; urgency=low

  * New upstream version

gnome-python (2.26.0-0ubuntu2) jaunty; urgency=low

  * No-change rebuild to fix lpia shared library dependencies.

gnome-python (2.26.0-0ubuntu1) jaunty; urgency=low

  * New upstream version

gnome-python (2.25.90-0ubuntu2) jaunty; urgency=low

  * debian/patches/70_autoreconf.dpatch:
    - autoreconf update to fix rpath issue (lp: #327671)
  * debian/patches/99-run-aclocal+autoconf+automake.dpatch:
    - the change is deprecated by the autoreconf one

gnome-python (2.25.90-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #327933)
    - Upgrade to newer WAF
    - Misc build fixes
    - gconf set_value should take unicode string as value
  * Update debian/watch to take into account unstable version
  * Add Vcs-Bzr tag to debian/control.in
  * Re-generate debian/control

gnome-python (2.22.3-3) unstable; urgency=low

  * Update Vcs-* fields.
  * Remove empty python-gnome2.examples.
  * Split the gconf module in a separate package named python-gconf.

gnome-python (2.22.3-2) unstable; urgency=low

  * Upload to unstable.

gnome-python (2.22.3-1) experimental; urgency=low

  [ Luca Bruno ]
  * New upstream release
  * rules:
    - Remove patch system
  * Add docs file
  * debian/control:
    - Bump Standards-Version to 3.8.0 (no changes needed)
    - Add python-gnome2-doc package
    - Add gtk-doc-tools to Build-Deps
    - python-gnome2 Suggests python-gnome2-doc
    - python-gnome2-dev Recommends python-gnome2-doc
  * python-gnome2.examples moved to python-gnome2-doc.examples
  * Change Homepage to http://www.pygtk.org/; the previous Homepage was a
    redirect to the new url.

  [ Emilio Pozuelo Monfort ]
  * Remove dpatch build-dependency.

  [ Josselin Mouette ]
  * Require python 2.5 to match the change in pygobject.
  * Add quilt patch system; build-depend on quilt.
  * 70_relibtoolize.patch: new patch. Relibtoolize the source to avoid
    the rpath issue on amd64.
  * Add copyright statements.

gnome-python (2.22.3-0ubuntu3) jaunty; urgency=low

  * Build for python2.6.

gnome-python (2.22.3-0ubuntu2) jaunty; urgency=low

  * debian/control.in:
    - updated the python version to the same than pygtk and pygobject

gnome-python (2.22.3-0ubuntu1) intrepid; urgency=low

  * New upstream version

gnome-python (2.22.2-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Compatibility with newer pygobject

gnome-python (2.22.1-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - ability to compile only selected modules

gnome-python (2.22.0-1ubuntu1) intrepid; urgency=low

  * Sync on Debian
  * debian/control.in:
    - Build-Depends on python-all-dbg (>= 2.5) and build debug versions
    - list python-gconf python-gnomecanvas
    - updated maintainer information
  * debian/patches/01-dont-build-with-lpython.dpatch:
    - don't create a depends on a python version
  * debian/patches/99-run-aclocal+autoconf+automake.dpatch:
    - run autotools update
  * debian/python-gnome2-dbg.rtupdate:
    - debug package variant
  * update examples and install files to list new variants

 -- Sebastien Bacher <email address hidden>   Mon, 11 May 2009 13:59:18 +0200

Upload details

Uploaded by:
Sebastien Bacher on 2009-05-11
Uploaded to:
Karmic
Original maintainer:
Ubuntu Desktop
Architectures:
any
Section:
python
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
gnome-python_2.27.1.orig.tar.gz 670.7 KiB ddbbd163bf3881b9f22f09102a1880e7641f4b069f8a4f19ecfb9c25902cd013
gnome-python_2.27.1-0ubuntu1.diff.gz 469.9 KiB f216e03d27e8f277fe612e9494e81a37cdc19fc06a0a56e9ad8c3fc65e9586d6
gnome-python_2.27.1-0ubuntu1.dsc 2.1 KiB 036bbeb16262255ac9d670416eaac21e6b7c3a1e00cc1ab71fb5f0b450404cab

Available diffs

View changes file

Binary packages built by this source

python-gconf: No summary available for python-gconf in ubuntu karmic.

No description available for python-gconf in ubuntu karmic.

python-gconf-dbg: No summary available for python-gconf-dbg in ubuntu karmic.

No description available for python-gconf-dbg in ubuntu karmic.

python-gnome2: No summary available for python-gnome2 in ubuntu karmic.

No description available for python-gnome2 in ubuntu karmic.

python-gnome2-dbg: No summary available for python-gnome2-dbg in ubuntu karmic.

No description available for python-gnome2-dbg in ubuntu karmic.

python-gnome2-dev: No summary available for python-gnome2-dev in ubuntu karmic.

No description available for python-gnome2-dev in ubuntu karmic.

python-gnome2-doc: No summary available for python-gnome2-doc in ubuntu karmic.

No description available for python-gnome2-doc in ubuntu karmic.

python-gnomecanvas: No summary available for python-gnomecanvas in ubuntu karmic.

No description available for python-gnomecanvas in ubuntu karmic.

python-gnomecanvas-dbg: No summary available for python-gnomecanvas-dbg in ubuntu karmic.

No description available for python-gnomecanvas-dbg in ubuntu karmic.