Change log for gravitywars package in Ubuntu

110 of 10 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-04-04
Deleted in bionic-proposed (Reason: moved to release)
gravitywars (1.102-34build1) bionic; urgency=high

  * No change rebuild to pick up -fPIE compiler default

 -- Balint Reczey <email address hidden>  Tue, 03 Apr 2018 12:26:44 +0000
Superseded in bionic-release on 2018-04-04
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-11-22
Deleted in xenial-proposed (Reason: moved to release)
gravitywars (1.102-34) unstable; urgency=medium

  * Team upload.
  * Install gravitywars.xpm to /usr/share/pixmaps, so that the icon is
    displayed by all menu systems. Thanks to Michael Terry for the report.
    (Closes: #527745)
  * Switch to source format 3.0 (quilt).
  * gravitywars.desktop: Add keywords and a comment in German.
  * menu: Adjust the icon path.
  * wrap-and-sort -sa.
  * Declare compliance with Debian Policy 3.9.6.
  * Use compat level 9 and require debhelper >= 9.
  * Use canonical Vcs-URI.
  * Remove quilt from Build-Depends because source format 3.0 uses quilt by
    default.
  * d/control: Add ${misc:Depends} substvar.
  * Rewrite debian/rules and switch to dh sequencer.
  * Install man page with manpages file.
  * Install documentation with docs file.
  * Create /var/games/gravitywars and /usr/games with dirs file.
  * Install icons, data and the desktop file with install file.
  * postrm: Use set -e.
  * Remove GravityWars101 with clean file.
  * Add hardening.patch and harden the binary.

 -- Markus Koschany <email address hidden>  Sat, 21 Nov 2015 21:27:21 +0100
Superseded in xenial-release on 2015-11-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
gravitywars (1.102-33ubuntu1) vivid; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - debian/gravitywars.links: (Closes: #527745)
      + Link icon into pixmaps directory for .desktop file to find.
 -- Artur Rona <email address hidden>   Thu, 25 Dec 2014 22:26:04 +0100

Available diffs

Superseded in vivid-release on 2014-12-25
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
gravitywars (1.102-32ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/gravitywars.links: Link icon into pixmaps directory
        for .desktop file to find.

Superseded in karmic-release on 2009-05-08
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
Obsolete in hardy-release on 2015-04-24
gravitywars (1.102-31ubuntu1) hardy; urgency=low

  * Provide a .desktop file (LP: #174906)
  * Debian/control:
    - Update maintainer field
  * Add debian/gravitywars.links

 -- Salvatore Palma <email address hidden>   Sun, 16 Dec 2007 20:31:35 +0100
Superseded in hardy-release on 2007-12-18
Obsolete in gutsy-release on 2011-09-16
gravitywars (1.102-31) unstable; urgency=low

  * debian/control:
    + Fixed the maintainer field.
    + Added Vcs fields.
  * debian/compat:
    + Set level to 5.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  27 Apr 2007 00:00:10 +0100
Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
gravitywars (1.102-30) unstable; urgency=low

  * Moved packaging to the Debian Games Team.
  * Use quilt for patch management.
  * debian/control:
    + Set policy to 3.7.2.
    + Build-depend on quilt.
    + Enhanced the long description and clarified that Gravity Wars is merely
      inspired by, not based on, Gravity Force, and that there is no longer
      an upstream website for it (Closes: #348278).
    + Removed deprecated suidmanager conflict.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Jun 2006 14:13:54 +0100
Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
gravitywars (1.102-29) unstable; urgency=low


  * debian/control:
    + Set policy to 3.6.2.1.
  * debian/postinst:
    + Properly use dpkg-statoverride.
    + Fix deprecated use of chown.
  * Makefile:
    + Compile with -g -O2 instead of -O3 -funroll-loops (Closes: #295695).

 -- Sam Hocevar (Debian packages) <email address hidden>  Sat, 12 Nov 2005 13:07:17 +0100
Obsolete in breezy-release on 2008-03-25
Obsolete in hoary-release on 2008-03-19
gravitywars (1.102-28) unstable; urgency=low


  * debian/control:
    + Set policy to 3.6.1.1.
  * moveship.c:
    + Fixed build with gcc-3.4, thanks to Andreas Jochens (Closes: #258737).
    + Fixed other warnings.

 -- Sam Hocevar (Debian packages) <email address hidden>  Sun, 11 Jul 2004 11:48:51 +0200
Obsolete in warty-release on 2008-01-09
gravitywars (1.102-27) unstable; urgency=low


  * debian/control:
    + Build-depend on libsdl1.2-dev (>= 1.2.5-8) because 1.2.5-7 had a broken
      shlibs file.
    + Removed the build-dependency on dpkg-dev since it is in build-essential.

 -- Sam Hocevar (Debian packages) <email address hidden>  Thu, 12 Jun 2003 13:31:00 +0200
110 of 10 results