Change log for haskell-swish package in Ubuntu

135 of 35 results
Published in eoan-proposed on 2019-08-08
haskell-swish (0.10.0.1-1build1) eoan; urgency=medium

  * Rebuild against new GHC abi.

 -- Gianfranco Costamagna <email address hidden>  Thu, 08 Aug 2019 13:49:57 +0200
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-12-20
Deleted in disco-proposed (Reason: moved to release)
haskell-swish (0.10.0.1-1) unstable; urgency=medium

  [ upstream ]
  * New release.
    + Bump to support polyparse and its GHC 8.6 compatibility.

  [ Jonas Smedegaard ]
  * Update package relations: Relax GHC upper bounds for polyparse.

 -- Jonas Smedegaard <email address hidden>  Tue, 04 Dec 2018 17:07:57 +0100

Available diffs

Superseded in disco-release on 2018-12-20
Published in cosmic-release on 2018-06-27
Deleted in cosmic-proposed (Reason: moved to release)
haskell-swish (0.9.2.1-2) unstable; urgency=medium

  * Simple rebuild.
    Closes: Bug#896974.
  * Update watch file:
    + Fix typo in usage comment.
    + Mention gbp option --upstream-vcs-tag in usage comment.

 -- Jonas Smedegaard <email address hidden>  Tue, 08 May 2018 09:28:49 +0200

Available diffs

Superseded in cosmic-release on 2018-06-27
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-08-21
Deleted in artful-proposed (Reason: moved to release)
haskell-swish (0.9.1.10-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).
    0.9.1.9:
    + Update upper bound on HUnit (only affects tests).
    + Add stack.yaml file.
    0.9.1.10:
    + Update upper bound on time to work with ghc 8.2.1.
    + Updated stack.yaml to use lts 9.1.

 -- Jonas Smedegaard <email address hidden>  Mon, 21 Aug 2017 01:51:45 +0200
Superseded in artful-release on 2017-08-21
Deleted in artful-proposed on 2017-08-22 (Reason: moved to release)
haskell-swish (0.9.1.8-1build1) artful; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Sat, 15 Jul 2017 17:14:33 +0200
Superseded in artful-release on 2017-07-22
Deleted in artful-proposed on 2017-07-23 (Reason: moved to release)
haskell-swish (0.9.1.8-1) unstable; urgency=medium

  [ upstream ]
  * New release.
    + Update upper bound on polyparse and directory.
    + Fix build failure of RDFGraphTest with time >= 1.6.
    + Update copyright years in README.md.

  [ Jonas Smedegaard ]
  * Modernize cdbs:
    + Do copyright-check in maintainer script (not during build).
    + Stop build-depend on licensecheck.
    + Stop explicitly suppress versioned build-dependency on debhelper.
    + Stop track upstream tarbarll checksum: Use gbp --uscan.
  * Update copyright info:
    + Extend coverage for main upstream author.
    + Extend copyright of packaging to cover current year.
    + Use https protocol in format string.
  * Declare compliance with Debian Policy 4.0.0.
  * Stop override lintian for
    package-needs-versioned-debhelper-build-depends: Fixed in lintian.
  * Update package relations:
    + Drop GHC lower bounds for network-uri: Needed version satisfied
      even in oldsable.
  * Modernize git-buildpackage config: Filter any .git* file.
  * Fix enable use of network-url, as intended since 0.9.1.3-1.
    Drop patch 1001.
  * Drop patches 1002 1003: Fixed upstream.
  * Modernize Vcs-* fields:
    + Use https protocol.
    + Consistently use git (not cgit) in paths.

 -- Jonas Smedegaard <email address hidden>  Wed, 21 Jun 2017 09:46:37 +0200
Superseded in artful-proposed on 2017-06-21
haskell-swish (0.9.1.7-3build3) artful; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Wed, 21 Jun 2017 18:55:43 +0200

Available diffs

Superseded in artful-proposed on 2017-06-22
haskell-swish (0.9.1.7-4) unstable; urgency=medium

  * Team upload.
  * Bump directory bounds.

 -- Gianfranco Costamagna <email address hidden>  Wed, 21 Jun 2017 08:16:17 +0200
Superseded in artful-proposed on 2017-06-21
haskell-swish (0.9.1.7-3build2) artful; urgency=medium

  * No-change rebuild for new GHC ABIs

 -- Steve Langasek <email address hidden>  Wed, 21 Jun 2017 05:49:45 +0000

Available diffs

Superseded in artful-release on 2017-06-24
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
haskell-swish (0.9.1.7-3build1) zesty; urgency=medium

  * Bump directory versions on buildds.

 -- Bhavani Shankar <email address hidden>  Thu, 26 Jan 2017 13:07:37 +0530
Superseded in zesty-release on 2017-01-31
Deleted in zesty-proposed on 2017-02-01 (Reason: moved to release)
haskell-swish (0.9.1.7-3) unstable; urgency=medium

  * Modernize CDBS setup: Build-depend on licensecheck (not devscripts).
  * Simply doing this rebuild implies rebuilding against ghc 8.
    Closes: Bug#843404. Thanks to Clint Adams.

 -- Jonas Smedegaard <email address hidden>  Thu, 17 Nov 2016 01:18:10 +0100
Superseded in zesty-release on 2016-11-17
Deleted in zesty-proposed on 2016-11-18 (Reason: moved to release)
haskell-swish (0.9.1.7-2build3) zesty; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Sun, 13 Nov 2016 17:07:52 +0100

Available diffs

Superseded in zesty-release on 2016-11-15
Deleted in zesty-proposed on 2016-11-16 (Reason: moved to release)
haskell-swish (0.9.1.7-2build2) zesty; urgency=medium

  * Rebuild against new GHC ABI.

 -- Gianfranco Costamagna <email address hidden>  Sat, 22 Oct 2016 23:47:40 +0200

Available diffs

Superseded in zesty-release on 2016-10-26
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
haskell-swish (0.9.1.7-2build1) yakkety; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Fri, 15 Jul 2016 15:38:45 +0100
Superseded in yakkety-release on 2016-08-22
Deleted in yakkety-proposed on 2016-08-24 (Reason: moved to release)
haskell-swish (0.9.1.7-2) unstable; urgency=medium

  * Unfuzz patch 1001.
  * Add patch to relax dependency on polyparse.
    Relax build-dependency accordingly.
    Thanks to Sean Whitton.
  * Declare compliance with Debian Policy 3.9.8.

 -- Jonas Smedegaard <email address hidden>  Sun, 29 May 2016 17:35:09 +0200

Available diffs

Superseded in yakkety-release on 2016-07-03
Published in xenial-release on 2016-02-10
Deleted in xenial-proposed (Reason: moved to release)
haskell-swish (0.9.1.7-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).

  [ Jonas Smedegaard ]
  * Declare compliance with Debian Policy 3.9.7.
  * Update copyright info:
    + Extend copyright for main upstream author to cover current year.
    + Extend copyright of packaging to cover current year.

 -- Jonas Smedegaard <email address hidden>  Fri, 05 Feb 2016 13:24:56 +0100
Superseded in xenial-proposed on 2016-02-06
haskell-swish (0.9.1.5-2build1) xenial; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Wed, 13 Jan 2016 11:11:01 +0000
Superseded in xenial-release on 2016-02-10
Deleted in xenial-proposed on 2016-02-11 (Reason: moved to release)
haskell-swish (0.9.1.5-2) unstable; urgency=medium

  * Fix (re-)drop build-dependency (accidentally reverted in 0.9.1.5-1).

 -- Jonas Smedegaard <email address hidden>  Sat, 26 Dec 2015 19:51:40 +0530
Superseded in xenial-proposed on 2015-12-26
haskell-swish (0.9.1.3-2build4) xenial; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Tue, 15 Dec 2015 13:29:20 +0000

Available diffs

Superseded in xenial-release on 2015-12-27
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
haskell-swish (0.9.1.3-2build3) wily; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Sat, 04 Jul 2015 11:42:43 +0100

Available diffs

Superseded in wily-release on 2015-07-10
Deleted in wily-proposed on 2015-07-11 (Reason: moved to release)
haskell-swish (0.9.1.3-2build2) wily; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Thu, 18 Jun 2015 11:17:01 +0100
Superseded in wily-proposed on 2015-06-18
haskell-swish (0.9.1.3-2build1) wily; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Fri, 05 Jun 2015 17:04:25 +0100
Superseded in wily-proposed on 2015-06-05
haskell-swish (0.9.1.3-2) unstable; urgency=medium

  * Drop build-dependency on libghc-transformers-doc, unnecessary with GHC
    7.8.

 -- Colin Watson <email address hidden>  Tue, 12 May 2015 01:25:47 +0100
Superseded in wily-proposed on 2015-05-12
haskell-swish (0.9.1.3-1build1) wily; urgency=medium

  * Rebuild for new GHC ABIs.

 -- Colin Watson <email address hidden>  Tue, 12 May 2015 00:00:11 +0100
Superseded in wily-proposed on 2015-05-12
haskell-swish (0.9.1.3-1) unstable; urgency=medium

  * Move packaging to pkg-haskell Alioth group.
  * Update copyright info: Extend coverage for myself.
  * Bump debhelper compatibility level to 9.
  * Enable use of network-uri.
    Update package relations:
    + Tighten GHC (build-)dependencies on network.
    + Add GHC (build-)dependencies on network-uri.
    + Relax GHC (build-)dependencies on polyparse and semigroups.

 -- Jonas Smedegaard <email address hidden>  Wed, 29 Apr 2015 12:49:13 +0200
Superseded in wily-release on 2015-06-24
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
haskell-swish (0.9.0.15-1build1) vivid; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Thu, 30 Oct 2014 10:07:37 +0000
Superseded in vivid-release on 2014-11-03
Deleted in vivid-proposed on 2014-11-04 (Reason: moved to release)
haskell-swish (0.9.0.15-1) unstable; urgency=medium


  * New upstream version.

 -- Clint Adams <email address hidden>  Tue, 16 Sep 2014 15:21:51 -0400
Superseded in vivid-release on 2014-10-25
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
haskell-swish (0.9.0.14-1build2) utopic; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Sun, 10 Aug 2014 12:38:13 +0200
Superseded in utopic-release on 2014-08-13
Deleted in utopic-proposed on 2014-08-14 (Reason: moved to release)
haskell-swish (0.9.0.14-1build1) utopic; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Wed, 30 Apr 2014 16:39:06 +0100
Superseded in utopic-proposed on 2014-04-30
haskell-swish (0.9.0.14-1) unstable; urgency=medium


  [ Jonas Smedegaard ]
  * Fix update watch file to use Hackage distro-monitor.

  [ Clint Adams ]
  * New upstream version.

 -- Clint Adams <email address hidden>  Tue, 29 Apr 2014 22:47:01 -0400
Superseded in utopic-proposed on 2014-04-30
haskell-swish (0.9.0.12-1build1) utopic; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Tue, 29 Apr 2014 18:19:12 +0100
Superseded in utopic-release on 2014-05-13
Deleted in utopic-proposed on 2014-05-14 (Reason: moved to release)
haskell-swish (0.9.0.12-1) unstable; urgency=medium


  * New upstream version.
  * Bump to Standards-Version 3.9.5.

 -- Clint Adams <email address hidden>  Sun, 20 Apr 2014 10:15:26 -0400
Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2013-12-30
Deleted in trusty-proposed (Reason: moved to release)
haskell-swish (0.9.0.7-1build2) trusty; urgency=medium

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Thu, 19 Dec 2013 18:17:26 +0000

Available diffs

Superseded in trusty-release on 2013-12-30
Deleted in trusty-proposed on 2013-12-31 (Reason: moved to release)
haskell-swish (0.9.0.7-1build1) trusty; urgency=low

  * Rebuild for new GHC ABIs.
 -- Colin Watson <email address hidden>   Sat, 26 Oct 2013 10:52:07 +0100
Superseded in trusty-release on 2013-10-28
Deleted in trusty-proposed on 2013-10-29 (Reason: moved to release)
haskell-swish (0.9.0.7-1) unstable; urgency=low


  [ upstream ]
  * New release.
    + Turtle parser: updated to the Candidate Recommendation (19
      February 2013) specification; added minor improvements to error
      messages when given invalid syntax. As part of the upgrade, there
      is no longer a default namespace set up for the empty prefix and
      numeric literals are no-longer converted into a canonical form.
    + Turtle/N3 output: improved string formatting (better handling of
      string literals with three or more consecutive @\"@ characters);
      blank node handling has been improved but the output may not be as
      elegant.
    + NTriples parser: now accepts upper-case language tags such as
      @en-UK@ (case is preserved).
    + @Swish.QName.LName@ names can now contain @#@, @:@ and @/@
      characters.
    + Added tests for the Turtle parser and formatter.
    + The new @w3ctests@ flag will build the @runw3ctests@ executable,
      which will run the W3C Turtle tests (if available locally).
    + Minor fixes and additions to the documentation.

  [ Jonas Smedegaard ]
  * Extend copyright coverage for main upstream author.

 -- Jonas Smedegaard <email address hidden>  Sun, 15 Sep 2013 20:17:25 +0200
135 of 35 results