Change log for kamoso package in Ubuntu

129 of 29 results
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-06-20
Deleted in artful-proposed (Reason: moved to release)
kamoso (3.2.4-1) unstable; urgency=medium

  * Team upload.

  [ Rohan Garg ]
  * New upstream release

  [ Pino Toscano ]
  * Update Vcs-* fields.
  * Replace deprecated build dependencies:
    - kdoctools-dev -> libkf5doctools-dev
    - kio-dev -> libkf5kio-dev
  * Remove extra shared-desktop-ontologies build dependency.
  * Bump Standards-Version to 4.0.0, no changes required.

 -- Pino Toscano <email address hidden>  Mon, 19 Jun 2017 21:47:04 +0200

Available diffs

Superseded in artful-release on 2017-06-20
Published in zesty-release on 2017-04-11
Deleted in zesty-proposed (Reason: moved to release)
kamoso (3.2.1-1) unstable; urgency=medium

  [ Pino Toscano ]
  * New upstream release.

  [ Rohan Garg ]
  * Fix watch file to take into account the xz extension
  * Add libkf5purpose-dev to build-depends
  * Drop all patches, irrelevant or applied upstream
  * Update rules
    - No need for special case handling anymore
  * Update Build-Depends
  * Drop kipi-plugins from Recommends
  * Add Depends on qml-modules-org-kde-purpose

  [ Maximiliano Curia ]
  * Set myself as uploader
  * Bump Standards-Version to 3.9.8, no changes needed.

 -- Maximiliano Curia <email address hidden>  Tue, 06 Dec 2016 21:03:15 +0100
Superseded in zesty-release on 2017-04-11
Published in yakkety-release on 2016-04-22
Published in xenial-release on 2015-10-22
Published in wily-release on 2015-09-28
Deleted in wily-proposed (Reason: moved to release)
kamoso (3.0.0-0ubuntu1) wily; urgency=medium

  * New upstream release
  * Updating watch file

 -- Clive Johnston <email address hidden>  Thu, 24 Sep 2015 17:33:54 +0100
Superseded in wily-release on 2015-09-28
Deleted in wily-proposed on 2015-09-29 (Reason: moved to release)
kamoso (3.0.0~rc1-0ubuntu1) wily; urgency=medium

  [ Clive Johnston ]
  * New upstream release

  [ Jonathan Riddell ]
  * New upstream snapshot of kf5 version
  * Port packaging to pkg-kde v3

 -- Clive Johnston <email address hidden>  Wed, 27 May 2015 23:21:56 +0100
Deleted in vivid-release on 2016-11-03 (Reason: uses old qt-gstreamer, remove until new version is out)
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
kamoso (2.0.2-2ubuntu3) utopic; urgency=medium

  * Do not build with nepomuk
 -- Jonathan Riddell <email address hidden>   Tue, 29 Jul 2014 17:48:25 +0200

Available diffs

Superseded in utopic-release on 2014-07-29
Published in trusty-release on 2014-04-10
Deleted in trusty-proposed (Reason: moved to release)
kamoso (2.0.2-2ubuntu2) trusty; urgency=medium

  * Add kubuntu_avoid-phonon.patch to not use Phonon anywhere. In trusty
    phonon-backend-gstreamer uses gstreamer1 whereas kamoso still uses 0.10.
    This causes runtime symbol clashes when both gstreamers are loaded. Phonon
    is only used for audbile feedback when taking a snapshot, which is not
    a particularly important feature to the application at large.
    This patch also drops unused code portions elsewhere.
    The patch takes care to only comment out lines, to preserve line count for
    consistency of backtraces.
 -- Harald Sitter <email address hidden>   Thu, 10 Apr 2014 12:50:49 +0200

Available diffs

Superseded in trusty-release on 2014-04-10
Deleted in trusty-proposed on 2014-04-11 (Reason: moved to release)
kamoso (2.0.2-2ubuntu1) trusty; urgency=low

  * Demote kipi-plugins from recommends to suggests.
    Pulls in all sorts of nonesense on the ISO.
 -- Harald Sitter <email address hidden>   Sat, 23 Nov 2013 16:59:29 +0100
Superseded in trusty-release on 2013-11-23
Deleted in trusty-proposed on 2013-11-24 (Reason: moved to release)
kamoso (2.0.2-2) unstable; urgency=low


  * Team upload.

  [ José Manuel Santamaría Lema ]
  * Bump debhelper compatibility level to 9. This enables the hardening flags.

  [ Pino Toscano ]
  * Fix the Vcs-* headers.
  * Backport upstream commit d3c5946f9f48f5d7a5249995424228fc51c84b67 to
    include a needed header; patch upstream_add-include.patch.
  * Backport upstream commits a0aec903b36b52bda1a9a5d2e875af1063747a86 and
    9f32257a1e930b16e64508e6fbfa9390fc0322ee to fix compatibility with libkipi
    2.x; patch upstream_libkipi-2.x.diff.
  * Backport part of upstream commit b8b03322d58a920deac198c2360d65deddccd610
    to rename the youtube icon to kipiplugin_youtube; patch
    upstream_rename-icons.diff. Since renaming sources is not viable, rename
    the actual icons at installation time.
  * Bump Standards-Version to 3.9.4, no changes required.
  * Link in as-needed mode.

 -- Pino Toscano <email address hidden>  Fri, 19 Jul 2013 15:42:37 +0200
Superseded in trusty-release on 2013-11-06
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
kamoso (2.0.2-1ubuntu4) saucy; urgency=low

  * No change rebiuld for libkipi transition
 -- Scott Kitterman <email address hidden>   Thu, 27 Jun 2013 18:42:21 -0400

Available diffs

Superseded in saucy-release on 2013-06-28
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
kamoso (2.0.2-1ubuntu3) raring; urgency=low

  * Add debian/patches/libkipi2.x_port.diff cherry picked from upstream to
    fix FTBFS with libkipi from KDE SC 4.10
  * Set minimum lipkipi version to 4:4.9.80 for now since this version of
    the patch does not build with the older libkipi
 -- Scott Kitterman <email address hidden>   Fri, 21 Dec 2012 12:16:49 -0500

Available diffs

Superseded in raring-release on 2012-12-21
Obsolete in quantal-release on 2015-04-24
kamoso (2.0.2-1ubuntu2) quantal; urgency=low

  * Suggest instead of recommend kipi-plugins since it has a large set of
    dependencies that we don't want to ship on the image.
 -- Felix Geyer <email address hidden>   Mon, 25 Jun 2012 14:50:10 +0200

Available diffs

Superseded in quantal-release on 2012-06-25
kamoso (2.0.2-1ubuntu1) quantal; urgency=low

  * Cherry-pick patch from upstream to fix FTBFS with libkipi9.
    - Add fix_ftbfs_libkipi9.patch
 -- Felix Geyer <email address hidden>   Sun, 10 Jun 2012 10:44:16 +0200

Available diffs

Superseded in quantal-release on 2012-06-10
Published in precise-release on 2012-03-22
kamoso (2.0.2-1build2) precise; urgency=low

  * Rebuild against libkipi 4.8. (LP: #960744)
 -- Felix Geyer <email address hidden>   Thu, 22 Mar 2012 15:50:46 +0100

Available diffs

Superseded in precise-release on 2012-03-22
Obsolete in oneiric-release on 2015-04-24
kamoso (2.0.2-1build1) oneiric; urgency=low

  * No-change rebuild to stop desktop file stripping (LP: #851953)
 -- Harald Sitter <email address hidden>   Fri, 16 Sep 2011 21:18:23 +0200

Available diffs

Superseded in oneiric-release on 2011-09-16
Superseded in oneiric-release on 2011-09-16
kamoso (2.0.2-1) unstable; urgency=low

  * Initial release (Closes: #577639)
 -- Felix Geyer <email address hidden>   Wed,  10 Aug 2011 11:45:50 +0000

Available diffs

Superseded in oneiric-release on 2011-08-10
kamoso (2.0.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
  * Build-depend on kdelibs5-dev instead of kdebase-workspace-dev.
  * Build-depend libqtgstreamer-dev instead of qtgstreamer-dev.
  * Bump Standards-Version to 3.9.2, no changes needed.
  * Switch debhelper compat level 8.
  * Drop unused lintian overrides.
  * Enable parallel building.
 -- Felix Geyer <email address hidden>   Mon, 30 May 2011 11:25:14 +0200

Available diffs

Superseded in oneiric-release on 2011-05-30
Superseded in oneiric-release on 2011-05-24
kamoso (2.0-0ubuntu2) oneiric; urgency=low

  * Remove libvlc-dev from build depends (LP: #712534)
  * Remove vlc from kamoso Depends
 -- Rohan Garg <email address hidden>   Fri, 20 May 2011 19:37:43 +0200

Available diffs

Obsolete in natty-backports on 2013-06-04
kamoso (2.0-0ubuntu1~natty1) natty-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in oneiric-release on 2011-05-20
kamoso (2.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - Drop kubuntu_01_fix_qmax_on_armel.diff
 -- Rohan Garg <email address hidden>   Tue, 17 May 2011 23:12:09 +0200
Superseded in oneiric-release on 2011-05-18
Obsolete in natty-release on 2013-06-04
kamoso (2.0~alpha2-0ubuntu2) natty; urgency=low

  * Add the missing dependency on gstreamer0.10-x. (Otherwise kamoso crashes)
 -- Jonathan Thomas <email address hidden>   Thu, 03 Feb 2011 18:40:53 -0500
Superseded in natty-release on 2011-02-04
kamoso (2.0~alpha2-0ubuntu1) natty; urgency=low

  * New upstream release
  * Added kipi-plugins to Recommends
  * Added (QT)GStreamer, shared-desktop-ontolgies and glib-dev to
    build-depends
  * kubuntu_01_fix_compile.diff vlc11-build-fix removed beacuse they are not
    needed anymore
  * Refreshed and renamed armel-fix-qmax to kubuntu_01_fix_qmax_on_armel.diff
 -- Michal Zajac <email address hidden>   Wed, 02 Feb 2011 18:11:29 +0100
Superseded in natty-release on 2011-02-03
Obsolete in maverick-release on 2013-03-05
kamoso (1.0.5-0ubuntu4) maverick; urgency=low

  * armel-qmax-fix:
    - Fixes non existent call to qMax(qreal, double) on armel bug
    by casting double arg to qreal (LP: #642117)
  * vlc11-build-fix:
    - Replace libvlc_exception and lib_media_player_set_drawable
    related code and to build against vlc 1.1 (LP: #642705)
 -- Niall Creech <email address hidden>   Tue, 21 Sep 2010 11:20:44 +0100

Available diffs

Superseded in maverick-release on 2010-09-21
kamoso (1.0.5-0ubuntu3) maverick; urgency=low

  * Rebuild for libsolidcontrol4 -> libsolidcontrol4a transition
 -- Alessandro Ghersi <email address hidden>   Sat, 12 Jun 2010 04:12:59 +0200

Available diffs

Superseded in maverick-release on 2010-06-13
kamoso (1.0.5-0ubuntu2) maverick; urgency=low

  * Transition from kde.mk to the KDE debhelper sequence from pkg-kde-tools:
    - Add build-depend on pkg-kde-tools 0.5.0 or greater
    - Use debhelper short rules with the KDE sequence in debian/rules
  * Transition to source format 3.0:
    - Bump debhelper build-depend version to 7.3.16 or greater
    - Add debian/source/format, specifying 3.0 (quilt)
  * Bump Standards-Version to 3.8.4
  * Add kubuntu_01_fix_compile.diff to cope with GCC changes that cause
    Kamoso to FTBFS
 -- Jonathan Thomas <email address hidden>   Sat, 05 Jun 2010 16:21:53 -0400

Available diffs

Superseded in maverick-release on 2010-06-05
Obsolete in lucid-release on 2016-10-26
kamoso (1.0.5-0ubuntu1) lucid; urgency=low

  * New upstream bugfix release (LP: #452715)

 -- Jonathan Thomas <email address hidden>   Thu, 15 Oct 2009 22:01:29 -0400

Available diffs

Superseded in lucid-release on 2009-11-03
Obsolete in karmic-release on 2013-03-04
kamoso (1.0.4-0ubuntu1) karmic; urgency=low

  * New upstream bugfix release (LP: #452715)

 -- Jonathan Thomas <email address hidden>   Thu, 15 Oct 2009 22:01:29 -0400

Available diffs

Superseded in karmic-release on 2009-10-16
kamoso (1.0.3-0ubuntu1) karmic; urgency=low

  * New upstream bugfix release (LP: #451791)

 -- Jonathan Thomas <email address hidden>   Wed, 14 Oct 2009 20:32:54 -0400

Available diffs

Superseded in karmic-release on 2009-10-15
kamoso (1.0.1-0ubuntu1) karmic; urgency=low

  * New upstream bugfix release
  * Add lintian overrides (LP: #4285420)
  * Add manpage as generated by kdemangen.pl for easy maintenance

 -- Harald Sitter <email address hidden>   Fri, 18 Sep 2009 18:35:15 +0200

Available diffs

Superseded in karmic-release on 2009-09-18
kamoso (1.0-0ubuntu1) karmic; urgency=low

  * Initial release (LP: #427841)

 -- Harald Sitter <email address hidden>   Fri, 11 Sep 2009 10:59:47 +0200
129 of 29 results