krb5 1.6.dfsg.1-7ubuntu0.2 source package in Ubuntu

Changelog

krb5 (1.6.dfsg.1-7ubuntu0.2) gutsy-security; urgency=low

  * SECURITY UPDATE: denial of service via buffer overflows.
    - src/lib/gssapi/spnego/spnego_mech.c, src/lib/krb5/asn.1/asn1buf.c:
      GSS-API could be crashed remotely (MITKRB5-SA-2009-001: CVE-2009-0844,
      CVE-2009-0845, CVE-2009-0847).
    - src/lib/krb5/asn.1/asn1_decode.c: ASN.1 decoder freed uninitialized
      pointers (MITKRB5-SA-2009-002: CVE-2009-0846).

 -- Kees Cook <email address hidden>   Tue, 07 Apr 2009 12:47:50 -0700

Upload details

Uploaded by:
Kees Cook on 2009-04-07
Uploaded to:
Gutsy
Original maintainer:
Ubuntu Development Team
Architectures:
any
Section:
net
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
krb5_1.6.dfsg.1.orig.tar.gz 13.8 MiB ae5966a43d3fe0045e39631759180ceb16067f16ea67be86f2b489a8a6f22cb2
krb5_1.6.dfsg.1-7ubuntu0.2.diff.gz 1.6 MiB 6a3ac85dc1d55adffceb6bf77388f4e5c81aecdb452d4e92e7c4cd50ad9af7d2
krb5_1.6.dfsg.1-7ubuntu0.2.dsc 1.1 KiB bc0c89fe0b4e8066ea2ddb99aba524b182a04cd99aff9b52bbd57e514e778458

View changes file

Binary packages built by this source

krb5-admin-server: No summary available for krb5-admin-server in ubuntu gutsy.

No description available for krb5-admin-server in ubuntu gutsy.

krb5-clients: No summary available for krb5-clients in ubuntu gutsy.

No description available for krb5-clients in ubuntu gutsy.

krb5-doc: No summary available for krb5-doc in ubuntu gutsy.

No description available for krb5-doc in ubuntu gutsy.

krb5-ftpd: No summary available for krb5-ftpd in ubuntu gutsy.

No description available for krb5-ftpd in ubuntu gutsy.

krb5-kdc: No summary available for krb5-kdc in ubuntu gutsy.

No description available for krb5-kdc in ubuntu gutsy.

krb5-rsh-server: No summary available for krb5-rsh-server in ubuntu gutsy.

No description available for krb5-rsh-server in ubuntu gutsy.

krb5-telnetd: No summary available for krb5-telnetd in ubuntu gutsy.

No description available for krb5-telnetd in ubuntu gutsy.

krb5-user: No summary available for krb5-user in ubuntu gutsy.

No description available for krb5-user in ubuntu gutsy.

libkadm55: No summary available for libkadm55 in ubuntu gutsy.

No description available for libkadm55 in ubuntu gutsy.

libkrb5-dbg: No summary available for libkrb5-dbg in ubuntu gutsy.

No description available for libkrb5-dbg in ubuntu gutsy.

libkrb5-dev: No summary available for libkrb5-dev in ubuntu gutsy.

No description available for libkrb5-dev in ubuntu gutsy.

libkrb53: No summary available for libkrb53 in ubuntu gutsy.

No description available for libkrb53 in ubuntu gutsy.