libgc 1:7.4.2-8ubuntu0.1 source package in Ubuntu

Changelog

libgc (1:7.4.2-8ubuntu0.1) yakkety-security; urgency=medium

  * SECURITY UPDATE: multiple integer overflows leading to pointers to
    memory zones smaller than requested size.
    - d/p/CVE-2016-9427-1.patch: Fix calloc_explicitly_typed in case
      of lb*n overflow.
    - d/p/CVE-2016-9427-2.patch: Fix malloc routines to prevent size
      value wrap-around of lb*n overflow.
    - d/p/CVE-2016-9427-3.patch: Fix GC_collect_or_expand to prevent
      allocation size value wrap-around
    - d/p/CVE-2016-9427-test.patch: add test cases
    - CVE-2016-9427
  * d/p/workaround-gcc-6-gnu++14.patch: Work around libgc test failure
    due to --std=gnu++14 (https://github.com/ivmai/bdwgc/issues/87)

 -- Steve Beattie <email address hidden>  Mon, 13 Feb 2017 11:50:02 -0800

Upload details

Uploaded by:
Steve Beattie on 2017-02-14
Uploaded to:
Yakkety
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
libgc_7.4.2.orig.tar.gz 713.3 KiB 09f21d38dd42bced14d6875f55804cb1b5e6bc486da7980187ecd2e768739c62
libgc_7.4.2-8ubuntu0.1.debian.tar.xz 24.0 KiB f13be98bb9478561e1498858c8cf37b96a6b8020131b636976d886ce6a611be4
libgc_7.4.2-8ubuntu0.1.dsc 2.1 KiB a9b90bc4ff28bf58fe6646f605b764ceccfe1719b8bde81818fb56022591b559

View changes file

Binary packages built by this source

libgc-dev: No summary available for libgc-dev in ubuntu yakkety.

No description available for libgc-dev in ubuntu yakkety.

libgc1c2: No summary available for libgc1c2 in ubuntu yakkety.

No description available for libgc1c2 in ubuntu yakkety.

libgc1c2-dbgsym: No summary available for libgc1c2-dbgsym in ubuntu yakkety.

No description available for libgc1c2-dbgsym in ubuntu yakkety.