Change log for libgd-gd2-perl package in Ubuntu

122 of 22 results
Deleted in wily-release on 2018-01-19 (Reason: (From Debian) NVIU; superceded by libgd-perl; Debian bug ...)
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
libgd-gd2-perl (1:2.46-3.1build2) utopic; urgency=medium

  * Rebuild for Perl 5.20.0.
 -- Colin Watson <email address hidden>   Tue, 19 Aug 2014 18:00:18 +0100
Superseded in utopic-release on 2014-08-27
Published in trusty-release on 2013-10-24
Deleted in trusty-proposed (Reason: moved to release)
libgd-gd2-perl (1:2.46-3.1build1) trusty; urgency=low

  * Rebuild for Perl 5.18.
 -- Colin Watson <email address hidden>   Mon, 21 Oct 2013 10:06:25 +0100
Superseded in trusty-release on 2013-10-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libgd-gd2-perl (1:2.46-3.1) unstable; urgency=low


  * Non-maintainer upload.
  * Add regression test files matching libgd 2.1.0-rc1, confirmed to be
    visually indistinguishable (closes: #709048).

 -- Colin Watson <email address hidden>  Sat, 22 Jun 2013 11:26:00 +0100
Superseded in saucy-release on 2013-06-25
Deleted in saucy-proposed on 2013-06-26 (Reason: moved to release)
libgd-gd2-perl (1:2.46-3ubuntu1) saucy; urgency=low

  * Add regression test files matching libgd 2.1.0-rc1, confirmed to be
    visually indistinguishable (closes: #709048).
 -- Colin Watson <email address hidden>   Sat, 01 Jun 2013 23:42:56 +0100
Superseded in saucy-proposed on 2013-06-01
libgd-gd2-perl (1:2.46-3build3) saucy; urgency=low

  * Rebuild for libgd3.
 -- Colin Watson <email address hidden>   Mon, 20 May 2013 00:10:49 +0100

Available diffs

Superseded in saucy-release on 2013-06-02
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
libgd-gd2-perl (1:2.46-3build2) quantal; urgency=low

  * Rebuild for new armel compiler default of ARMv5t.
 -- Colin Watson <email address hidden>   Thu, 04 Oct 2012 16:25:57 +0100

Available diffs

Superseded in quantal-release on 2012-10-04
Published in precise-release on 2011-11-15
libgd-gd2-perl (1:2.46-3build1) precise; urgency=low

  * Rebuild for Perl 5.14.
 -- Colin Watson <email address hidden>   Tue, 15 Nov 2011 19:55:00 +0000

Available diffs

Superseded in precise-release on 2011-11-15
libgd-gd2-perl (1:2.46-3) unstable; urgency=low

  * Fix FTBFS on perl 5.14: append $Config{ccflags} to CCFLAGS
    (Closes: #636649)

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
libgd-gd2-perl (1:2.46-1) unstable; urgency=low

  * New upstream release.
  * Tidy watch file: Strip unneeded + in regexp.
  * Update copyright file:
    + Rewrite using draft 174 of DEP-5 format.
    + Extend copyright years for Debian packaging.
    + Fix use initial wildcard Files section.
    + Rewrap license fields at 72 chars.
  * Bump policy compliance to standards-version 3.9.2.
  * Drop removal-during-install of no longer shipped bdf2gdfont.pl.
  * Improve package relations:
    + Relax (drop versioning) for package satisifed even in oldstable:
      - libgd2-xpm-dev
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  09 May 2011 11:52:57 +0000

Available diffs

Superseded in oneiric-release on 2011-05-09
libgd-gd2-perl (1:2.45-2build1) oneiric; urgency=low

  * Rebuild for Perl 5.12.
 -- Colin Watson <email address hidden>   Sat, 07 May 2011 02:01:41 +0100

Available diffs

Superseded in oneiric-release on 2011-05-07
libgd-gd2-perl (1:2.45-2) unstable; urgency=low

  * Fix update watch file to track both by-modules and search.cpan.org.

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
libgd-gd2-perl (1:2.41-1) unstable; urgency=low

  * New upstream release.
  * Drop locally included CDBS snippets: included in main cdbs now.
  * Packaging moved to Git:
    + Update Vcs stanzas.
    + Add git-buildpackage configfile, enabling signed tags and use of
      pristine-tar.
    + Use source format 3.0 (quilt), with suitable local-options.
    + Git-ignore quilt .pc dir.
  * Drop Sean Finney as uploader, to reflect reality.
  * Add proper licensing header to debian/rules. Extend copyright years.
  * Add README.source. Drop custom hints about CDBS.
  * Strip now obsolete suffices from watch file.
  * Ease backporting to Debian stable: Relax inclusion of CDBS snippets
    required only in DEB_MAINTAINER_MODE, and suppress related build-
    dependencies.
  * Rewrite copyright file using draft rev135 of DEP5 format.
  * Suppress some graphics from copyright-check.
  * Update README.source to not mention quilt: Source format 3.0 use it
    internally, but there it is standard and thus need no mention here.
  * Bump Policy compliance to standards-version 3.9.1.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  18 Oct 2010 08:38:34 +0000

Available diffs

Superseded in natty-release on 2010-10-18
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
libgd-gd2-perl (1:2.39-2build1) lucid; urgency=low

  * rebuild rest of main for armel armv7/thumb2 optimization;
    UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2
 -- Alexander Sack <email address hidden>   Sat, 06 Mar 2010 13:32:55 +0100

Available diffs

Superseded in lucid-release on 2010-03-06
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
libgd-gd2-perl (1:2.39-2) unstable; urgency=medium

  * Invoke svn-upgrade (not uupdate) in debian/watch.
  * Set urgency=medium as 1:2.39-2 included a FTBFS bugfix (similar to
    bug#487066).

Available diffs

Superseded in intrepid-release on 2008-07-02
libgd-gd2-perl (1:2.35-1build2) intrepid; urgency=low

  * Rebuild against Perl 5.10 (this time on hppa too).

 -- Colin Watson <email address hidden>   Sat, 14 Jun 2008 17:11:39 +0100

Available diffs

Superseded in intrepid-release on 2008-06-14
libgd-gd2-perl (1:2.35-1build1) intrepid; urgency=low

  * Rebuild for the perl 5.10 transition (LP: #229918).

 -- Michael Bienia <email address hidden>   Tue, 13 May 2008 14:14:05 +0200
Superseded in intrepid-release on 2008-05-14
Obsolete in hardy-release on 2015-04-24
libgd-gd2-perl (1:2.35-1) unstable; urgency=low

  * New upstream release.
  * Switch to team maintainance using Alioth project pkg-gd, and myself
    and Sean Finney as uploaders. If you (yes, you!) want to help
    packaging GD and related packages for Debian, please get in touch
    with us at <email address hidden> .
  * Update CDBS tweaks:
    + Replace auto-update.mk with overloading buildcore.mk.
    + Fix applying buildinfo only once.
    + Fix race condition: check copyright strings in pre-build target
      (not clean target). Closes: bug#424523, thanks to Lucas Nussbaum
      for discovering and Patrick Winnertz for reporting.
    + Add upstream-tarball.mk to implement get-orig-source target.
    + Add debian/README.cdbs-tweaks and advertise it in debian/rules.
  * Declare build-dependencies in debian/rules. Drop deprecated fallback
    build-dependencies on old X11 packages.
  * Semi-auto-update debian/control:
      DEB_BUILD_OPTIONS=cdbs-autoupdate fakeroot debian/rules pre-build

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Oct 2007 17:09:22 +0100
Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
libgd-gd2-perl (1:2.34-1) unstable; urgency=low

  * New upstream release.
  * Bump standards-version to 3.7.2 (no changes needed).
  * Advertise search.cpan.org as Homepage (not "Website") in long
    description.
  * Bump watch file version and use uversionmangle to chop 3-digit minor
    version into manageable pieces (2.041->2.04.1 is lower than 2.05).
  * Add local cdbs snippet copyright-check.mk.
  * Move cdbs auto-update activation to local snippet auto-update.mk.
  * Update local cdbs snippet buildinfo.mk to use correct namespace.
  * Quote a couple of install paths (even though cdbs itself does not
    claim to support funny characters in builddir).
  * Update debian/copyright, thanks to copyright-check.mk: bdf2gdfont.pl
    has same license but different owner.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  07 Nov 2006 02:25:00 +0000
Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
libgd-gd2-perl (1:2.30-1) unstable; urgency=low


  * New upstream release.

 -- Jonas Smedegaard <email address hidden>  Sun, 30 Oct 2005 13:13:09 +0100
Obsolete in breezy-release on 2008-03-25
libgd-gd2-perl (1:2.23-1) unstable; urgency=low


  * New upstream release.

 -- Jonas Smedegaard <email address hidden>  Sat, 26 Mar 2005 04:07:10 +0100
Obsolete in hoary-release on 2008-03-19
libgd-gd2-perl (1:2.19-1) unstable; urgency=low


  * New upstream release.
    + Tests updated, which closes: Bug#282370 (thanks to Kurt Roeckx
      <email address hidden>).
  * Build-depend on libxpm-dev and libx11-dev, and on xlibs-dev only as
    fallback.
  * Improve debian/rules:
    + Correctly install docs and example code.
    + Invoke dh-buildinfo from cdbs snippet (included locally for now).
    + Clean temporary files slightly more agressively.
    + Install bdf2gdfont.pl only as example script (not below /usr/bin).
    + Add more comments.
    + Make it generic: same file for both libgd-gd2-noxpm-perl and
      libgd-gd2-perl.
  * Tighten build-dependency on debhelper to please linda.
  * Rewrite long description: Mention some of the features and supported
    graphics formats.

 -- Jonas Smedegaard <email address hidden>  Fri, 26 Nov 2004 15:47:08 +0100
Obsolete in warty-release on 2008-01-09
libgd-gd2-perl (1:2.12-1) unstable; urgency=low


  * New upstream release. Closes: Bug#227307 (anyhow, thanks to Daniel
    Schepler <email address hidden>, Bencsath Boldizsar
    <email address hidden>, and Marc 'HE' Brockschmidt
    <email address hidden> for their efforts).
  * Add epoch to get back to sane version number again.
  * Use "debian" as current version in watch file.

 -- Jonas Smedegaard <email address hidden>  Fri, 16 Apr 2004 18:14:03 +0200
122 of 22 results