libsoap-lite-perl 0.710.10-1 source package in Ubuntu

Changelog

libsoap-lite-perl (0.710.10-1) unstable; urgency=low

  [ Nathan Handler ]
  * debian/watch: Update to ignore development releases.

  [ gregor herrmann ]
  * Change source package name to libsoap-lite-perl.

  [ Jonathan Yu ]
  * New upstream release
  * Rename examples -> libsoap-lite-perl.examples
  * Standards-Version 3.8.3 (no changes)
  * Use new short debhelper rules format
  * Slight rewrite to control description
  * Refresh quilt patches & remove those applied upstream

  [ gregor herrmann ]
  * debian/control: Changed: (build-)depend on perl instead of perl-
    modules.
  * Put the whole renaming/hashbang-fixing/... stuff into debian/rules (was
    split between a patch and debian/rules); remove remaining patch and quilt
    framework.
  * Fix hashbang in examples.
  * debian/control: add (build) dependency on libtask-weaken-perl, perl (>=
    5.10.1) (for constant 1.14); add "perl (>= 5.10) | libio-compress-perl" as
    alternative (build) dependencies to libcompress-zlib-perl.
  * debian/rules: explicitly turn off author tests.

soap-lite (0.710.08-2) unstable; urgency=low

  [ Damyan Ivanov ]
  * drop disabled patches that are included upstream
    + no_service_parameter.diff (since 0.710.08)
    + warnings-redefine.patch (since 0.710.05)
    + fix_xml_parser_lite_from_cvs (since 0.71)
  * add description to all patches
  * add fix-missing-import.diff, fixing missing imports for BAD_REQUEST apache
    constant. Thanks to Erik Anderson. Closes: #509625
  * remove (now unused) debian/lintian-overrides

  [ gregor herrmann ]
  * debian/control: Changed: Switched Vcs-Browser field to ViewSVN
    (source stanza).
  * debian/control: Added: ${misc:Depends} to Depends: field.

soap-lite (0.710.08-1) unstable; urgency=low

  * New upstream bugfix release
  * refresh makefile_exe_files.diff to apply again
  * update copyright information

soap-lite (0.710.07-1) unstable; urgency=low

  [ gregor herrmann ]
  * debian/control:
    - replace libmime-perl by libmime-tools-perl
    - make dependency on quilt versioned
    - change my email address
    - add 'perl-modules (>= 5.10.0) | libversion-perl' to Depends
      (closes: #485983), thanks to dleonard for the bug report

  [ Damyan Ivanov ]
  * New upstream release
  * strip-down debian/rules with debhelper 7; adjust dh compat level and
    build-dependency accordingly
    + do not install redundant README
  * add myself to Uploaders
  * Standards-Version: 3.8.0
    + add README.source about quilt usage

soap-lite (0.710.06-1) unstable; urgency=low

  * New upstream release.

soap-lite (0.710.05-1) unstable; urgency=low

  [ Martín Ferrari ]
  * New upstream release.
  * debian/control: updated my email address; added dependency on
    "perl-modules (>= 5.10.0) | libversion-perl" as version.pm is now
    required.
  * debian/watch: seems that upstream moved back to CPAN, and they're using
    sane version numbers!
  * debian/control,compat: moved back to debhelper 5, as it seems to be the
    current concensus.
  * debian/patches/series: disable warnings-redefine.patch, already applied
    upstream.

  [ gregor herrmann ]
  * Add lintian overrides for warnings about long lines in manpages which
    are caused by long URLs.
  * Refresh remaining patches.

soap-lite (0.71-2) unstable; urgency=low

  * Add patch warnings-redefine.patch to again suppress two harmless
    warnings (closes: #470090).
  * debian/rules: remove obsolete source and diff targets; add install
    target to .PHONY.

soap-lite (0.71-1) unstable; urgency=low

  [ gregor herrmann ]
  * debian/watch: make regexp for upstream versions more strict, we don't
    want -1 releases.

  [ Martín Ferrari ]
  * New upstream release.
  * debian/patches: updated patches to apply cleanly, disable patch included
    in new release.
  * 0.70_07 fixed the test failures under perl 5.10, confirmed by my perl10
    chroot (Closes: #467320).
  * debian/control: add libtest-mockobject-perl to B-D-I, to improve tests;
    libtest-pod-coverage-perl is not added, as the tests fail.
  * debian/rules: cleaned a little; touch Makefile before clean, because the
    patching/unpatching dance makes it unhappy.

soap-lite (0.70.04-4) unstable; urgency=medium

  * debian/control: added myself to Uploaders.
  * debian/watch: only scan tarballs, as the ZIP files are PPM bundles.
  * debian/patches/more_tests_to_run.diff: t/40-loopback.t and
    t/27-xmlparserlite.t should be run too.
  * debian/patches/fix_xml_parser_lite_from_cvs: fix lib/XML/Parser/Lite.pm
    brokenness, taken from CVS. Closes: #465198.
  * debian/copyright: updated cp info for lib/XML/Parser/Lite.pm, s/(C)/©/.
  * Urgency set to medium as this will fix two FTBFS (RC) bugs.

soap-lite (0.70.04-3) unstable; urgency=medium

  * Add nullmailer | mail-transport-agent to build dependencies to make
    tests pass (needed by libmime-lite-perl) (closes: #464316).
  * Urgency set to medium because of the FTBFS bug.
  * Add /me to Uploaders.

soap-lite (0.70.04-2) unstable; urgency=low

  [ gregor herrmann ]
  * Move libnet-jabber-perl from Recommends to Suggests, thanks to Josh
    Triplett (closes: #462307).
  * Move libmime-lite-perl from Depends to Suggests, thanks to Josh Triplett
    (closes: #462316).

soap-lite (0.70.04-1) unstable; urgency=low

  [ gregor herrmann ]
  * New upstream release (closes: #458598).
  * debian/control:
    - added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza)
    - added: Homepage field (source stanza), using Sourceforge URL
    - removed: XS-Vcs-Svn fields
  * debian/watch:
    - use Sourceforge download URL (more recent than CPAN)
    - use uversionmangle to deal with underlines in upstream version
  * debian/control:
    - set Standards-Version to 3.7.3 (no changes needed)
    - wrap long lines
  * debian/rules:
    - remove compiler flags and variables, this package is arch:all
    - move dh_clean and rm's before make distclean
    - remove /usr/lib/perl5 only if it exists
    - remove unused/commented dh_* calls
    - introduce fix-scripts-stamp to make debian/rules parallel-build-safe
  * Create patch makefile_exe_files.diff instead of changing Makefile.PL
    directly; adding quilt framework accordingly.
  * debian/copyright:
    - add location for recent upstream releases
    - update years of copyright
    - include other copyright holders
    - convert to new format
  * Bump debhelper compatibility level.

soap-lite (0.69-2) unstable; urgency=low

  * Mention the Debian Perl Group and the upstream URL in debian/copyright,
    thanks to Matej Vela (closes: #430464).
  * Remove libapache-mod-perl from Suggests: in debian/control.
  * Remove duplicate libmime-perl from Build-Depends-Indep in
    debian/control.

soap-lite (0.69-1) unstable; urgency=low

  * New upstream release

soap-lite (0.68-1) unstable; urgency=low

  * New upstream release
  * debian/compat:
   + increased to 5
  * debian/control:
   + Standards-Version: increased to 3.7.2.1 without changes

soap-lite (0.67-1) unstable; urgency=low

  * New upstream release (closes: #349159)

soap-lite (0.66.1-1) unstable; urgency=low

  * New upstream release

soap-lite (0.66-2) unstable; urgency=low

  * Fix the scripts in bin/ at build-time rather than statically, to
    make sure they stay up to date. (Closes: #345318)
    + remove .pl extensions
    + fix the shebang lines to /usr/bin/perl
    + change any references to the script name inside the script too
  * New version of stubmaker includes a manual page; removed symlink
    to undocumented(7). (Closes: #280504)
  * Don't ignore the return value of 'make distclean'.
  * Conflict with libsoap-perl (which has been removed after sarge)
    because both include a Soap::Packager module. (Closes: #345385)
  * Add myself to Uploaders.
  * Move debhelper from Build-Depends-Indep to Build-Depends, as per policy.
  * Remove the execute bit from two MS-DOS batch files in examples.
  * Remove the feature list from the package description, since it was
    still rendering incorrectly and was much too long in the first place.
  * Run 'make test' at build time.

soap-lite (0.66-1) unstable; urgency=low

  * New upstream release (closes: #344737)
  * debian/control:
    - Build-Depends-Indep & Depends updated 
    - Standards-Version bumped to 3.6.2
    - Fixed long description (closes: #323497)

soap-lite (0.60-2) unstable; urgency=low

  * XMLRPCsh: Removed .pl language-specific extension
  * XMLRPCsh: Changed env hashbang lines to reference /usr/bin/perl as per 
    Debian Perl Policy
  * SOAPsh: Removed .pl language-specific extension
  * SOAPsh: Changed env hashbang lines to reference /usr/bin/perl as per 
    Debian Perl Policy
  * stubmaker: Removed .pl language-specific extension
  * stubmaker: Changed env hashbang lines to reference /usr/bin/perl as per 
    Debian Perl Policy
  * Included examples
  * Lite.pm: Removed reference to test suite file (Closes: #178059)
  * Included synmlink to undocumented man page for stubmaker
  
soap-lite (0.60-1) unstable; urgency=low

  * Upgraded to new release 0.60; New maintainer.

soap-lite (0.55-4) unstable; urgency=low

  * New maintainer.

soap-lite (0.55-3) unstable; urgency=low

  * debian/control: Remove libcrypt-ssleay-perl from Build-Depends and
    Suggests as this package is still in non-US. (Closes: #162260)

soap-lite (0.55-2) unstable; urgency=low

  * debian/control: Added Suggests: libcrypt-ssleay-perl (Closes: #150300)

soap-lite (0.55-1) unstable; urgency=high

  * Upgraded new upstream release with, among others, a fix for a security
    vulnerability with fully qualified method names (Closes: #142078)

soap-lite (0.52-3) unstable; urgency=low

  * debian/rules: Don't call dh_installmanpages; it is a) not needed as
    'make install' does its work and b) erroneously drops the man pages
    for SOAPsh.pl and XMLRPCsh.pl in man/pl/man1 (Closes: #137816)

soap-lite (0.52-2) unstable; urgency=low

  * debian/control: Spelling correction (Closes: #125050)

soap-lite (0.52-1) unstable; urgency=low

  * Upgraded to new release

soap-lite (0.51-1) unstable; urgency=low

  * Upgraded to new release 0.51

soap-lite (0.50-1) unstable; urgency=low

  * Upgraded to new release 0.50

soap-lite (0.47-1) unstable; urgency=low

  * Initial Release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  05 Dec 2009 11:19:31 +0000

Upload details

Uploaded by:
Ubuntu Archive Auto-Sync on 2009-12-05
Uploaded to:
Lucid
Original maintainer:
Debian Perl Group
Architectures:
all
Section:
perl
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Lucid: [FULLYBUILT] i386

Downloads

File Size SHA-256 Checksum
libsoap-lite-perl_0.710.10.orig.tar.gz 238.5 KiB 08524c6af908fcc2a6ac3a15038c9af650a5c63006f45673ed4d4ccf8af295f2
libsoap-lite-perl_0.710.10-1.diff.gz 5.9 KiB 1a3287cf7004e7471b1ba00b0178f254a044980177cdb293b853d767ebb31e9b
libsoap-lite-perl_0.710.10-1.dsc 1.8 KiB ba57798eec8e2dade857f9ac572458e1cad99812b9a9ce82c2ae5687c3eb1208

View changes file

Binary packages built by this source

libsoap-lite-perl: No summary available for libsoap-lite-perl in ubuntu maverick.

No description available for libsoap-lite-perl in ubuntu maverick.