libxi 2:1.3-3ubuntu0.2 source package in Ubuntu

Changelog

libxi (2:1.3-3ubuntu0.2) lucid-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect memory size calculations
    - debian/patches/CVE-2013-1984.patch: fix multiple integer overflows.
    - CVE-2013-1984
  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect memory size calculations from signedness issues
    - debian/patches/CVE-2013-1995.patch: fix signedness issues in
      src/XListDev.c.
    - CVE-2013-1995
  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect length and bounds checking
    - debian/patches/CVE-2013-1998.patch: properly check lengths and
      indexes in src/XGetBMap.c, src/XIPassiveGrab.c, src/XQueryDv.c.
    - CVE-2013-1998
 -- Marc Deslauriers <email address hidden>   Wed, 29 May 2013 10:40:33 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2013-06-05
Uploaded to:
Lucid
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
x11
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
libxi_1.3.orig.tar.gz 424.5 KiB 1739a14403ec2e74e208f1748da005b98c376a9a43b63ce5f117e3f9fb6f29a5
libxi_1.3-3ubuntu0.2.diff.gz 24.8 KiB bfc6febfd5d09947fa4df2a8cfc9ec62083144d97d7d25072dae9c16fbc30050
libxi_1.3-3ubuntu0.2.dsc 2.1 KiB 061ea01fe85943fccfcf64f96806ca5be054899b33a8378e64d234e721eb7dbc

View changes file

Binary packages built by this source

libxi-dev: No summary available for libxi-dev in ubuntu lucid.

No description available for libxi-dev in ubuntu lucid.

libxi6: No summary available for libxi6 in ubuntu lucid.

No description available for libxi6 in ubuntu lucid.

libxi6-dbg: No summary available for libxi6-dbg in ubuntu lucid.

No description available for libxi6-dbg in ubuntu lucid.