Ubuntu

sky2 driver freezing system after ifdown and ifup

Reported by capacman on 2006-04-09
128
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.15 (Ubuntu)
Undecided
Ben Collins
linux-source-2.6.15 (Ubuntu)
High
Ben Collins
linux-source-2.6.17 (Ubuntu)
High
Ben Collins

Bug Description

My system is freezing when i issue command
sudo ifdown eth0
sudo ifup eth0

This did not happen in linux-image-2.6.15-19-686. I tried same commands in different computer with different ethernet card and it works. I think the problem is related to sky2 driver.
This is the output in /var/log/messages when issue those commands:
Apr 9 01:48:16 localhost kernel: [4301524.091000] sky2 eth0: disabling interface
Apr 9 01:48:16 localhost kernel: [4301524.136000] sky2 eth0: enabling interface
Apr 9 01:48:17 localhost kernel: [4301525.786000] sky2 eth0: Link is up at 100 Mbps, full duplex, flow control both
Apr 9 01:49:33 localhost syslogd 1.4.1#17ubuntu5: restart.
I have to restart after those commands.

Barry Shilliday (teppic74) wrote :

I can confirm this problem on my system too. Also with the sky2 driver - bringing the network down and up again causes a hard lock.

Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed
capacman (achalil) wrote :

Sometimes it does not lock the computer but give this error message
capacman@ubuntu:~$ sudo ifup eth0
Password:
capacman@ubuntu:~$ sudo ifdown eth0
capacman@ubuntu:~$ sudo ifup eth0
Error : Name or service not known

corresponding /var/log/messages entry:
[4294776.583000] sky2 eth0: enabling interface
[4294776.593000] ADDRCONF(NETDEV_UP): eth0: link is not ready
[4294778.287000] sky2 eth0: Link is up at 100 Mbps, full duplex, flow control both
[4294778.294000] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[4294788.080000] sky2 eth0: disabling interface
[4294790.073000] sky2 eth0: enabling interface
[4294791.759000] sky2 eth0: Link is up at 100 Mbps, full duplex, flow control both
[4294801.074000] eth0: no IPv6 routers present

Albert Vilella (avilella) wrote :

This is also happening to me.
I had another crash while doing a "sudo dhclient".
This:
----
bogus UDP packet length: 328
bogus UDP packet length: 328
bogus UDP packet length: 328
bogus UDP packet length: 328
----
Appeared in the screen just before the crash.

I am using 2.6.15.20 kernel:
Linux magneto 2.6.15-20-686 #1 SMP PREEMPT Tue Apr 4 18:37:00 UTC 2006 i686 GNU/Linux

Barry Shilliday (teppic74) wrote :

Kernel panic is still occuring on reactivation of the sky2 driver with the latest kernel (2.6.15-22)

Part of the panic (most scrolls by off screen)

sky2_status_intr+0x20d/0x350 [sky2]
sky2_poll+0x54/0x230 [sky2]
update_wall_time+0x1a/0x50
net_rx_action+0xdc/0x1f0
__do_softirq+0x76/0xe0

Kernel panic - not syncing: Fatal exception in interrupt

It seems that there's a new release of sky2 driver (1.3) that fixes some issues:

sky2: backout NAPI reschedule
sky2: status irq hang fix
sky2: tx ring index mask fix
sky2: use mask instead of modulo operation
sky2: edge triggered workaround enhancement
sky2: dont write status ring
sky2: synchronize irq on remove
sky2: Add more support for the Yukon Ultra chip found in dual core centino laptops.

There are about 15 bugs opened about sky2 driver! We desperately need to choose: sync with upstream or revert back to the old syskonnect driver (sk98lin)

http://marc.theaimsgroup.com/?l=linux-netdev&m=114713054104179&w=2

Albert Vilella (avilella) wrote :

If sky2 is still buggy and sk98lin does the trick: what is the preferred way to substitue sk98lin for sky2?
I noticed there is sort of a blacklist of devices in /etc/modprobe.d/

Ben Collins (ben-collins) wrote :

I've backported the sky2 driver from 2.6.16.13. It will be in the next kernel upload. Please test when it is available.

Changed in linux-source-2.6.15:
assignee: nobody → ben-collins
status: Confirmed → Fix Committed

Ben, sky2 version 0.15 is also known as buggy...i think you have to sync with the Stephen Shemminger's netdev git tree which include the last version (1.3)

http://www.kernel.org/git/?p=linux/kernel/git/shemminger/netdev-2.6.git;a=summary

I found this reading netdev mailing list...i think it's closely related to this bug...

[PATCH] sky2: ifdown kills irq mask
Stephen Hemminger
Tue, 09 May 2006 14:47:11 -0700

Bringing down a port also masks off the status and other IRQ's
needed for device to function due to missing paren's.

http://mail-archive.com/netdev%40vger.kernel.org/msg12133.html

rick (sheepiedog) wrote :

I've just tried the latest vanilla git snapshop 2.6.17-rc3-git17. It contains v1.3 and I was hoping it would stop my card (88E8036) freezing. It didn't. Hopefully this driver is getting better but it still isn't there. I will continue to try new releases but until they work, the syskonnect driver is the only reliable solution. I know the code is supposedly ugly but at least it works. Can we not have it in ubuntu kernels?

Three days ago Ben Collins has backported the patch I mentioned above from upstream:

[UBUNTU:net/sky2] Fix irq masks

Bringing down a port also masks off the status and other IRQ's
needed for device to function due to missing paren's.

Signed-off-by: Stephen Hemminger
Signed-off-by: Ben Collins <email address hidden>

angystardust hugs BenC ;-)

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
capacman (achalil) wrote :

The problem seems to be fixed with linux-image-2.6.15-23-686. There is no problem with ifup/ifdown for now.

Barry Shilliday (teppic74) wrote :

Same here - no longer any problems.

anonym (launch-mailinator) wrote :

I still have the problem. I can reproduce the problem using linux-image-2.6.15-23-686 by wgetting a large file, for example an iso.

The problem occurs for a large download in any program (apt. lynx, etc), but an scp of a file from a local machine does not show the problem, only downloads from the internet. I assume this is due to a timing issue.

Albert Vilella (avilella) wrote :

It is still hard-locking my laptop with linux-image-2.6.15-23-686 when I do fancy networking, like scp or rsync. The symptoms usually are: loosing connection, ifdowning/ifuping recovers the connection, but hard-locking the computer very often when scping or rsyncing things.

The problem occurs not only while downloading from internet. Sky2 also hangs while copying files over samba, ftp, rsync, ... in local network. I'm not able to send a 600MB iso over network without a crash. There were unfortunately no improvements with latest kernel updates.

JosefK (josefk) wrote :

I can confirm sky2 freezing when transferring file, but it's rare that I get the hard-lock. Notably, my problems started with release -23.

I filed bug #46326.

JosefK (josefk) wrote :

I can confirm sky2 freezing when transferring file, but it's rare that I get the hard-lock. Notably, my problems have also started with release -23.

I filed bug #46326.

pogets (pogets) wrote :

I have the same problem: my network card (Marvell 88E8036 Fast Ethernet Controller with sky2 driver) stops working upon file transfers (in my case, transferring from an NFS-mounted file system to a local one). Ifdown/ifup does not solve the problem after a freeze, only rebooting does. I had posted this as a comment to Bug #40282 before, but the two problems seem to be related, so I repost here.

You don't have to reboot. You can try "rmmod sky2" and "modprobe sky2" to "solve" the problem until the next freeze... What informations can we provide to help solving this bug?

Barry Shilliday (teppic74) wrote :

One possibility is to use the latest version of the sky2 driver - 1.4. This includes a fix for the kernel panic bug, and I believe the large transfer issues were already fixed in earlier 1.x releases.

nodata (ubuntu-nodata) wrote :

BenCollins: Is there any chance that your backport can be upgraded to version 1.4 of the sky2 driver?

pogets (pogets) wrote :

Now that the final version of Dapper has been released, I was wondering if someone is still working on this bug, or should we resign ourselves to manually patch the kernel and install the sk98lin driver? I've been using my wireless network exclusively since upgrading to dapper due to this problem, but it would be really nice to be able to use my ethernet card again.

Ben Collins (ben-collins) wrote :

I've pushed the driver in dapper from v0.15 to v1.4 (latest in 2.6 git). I can't guarantee that it will fix the problems, but it's about all I can do at this point. It's a 45k diff between the two, so I'm hoping that there's a few bug fixes in there :)

Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
Albert Vilella (avilella) wrote :

So if the v1.4 is in dapper, what is the way to update this? Recompile the kernel? How can I have the v1.4 driver with the 2.6.15-23-686 kernel?

Thanks

Ben Collins (ben-collins) wrote :

You can wait until I get the updated kernel into dapper, which should be in the next few days.

Hi Ben,

one quick request, since you have not released the new kernel, is it possible to move to sky2 driver included in 2.6.17-rc6-git5? I saw Linus just committed another important bug fix.
Generally speaking I think that we'll need to track the upstream on sky2 driver as close as possible... I have the impression that sky2 driver is still a bit "work in progress"...

Many thanks for your great work.

On Tue, 2006-06-13 at 16:48 +0000, luca wrote:
> Hi Ben,
>
> one quick request, since you have not released the new kernel, is it possible to move to sky2 driver included in 2.6.17-rc6-git5? I saw Linus just committed another important bug fix.
> Generally speaking I think that we'll need to track the upstream on sky2 driver as close as possible... I have the impression that sky2 driver is still a bit "work in progress"...

I already pulled in that fix for the dapper kernel.

Currently we are waiting for one more important fix to go into this
dapper update, and once it's ready, the kernel will be uploaded and made
available.

Etienne F-L (eflavoie) wrote :

I just tried the kernel 2.6.15-25-386 and my network still freeze when sending or uploading large e-mails or files. I can restart "networking" and continue to work, but I can't transmit large files.

My USB memory key just got useful again!

Changed in linux-source-2.6.15:
assignee: ben-collins → ubuntu-kernel-team
importance: Critical → High
status: Fix Committed → Confirmed
pogets (pogets) wrote :

I also tried the new kernel just now, and it does not solve the problem, the networking freezes upon copying a file from an NFS-mounted file system to the local hard drive. I guess I will try the sk98lin driver now ...

pogets (pogets) wrote :

Just installed sk98lin (Yukon linux driver version 8.32 from www.marvell.com) and everything works fine so far. Installation of driver was very easy, just install the corresponding linux-headers packages and then choose the install option in the sk98lin installation script.

Harald Held (hheld) wrote :

Here it's finally working perfectly. I tried transferring large files and the network is still working. Thanks for upgrading that driver!!

Albert Vilella (avilella) wrote :

The newer 2.6.15-25-686 is not crashing my machine, but rsyncing directories still cuts the connection. This is a test I made:

rsyncing a big directory in one terminal, while
ping -A google.com in another

After about 5-10 seconds, the connection fails (I append ping results)

ping results, with a problem in the middle, that finally cuts the connection.

Bost (rostislav-svoboda) wrote :

> Just installed sk98lin (Yukon linux driver version 8.32 from www.marvell.com) and everything works fine so far. Installation
> of driver was very easy, just install the corresponding linux-headers packages and then choose the install option in the
> sk98lin installation script.

I'm fighting with the compilation of the sk98lin driver, compilation of kernel, soundcard fullduplex troubles, bluetooth and I
dunno what more this whole weekend... In fact I'm fighting all the time with something since I quit on M$ (2 years or more)
And right now because of these sky2 problem I decided to try SUSE (10.1. Inet Installation)... and of course it doesnt work...
Guys... sometimes I'm really frustrated... I can tell you having linux is a bit like taking care of tamagotschi... doesnt matter
what distro you choosed

OK back to the point - I get problems while compiling the sk98lin:
Compile the kernel (error) [ failed ]

and the sk98lin install.log says:

+++ Compile the driver
+++ ====================================
make: Entering directory `/usr/src/linux-source-2.6.15'
  Building modules, stage 2.
  MODPOST
make: Leaving directory `/usr/src/linux-source-2.6.15'
+++ Compiler error

thx

Bost (still on Ubuntu)

pogets (pogets) wrote :

Here's exactly what I did and what worked for me:
-install linux-headers-2.6.15-25 and linux-headers-2.6.15.25.386 (the second package will obviously depend on your architecture and have to atch your kernel version) with synaptic package manager
- make a simlink in /usr/src from linux-headers-2.6.15-25-386 to linux (sudo ln -s /usr/src/linux-headers-2.6.15-25-386 /usr/src/linux)
- unpack the file install-8_32.tar.bz2 downloaded from the marvell website, change into that directory and run install.sh as root - at the prompt, enter option '1' = installation
- remove the module sky2 (sudo rmmod sky2) and load sk98lin (sudo modprobe sk98lin) - I have not made this permanent yet, so every time I restart, I have to manually remove both sky2 and sk98lin and then reload sk98lin, but eventually I'll remove sky2 alltogether.

Etienne F-L (eflavoie) wrote :

I still have problem for compiling the sk98lin driver. Here is the install.log file:
  WARNING: Symbol version dump /usr/src/linux-headers-2.6.15-25/Module.symvers
           is missing; modules will have no dependencies and modversions.

  Building modules, stage 2.
/usr/src/linux-headers-2.6.15-25/scripts/Makefile.modpost:38: .config: No such file or directory
make[1]: *** No rule to make target `.config'. Stop.
make: *** [modules] Error 2
make: Leaving directory `/usr/src/linux-headers-2.6.15-25'
+++ Compiler error

Is there a possibility that the sk98lin driver be built into the next version of the 2.6.15 kernel?

Etienne F-L (eflavoie) wrote :

I finally managed to install the sk98lin driver. After
rmmod sky2
rmmod sk98lin and
modprobe sk98lin
everything is fine.

I'm not sure my folks could have done it without my help though. I hope it will get fix in the next stock kernel of K/Ubuntu.

Thanks.

Pedro Casagrande (pccampos) wrote :

The connection dropping problem is present on 2.6.15-26-686. Should'nt this bug marked as critical as some really important jobs cannot be done on my laptop?

As always "modprobe -r sky2; modprobe sky2" corrects the problem temporally.

Thanks.

My Asus P5GDC ICH6 chipset broke down, and I resolved to switch to a P5LD2.
Both have a Marvell 88E805 gigabit Ethernet controller.
Unfortunately, the sky2 driver which worked fine on my previous mainboard freezes after a few seconds with the new one ... Maybe a revision problem ?
I compiled the newest sk98lin, and it's now working.
Thanks a lot to all of you !

I've got the feeling this sky2 bug's been here quite a long. Where's
the problem guys?
Not enough info? Complicated logic? No time?
I mean I doubt I'll be able to find'n'fix the bug(s) but who knows...?

On 7/18/06, Denis PORTHAULT <email address hidden> wrote:
> My Asus P5GDC ICH6 chipset broke down, and I resolved to switch to a P5LD2.
> Both have a Marvell 88E805 gigabit Ethernet controller.
> Unfortunately, the sky2 driver which worked fine on my previous mainboard freezes after a few seconds with the new one ... Maybe a revision problem ?
> I compiled the newest sk98lin, and it's now working.
> Thanks a lot to all of you !

kozimodo (forums-theo) wrote :

It seems that the new kernel upgrade (2.6.15-25.45) has broken the sky2 module again -- it had been working fine on my AOpen EZ482 for quite some time.

Diman (vyushin) wrote :

Even the most recent kernel 2.6.15-26 doesn't help. I've successfully compiled and installed sk98lin. It works fine ! In order to permanently disable sky2 I've added it to blacklist. I've added sk98lin to /etc/modules.
After Dapper is booted sk98lin is loaded. However the network is not active. I have to manually activate it. Please tell me what I have done wrong to permanently load sk98lin ?

pogets (pogets) wrote :

To permanently use sk98lin, I have simply moved the sky2.ko file to some other location from the /lib/modules/2.6.15-26-386/kernel/drivers/net directory. That way, only sk98lin gets loaded at boot and works fine - I always bring up the network manually (ifup eth0) with different scripts depending on my location, but I think it should also work automatically if you have set it up that way.

vdaron (tropico) wrote :

If you have the error

 Building modules, stage 2.
/usr/src/linux-headers-2.6.15-25/scripts/Makefile.modpost:38: .config: No such file or directory
make[1]: *** No rule to make target `.config'. Stop.
make: *** [modules] Error 2
make: Leaving directory `/usr/src/linux-headers-2.6.15-25'
+++ Compiler error

It's probably because you do not have libc-dev package installed.

On Mon, 2006-07-24 at 16:00 +0000, pogets wrote:
> To permanently use sk98lin, I have simply moved the sky2.ko file to some
> other location from the /lib/modules/2.6.15-26-386/kernel/drivers/net
> directory. That way, only sk98lin gets loaded at boot and works fine - I
> always bring up the network manually (ifup eth0) with different scripts
> depending on my location, but I think it should also work automatically
> if you have set it up that way.

sudo bash
echo blacklist sky2 > /etc/modprobe.d/blacklist-sky2
exit

This will make it permanent even across upgrades.

Changed in linux-source-2.6.15:
status: Confirmed → Fix Committed
Changed in linux-source-2.6.17:
assignee: nobody → ben-collins
status: Unconfirmed → Fix Committed
importance: Untriaged → High
Changed in linux-source-2.6.15:
assignee: ubuntu-kernel-team → ben-collins
Ben Collins (ben-collins) wrote :

I have test packages for dapper to see if this "fix" works. It's not really a fix. I forward ported the sk98lin driver from breezy into dapper, and disabled the sky2 driver.

If you would like to test this for me, there are -386 and -k7 packages available at:

http://people.ubuntu.com/~bcollins/kernels/sk98lin-dapper/

Since this is not an ABI bump, this should work with current linux-restricted-modules and friends.

Sorry, I removed the -686 kernel without thinking and don't want to go through a build again. You just need to test the -386 image anyway. Test -k7 if you have an AMD and just feel the need.

WARNING: These are not well tested packages. There's a lot of fixes in there totally unrelated to sky2/sk98lin. It should work fine, but use at your own risk. Make sure you have an alternate way to boot to an older kernel. This will replace your currently installed kernel.

Albert Vilella (avilella) wrote :

Hi all,
I've successfully compiled and installed sk98lin.
I added sky2 to the blacklist.
I've added sk98lin to /etc/modules.
After boot up, sk98lin is loaded and sky2 is not.
But no eth0 device appears: I don't know how to bring up the interface.

Stupid as it may seem... How do I bring up the eth0 interface? Where is sk98lin hooked up to a eth0?

Ben Collins (ben-collins) wrote :

On Wed, 2006-08-30 at 12:21 +0000, Albert Vilella wrote:
> Hi all,
> I've successfully compiled and installed sk98lin.
> I added sky2 to the blacklist.
> I've added sk98lin to /etc/modules.
> After boot up, sk98lin is loaded and sky2 is not.
> But no eth0 device appears: I don't know how to bring up the interface.

This is pointless. I went to the effort of putting sk98lin into the
dapper kernel, compiling it for testing, and posted that URL to this bug
report. Matter of fact, it's in the comment right above yours. I did
this so I could get some feedback before uploading it for
dapper-updates. If no one tests it, I'll have to back it out, which
means it may never get put back in.

How about someone test it?

Ben Collins (ben-collins) wrote :

Well, no one tested my kernels. I could just back out the fix because of that, but instead I'll leave it in, and just hope it works.

If it isn't fixed, then we'll have to wait for the next kernel update.

On 08/09/06 19:10 -0000, Ben Collins wrote:
> Well, no one tested my kernels. I could just back out the fix because of
> that, but instead I'll leave it in, and just hope it works.
>
> If it isn't fixed, then we'll have to wait for the next kernel update.

I think my problem is associated to a wrong bug, I use sky2 and it's ok
after ifup/ifdown with latest ubuntu kernel... but when I transfert a
file (high usage of the network card) it stops working, and I have to
reload reload the module and reconfigure everything...
I'm ready to test something if you want to.

Best regards.
fab.

I would like to test your kernel, but I need the -686 version.

Ben Collins (ben-collins) wrote :

On Sep 9, 2006, at 2:35 AM, Matthias Hampel wrote:

> I would like to test your kernel, but I need the -686 version.

Just use the -386 version for testing. You really don't need the -686
just to tell me if your network card works.

Albert Vilella (avilella) wrote :

On 9/9/06, Matthias Hampel <email address hidden> wrote:
> I would like to test your kernel, but I need the -686 version.

same here.

>
> --
> sky2 driver freezing system after ifdown and ifup
> https://launchpad.net/bugs/38865
>

I have just retried it:

  491 wget -b http://people.ubuntu.com/~bcollins/kernels/sk98lin-dapper/linux-image-2.6.15-26-k7_2.6.15-26.47_i386.deb
  492 wget -b http://people.ubuntu.com/~bcollins/kernels/sk98lin-dapper/linux-headers-2.6.15-26-386_2.6.15-26.47_i386.deb
  493 ll -rt
  494 cat wget-log*
  495 ll
  496 sudo dpkg -i linux-headers-2.6.15-26-386_2.6.15-26.47_i386.deb
linux-image-2.6.15-26-k7_2.6.15-26.47_i386.deb
  497 grep 2.6.15 /boot/grub/menu.lst
  498 sudo shutdown -r now

Then it gets stuck and unresponsive at:

Uncompressing linux kernel ... Ok, now running the kernel. (or
something like that)

This is on a Core Duo laptop (http://avilella.googlepages.com/vaiosz)

Any ideas?

On 9/9/06, Ben Collins <email address hidden> wrote:
>
> On Sep 9, 2006, at 2:35 AM, Matthias Hampel wrote:
>
> > I would like to test your kernel, but I need the -686 version.
>
> Just use the -386 version for testing. You really don't need the -686
> just to tell me if your network card works.
>
> --
> sky2 driver freezing system after ifdown and ifup
> https://launchpad.net/bugs/38865
>

akaposi (ambrus.kaposi) wrote :

On 08/09/06 19:10 -0000, Ben Collins wrote:
> Well, no one tested my kernels. I could just back out the fix because of
> that, but instead I'll leave it in, and just hope it works.

There is a 386 headers package and a k7 kernel image in the http://people.ubuntu.com/~bcollins/kernels/sk98lin-dapper/ directory but I need a 386 kernel image to test it. Am I wrong?

I installed the header image and downloaded the sk98lin kernel module from www.marvell.com, and now my 88E8036 chip is working better (I'm able to copy large files etc), albeit sometimes it reports "Port A failed" in dmesg and I have to reboot to get it work again. Google doesn't find anybody who had the same problem before.

Uriel (hidden-wolfstep) wrote :

Hello all,

i had the same problem in the past, then i tried to understand what's was going on the network ,and then i was able to solve the problem for me.

Problem is this stupid module is going bad with autonegotiation with some switches (sure with mine!). I solved my problem (i'm using one Toshiba Tecra A3 to write, with such adapter:) )simply writing

ethtool -s eth0 autoneg off

then , the problem has ceased.

So, i believe the problem when downloading large files happens with autonegotiation, but i can't be more precise.

hope being useful,

Uriel

Ben, your sk98lin-kernel is working.

But now I try out the "autonegotiation = off" setting... Let's see if it works.

Hi Ben,

the last update (.47) containing sk98lin driver definitely broke my network access. The sky2 driver on .46 was working correctly.

Since I read that other people are exactly in the opposite situation (they have problems using sky2 driver), is there a way to let each user choose which driver to use?

wodz (wodz) wrote :

For me last update (.47) also broke network access. The sky2 worked correctly. So I was forced to downgrade. Hardware is Marvell 88E8053 (rev19) in Gericom Supersonic PCIE notebook.

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Changed in linux-source-2.6.17:
status: Fix Committed → Fix Released

I just want to advertise with actual kernel sky2 driver is still not
working (stops transfering data under high load, even if I disable
autonegociation). But, sk98lin driver loads and works like a charm
(unlike before).

BTW, Thanks for your work.
Fabien Devaux.

pogets (pogets) wrote :

I also wanted to mention that kernel 26 fixed the networking issue for me, and 27 broke it again (Marvell 88E8036 Fast Ethernet Controlleron Toshiba Satellite M55-S325 laptop). I assume that 27 uses sky2 again due to other people's problems. I just keep using 26 for now.

Thanks, Sebastien

Matteo Zandi (matteozandi) wrote :

I don't know what autonegotiation is, but if I turn it off like Uriel suggested, the card doesn't freeze when uploading large files..

The card is
0000:02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8036 Fast Ethernet Controller (rev 10)

I'm using sky2 on a custom vanilla 2.6.18-git5 kernel.
Matteo

Matteo Zandi (matteozandi) wrote :

Sorry but I spoke too fast.. it still hangs with large files

Albert Vilella (avilella) wrote :

my experience with "autoneg off" is that it partly alleviates the
disconnections I get during the day, but the driver is still not
perfectly functional.

On 10/1/06, MatteoZandi <email address hidden> wrote:
> Sorry but I spoke too fast.. it still hangs with large files
>
> --
> sky2 driver freezing system after ifdown and ifup
> https://launchpad.net/bugs/38865
>

I also had these connection getting stuck randomly problem, they appeard when transfering
much data using samba server and a windows client with a gigabit connection.

I applied the patch from http://marc.theaimsgroup.com/?l=linux-kernel&m=116060287918559&w=2
to the sky2 v1.4 driver from ubuntu 2.6.15 kernel source and it seems to work, the lockups are gone.

Matteo Zandi (matteozandi) wrote :

Latest patch by Stephen Hemminger on bugs.kernel.com solved the problem for me, I'm using a custom 2.6.18.1 kernel on dapper.

See also here http://bugzilla.kernel.org/show_bug.cgi?id=6839

Changed in linux-restricted-modules-2.6.15:
status: New → Fix Released
assignee: nobody → benc
assignee: benc → ben-collins
Changed in linux-restricted-modules-2.6.15:
status: Fix Released → Invalid
Changed in linux-source-2.6.15:
status: Fix Released → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
eze80 (ezequiel-pozzo) wrote :

Hello, I'm having the same problem under Feisty while copying large files over samba or accessing my pc through VNC.

uname -a
Linux Desktop 2.6.20-16-generic #2 SMP Fri Aug 31 00:55:27 UTC 2007 i686 GUN/Linux

rmmod sky2; modprobe sky2 and then restarting the network helps for a while.

What can be done to solve this bug?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments