Ubuntu

[gutsy] kernel 2.6.20 and 2.6.22 problem on asus centrino

Reported by Alessandro Pascali on 2007-02-04
64
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Gutsy by Onestone
linux-meta (Ubuntu)
Undecided
Unassigned
Nominated for Gutsy by Onestone
linux-source-2.6.20 (Baltix)
Undecided
Unassigned
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by Onestone
linux-source-2.6.22 (Ubuntu)
Medium
Unassigned
Nominated for Gutsy by Onestone

Bug Description

Binary package hint: linux-generic

Ive upgraded my kubuntu edgy (perfectly functioning) to the feisty herd 3, but the kernel wont boot (the computer simply reboot after few second i selected the kernel 2.6.20 in grub).
I can boot only if i add the 'acpi=off' to the grub kernel line. My soundcard won't work , but the kernel modules are loaded, and i have no direct rendering (and no i810 or i915 module loaded automatically).
I've read a dmesg after a boot sequence, and i've added two option to grub (pci=biosirq pci=assign-busses ) but the problem is still there..
Ill post soon a fresh dmesg, a lspci and a lshw. Any other request?

here the output of lshw

output from lspci

Thi is my dmesg, with pci=biosirq and pci=assign-busses

Dmesg without pci=biosirq and pci=assign-busses

Its maybe an DSDT issue? ive noticed that it could be a problem related to this...

Chuck Short (zulcss) wrote :

Re-assigning to proper component.

Michael Stempin (mstempin) wrote :

I can confirm this!
On my Asus M2400N Laptop (1.5 GHz Centrino, 512 MB RAM) the kernel only boots if put acpi=off as a parameter on boot.
If acpi=off is not set the grey box with "loading the Linux kernel" appears for a couple of seconds, then disappears and the machine reboots.

Having set acpi=off the Desktop-CD boots just fine and everything seems to work (except extra keys (but I haven't played around with that yet).
I am actually typing this being online with the Desktop CD.

If any further information is needed just let me know.

Changed in linux-source-2.6.20:
status: Unconfirmed → Confirmed
Roy (roymen) wrote :

I can confirm this too. I'm also using a Asus M2400N.

Thank you very much for your help.
Roy

Changed in linux-source-2.6.20:
importance: Undecided → Medium

Of course this happen with the precompiled linux kernel package..
Should i add this also? It's my first bug report here, and the system its a little bit cryptic...

There is the output of the
lspci -vvnn

Changed in linux-source-2.6.20:
status: Unconfirmed → Rejected
Changed in linux-meta:
status: Unconfirmed → Rejected
Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
Paul Betts (paul-betts) wrote :

Confirming this problem too; I tried both the newest BIOS as well as the previous one; on the previous BIOS it halted while initializing PCI resources . On the current one, it scrolls too fast for me to read.

With acpi=off, the kernel faults while trying to load sound, which explains the no sound problem; you can see the fault in the dmesg posted.

I've tried the new precompiled kernel in the feisty's repo (2.6.20-12.19) and the pc doesn't reboot anymore during boot sequence, but hang with a "Initializing PCI resources" line.

I can see an error too:
"Error: [....] /DTD.aml not found" few lines above.
If you need the exact error i can write back by hand...

I can confirm this.
Booting with no further options stops with:

[46.459412] setting up standard pci resources
[46.025857] ACPI: Looking for DSDT in initramfs... error, file /DSDT.aml not found

Setting the acpi=off option leaves me with:

[61.882778] Uniform CD-ROM driver Revision: 3.20
[74.972749] end request I/O error, dev fd0, sector 0

systems hangs here for about 2 minutes or so continuing with:

[147.138743] squashfs: version 3.2-r2
and then stops with:

[269.307435] udevd-event [6064]: run_program: '/sbin/modprobe' abnormal exit

and thats it. No boot at all.
I hope this helps.
There is another bug I contribute to and I think it has something to do with this since DSDT is involved there too.
https://launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/83544

I hope this helps somehow and feisty will happen for us, who suffer from this bug, too.

Hello,

I can confirm all of the above on my ASUS M2400N too.
Everything worked fine on Edgy.
With acpi=off feisty works too, but without sound and the special keys.

Greetings,
fogman

Hello,

I can confirm all of the above on my ASUS M2400N too.

Greetings,
Walter

Angelo (ngilone85) wrote :

On my asus kernel 2.6.20.13 doesn't start also with acpi=off...To boot feisty beta i must to use kernel version 2.6.17.10!!!
Sorry for my english!!!
Bye!!

Michael Stempin (mstempin) wrote :

Still no luck with the daily build of today (April 6th 2007) :-(
Kernel: 2.6.20-14-generic

Booting without any options:

45.758032 ACPI: bus type pci registered
45.758290 PCI: using configuration type 1
45.758341 Setting up standard PCI resources

then nothing.
System just stops booting.

Booting with acpi=off option:

Uniform CD-ROM driver Revision: 3.20
end request I/O error, dev fd0, sector 0
end request I/O error, dev fd0, sector 0
Buffer I/O error on device fd0 logical block 0
end request I/O error, dev fd0, sector 0
Buffer I/O error on device fd0 logical block 0

... --> System keeps booting then

kjournald.... --> here is more info, but the system keeps on booting, so I could not write it down
Intel ICH: probe of .... error -16 --> this is probably why sound is not working at all

... --> System keeps booting then

*configuring network interfaces --> System hangs here for like 2 minutes but then continues booting

Everything loads fine, X is started and the live-desktop comes up.
But there is no sound at all, extra keys (volume up and down, etc) do not work.
Wireless (ipw2100) is recognized just fine and totally out-of-the-box.
Also desktop-effects work perfectly (Intel i810)

I really hope this helps somehow and this can be fixed in time.
Good Luck guys!

Michael Stempin (mstempin) wrote :
Florian Reichert (florianr) wrote :

Confirm this bug for my ASUS M2400N

Michael Stempin (mstempin) wrote :

I tried it again today.
This time used nolapic instead of acpi=off and it worked.

There still is a major dealy at this point:

Uniform CD-ROM driver Revision: 3.20
end request I/O error, dev fd0, sector 0
end request I/O error, dev fd0, sector 0
Buffer I/O error on device fd0 logical block 0
end request I/O error, dev fd0, sector 0
Buffer I/O error on device fd0 logical block 0

But then the system comes up just fine.
The battery of the laptop was recognized just fine and also sound and extra-keys (play, pause, skip, etc)
worked.

This still is somewhat of a regression compared to previous versions of Ubuntu (I started with breezy) but I guess I can/will have to live with that.
So I guess fesity is actually going to happen for me/us as Asus M2400N users too. :-)

Keep on rocking!

I think headline and importance should be changes, acpi=off is not a solution at all, since many function of the Notebook don't work with that. Importance is IMHO high, since also the install CD (also alternative) doesn't boot at all.

Tried today again with feisty 20070415. Still not booting.
Will try again with the nolapic option. (I tried that before with older feisty versions, there it didn't help!)

One hint for the kernel team: There have been a similar Problem with this notebook before:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/8012

And perhaps you should have a look on knoppix live cd. There I could boot the live CD, but not the installed System ... perhaps you could figure out some differences.

confirm what Lebowski wrote:
booting with nolapic works ...

But that seems to cause some Problems with the built in ipw2100 Wireless card, it's reconecting every 5 Minutes, didn't that before (6.10)

Nickybatts (nickybatts) wrote :

This is a confirmed problem with the M3000n as well.

Flashing the BIOS to the newest version does nothing as well.

nolacpci worked, but disables many of the laptops functions.

Nickybatts (nickybatts) wrote :

Okay, it is IMPOSSIBLE to install Ubuntu with this bug on an ASUS M3000n.

I have tried everything, all to no avail.

I think the severity of this bug should be bumped up.

chriz (christian-seipel) wrote :

I can confirm this problem on an Asus m2400n notebook with Centrino 1.3GHz.

apm (apm-bigendian) wrote :

Another "me too": My M2400N have the exact behaviour that Lebowski described above. "nolapic" is needed to boot (and to install). I seem to recall Debian Sarge needed this too until ASUS released a BIOS upgrade.

I've not yet found out if it's related, but my xorg.conf/915resolution setup I used to drive my external Samsung215TW on Dapper and edgy no longer works with Feisty :(

This is not "partially solved'... I have changed the title to reflect that.

chriz (christian-seipel) wrote :

It seems to be not only a ubuntu kernel bug it is a generally bug in the 2.6.20 kernel. I tried the 2.6.20 kernel on my old kubuntu 6.10 and it doesn't work too. Yesterday I build a new 2.6.21 kernel on my system and it works. So I guess the new 2.6.21 kernel will also work on ubuntu 7.04 and asus M2N notebooks.

Confirming problem also in ASUS M3000n.

Federico Leoni (effelle-gmail) wrote :

Same here on a Dell C400.
I can Install 7.04 only if I do an upgrade from Ubuntu 6.10.

sputnik (sputnik) wrote :

I can confirm this bug. - But I have managed to install Kubuntu with acpi=off.

I did a new install (first one since 2005) and had big problems to start the live-CD.
The only way the installer worked was with acpi=off and in addition using the old debian-installer on the CD. (I also removed the bootparameters "quiet" and "splash"). It was not possible to use a better VGA-mode...

Feisty now works. - But I do not have sound. - You can see my dmesg and lspci -nc here:

http://librarian.launchpad.net/7603349/lspci-nv__dmesg.txt

I've had similar problems with the latest two Knoppix versions which seems to point at the linux-source in general. On the other hand I have had not problems with a now uptodate Mepis-Live-CD which builds upon Kubuntu.

sputnik (sputnik) wrote :

Sorry: My machine is a Asus M2N-Laptop (0,600 -1,4 GHz) - Soundcard will be i810.

lightweight (dave-egressive) wrote :

I can confirm problems with Feisty: both
vmlinuz-2.6.20-15-generic (immediate reboot upon initiating boot, starting a perpetual reboot cycle if machine is left unattended :) )
vmlinuz-2.6.20-15-lowlatency (hangs immediately on boot)
on my Asus M300N. Is it ACPI or some misconfiguration of the initrd.img??

I can't confirm this, but I believe that on a couple occasions, the vmlinuz-2.6.20-15-generic kernel *might* have booted when the machine was unattended (i.e. I came back to it, and it was running, and there isn't any way I know of that it would've automatically selected my fall-back kernel of 2.6.17-11 from Edgy). The machine was upgraded from Edgy, by the way. I'm very keen to resolve this issue.

pjs (paulojjs) wrote :

In my Asus M3N using the kernel 2.6.20-15 (generic) the problem seems to be resolved passing the option nolapic to the kernel.

sputnik (sputnik) wrote :

Same problem here with the new 2.6.20.16-generic-kernel.

It would be very kind if someone could also give me a hint why this is just a "medium" bug. - It is a "ubuntu-does-not-work-at-all" bug that kills every good will for newbies. - And this on laptops where linux was no problem before...

I use a Asus M2N here with Centrino technology.

gabryponte (gabry-gatti) wrote :

I have the same problem on my asus M3N (Centrino 1,4GHz): the ubuntu edgy worked fine, then I upgrade to faisty and the kernel doesn't boot. The lastest kernel working is 2.6.20.10 !
I'm still using this old kernel, on which function the main feature.
Anyone have ideas for solve the problem?

Yes,
you should add the option
nolapic
to the grub boot options.

Then, it could boot fine!

2007/6/19, gabryponte <email address hidden>:
>
> I have the same problem on my asus M3N (Centrino 1,4GHz): the ubuntu edgy
> worked fine, then I upgrade to faisty and the kernel doesn't boot. The
> lastest kernel working is 2.6.20.10 !
> I'm still using this old kernel, on which function the main feature.
> Anyone have ideas for solve the problem?
>
> --
> kernel 2.6.20-6 problem on asus centrino with kubuntu feisty herd 3
> https://bugs.launchpad.net/bugs/83290
> You received this bug notification because you are a direct subscriber
> of the bug.
>

!hi all, new happy kubuntu user since three weeks on asus m3n.
yes, nolapic does solve it, and apparently without consequences.
Florian, you reported a strange behaviour of the ipw2100, reconnecting every 5 mins.

 Florian Reichert said on 2007-04-18:
confirm what Lebowski wrote:
booting with nolapic works ...
But that seems to cause some Problems with the built in ipw2100 Wireless card, it's reconecting every 5 Minutes, didn't that before (6.10)

still have this trouble?
i have a similar problem -wifi reconnecting every 5 10 up to 30 mins- but i'm sure its hardware cause i suffer for it since a few months in winzoz too...
let us know!
cia'cia', Lo.

Michael Stempin (mstempin) wrote :

Same problem with Gutsy Gibbon as of Tribe 2.
I filed a bug here:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/124411

I hope this gets fixed for gutsy. :-)

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Confirmed
Michael Stempin (mstempin) wrote :

Thanks for the hint via email, Brian.
Here is the output of sudo dmidecode from my feisty installation with the 2.6.20 Kernel.

If you need anything else just tell.

Thanks a lot for yout time and efforts of getting this fixed,

Michael

Florian Reichert (florianr) wrote :

Lo:
"i have a similar problem -wifi reconnecting every 5 10 up to 30 mins- but i'm sure its hardware cause i suffer for it since a few months in winzoz too...
let us know!"

Hmm don't know, but with 6.10 I didn't have that problem. Only if booting 7.04 with nolapic. The wifi card schould be OK (I tried another ipw2100 Card, with same behavior).
So may be another hardware missconfiguration on the ASUS M2N ... Or a driver Problem on linux ...
Since this reconnects don't effect download speed (I only have DSL 3000 and I just use wifi for internet connections).
I didn't try to resolve that.

GUTSY:
tribe 2 bootet with nolapic, everything seems to work fine.
tribe 3 boots live CD with nolapic but after Installing to hdd, it doesn't boot, neither with nolapic or acpi=off.

Arthur Kalimullin (kalimullin) wrote :

I have the same problem on my Asus A6M
I can boot to 2.6.20-15-generic (standard feisty kernel) without any changes in /boot/grub/menu.lst but I need acpi=off to boot to 2.6.22-8 and 2.6.22-9

Jon Steffen Larsen (jon-s) wrote :

This dmidecode info was also posted to the duplicate bug #124411. Hope someone will find the time to take a look at it.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → ubuntu-kernel-acpi
Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-team → ubuntu-kernel-acpi
Benjamin.M (benjaminm) wrote :

I have the same problem with this Asus M2400N, Pentium M 1,3 GHz.
Ubuntu Version is latest Gutsy Gibbon and I can only boot with "nolapic" option (or acpi=off).
Direct rendering works, sound seems to work too... Havent tested it very intense yet.

I'll also append my sudo dmidecode output.

sblanz (lanzato) wrote :

I can confirm this bug. In my opinion this is a very important issue because it becomes impossible to install or boot ubuntu out of the box on several popular mainboards like asus. This causes a lot of people to abandon ubuntu.

This bug is present when trying to install or boot feisty on a M2A-MVP Asus mainboard.

The only way to install is to add "acpi=off" on grub boot both during installation and next boots.

This causes the computer to be impossible to automatically shutdown because it hangs on "Will now halt" message.

In this MB the sound works using the workaround snd_hda workaround.

We're still looking for a solution, and hearing that this bug is present even if gutsy gibbon earlier versions is not a good news.

Necromancer (d-smirnoff) wrote :

My laptop with 2.6.22 kernel (gutsy) will also boot only when specifying acpi=off option.
The model is Asus A6M. Feisty worked fine.

In the attachment needed info while working in latest kernel with acpi=off option specified.

Necromancer (d-smirnoff) wrote :
Necromancer (d-smirnoff) wrote :
Necromancer (d-smirnoff) wrote :
Tarik Jabri (tjabri) wrote :

I can confirm this bug on several Dell machines as well, including the Optiplex 520, 745 and Latitude D610. I just tested it with the 9/21 daily build live-cd and it happened on all these machines.

Onestone (onestone) wrote :

I confirm this bug (or something very similar) on Acer TravelMate 4502WLMi. Both Gutsy Tribe 5, and the 9/20 daily build fail to boot, freezing at "Loading ACPI modules". With "acpi=off" they boot, but then frequency scaling doesn't work, which is critical. Feisty worked fine.

goalieca (goalieca) wrote :

Same problem here on gutsy with mobo: Asus 8AN-E.
Currently I am using edgy's 2.6.20-16-lowlatency which works quite fine!

goalieca (goalieca) wrote :

I just compiled 2.6.23.1 kernel and it works flawlessly. My only problem was with the 2.6.22 series it appears. Either that or some patch was added that "broke" my system.

Aserge (s-ammosov) wrote :

Same problem on ASUS A6M ... setting acpi=off helps.. but.. there is still no problem with old kernel from 7.04

Aserge (s-ammosov) wrote :

I think that problem covers not only notebooks, but systems with asus motherboards, i have the exactly the same problem on desktop with ASUS motherboard running 2.6.22 kernel in Open SuSE 10.3

wdesmet (kromagg) wrote :

Not sure if this is related but I have a similar problem with feisty (kernel just hangs at "setting up standard pci resources"). This happened after upgrading the RAM modules. The kernel is currently using a modified DSDT, I'll find out how to disable it, try again and post some updates later. It does seem something is seriously broken on these laptops that they would just hang on PCI after putting in some sticks of RAM.

I've tried memcheck et al., everything seems to work fine.

wdesmet (kromagg) wrote :

In follow up of my previous post: the DSDT I had was indeed malfunctioning. I managed to boot by turning ACPI off, then remove it from the initrd and reboot. Unfortunately I get a bunch of nasty error messages on boot and it seems ipw2200 is simply not functional now. The model is an acer travelmate 4102 WLMi. (latest version)

Henrik Nilsen Omma (henrik) wrote :

This will be retargeted towards the Hardy kernel once it is released. I've tagged this as "hardy-kernel-candidate" so that we make sure to retarget this report once the new release is out. However against the linux-source-2.6.22 package this is being marked as "Won't Fix" as it does not meet the criteria for a stable release update. To learn more about the stable release update process please refer to https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Changed in linux:
status: New → Incomplete
goalieca (goalieca) wrote :

I am typing this from inside alpha2 on the live cd. So it seems to be working.

Michael Stempin (mstempin) wrote :

I can confirm that it is working with Alpha2 of Hardy Heron.
No more "nolapic" needed.
Hopefully it stays that way since the 2.6.24 kernel is still in development.

Thanks for testing and the feedback. Before we close the bug report, Alessandro, since you are the original bug reporter, can you confirm the new Hardy release resolves the issue for you as well? Thanks.

OK, for now its impossible for me to upgrade and test hardy heron (i'm sorry, but its exams period, and i need that all work simply out of the box)

As early as i can, i test if the solution is here!

Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in linux:
status: Incomplete → Invalid
Curtis Hovey (sinzui) on 2012-04-09
Changed in linux-source-2.6.20 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
Changed in linux-source-2.6.22 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions