[UVFe] lirc-modules-source doesn't compile with kernel 2.6.20

Bug #78140 reported by Sergey Romanov
24
Affects Status Importance Assigned to Milestone
lirc (Ubuntu)
Medium
Kees Cook

Bug Description

Binary package hint: lirc-modules-source

See debian bug #400494. Could you please apply the patch from that bug? So I don't have to do touch /usr/src/linux/include/linux/config.h any more.

Thanks.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

yep, annoying.

Changed in lirc:
status: Unconfirmed → Confirmed
Revision history for this message
funkydan2 (daniel-saunders-laus-deo) wrote :

Problem here as well.

The link in the first post is dead for me, so here's a link to a message on the <a href="http://<email address hidden>/msg09210.html">Arch Linux mailing list</a> which also mentions the problem which is that linux/config.h is no longer used in kernels >= 2.6.19 and linux/autoconf.h is used instead.

Would an upgrade to 0.8.1 of the lirc-modules fix this?

Kees Cook (kees)
Changed in lirc:
assignee: nobody → keescook
importance: Undecided → Medium
Revision history for this message
Kees Cook (kees) wrote :

With Mario's help, I've got a build of 0.8.1+cvs20070310 built and compiling the modules. I'm going to turn this bug report into a UVFE. :)

This package builds and so does the lirc-modules-source package, tested by building all drivers (except parallel which isn't SMP safe).

The build system is virtually unchanged. It had to be tweaked for the newer automake. The changes for 2.6.20 have been included as a deb patch.

The serial driver has been tested, but seeing as how no drivers at all work currently, this package can only be an improvement. :)

Revision history for this message
Kees Cook (kees) wrote :

changelog since prior package.

Revision history for this message
Kees Cook (kees) wrote :

If anyone wants to examine the resulting packaging, I've put it here:

http://people.ubuntu.com/~kees/feisty/

Revision history for this message
Mario Limonciello (superm1) wrote :

Also,
this fixes the currently open bug for mceusb2 transmission, 68906.

Revision history for this message
Kees Cook (kees) wrote :

And will close bug 53111, for gpio drivers.

Changed in lirc:
assignee: keescook → motu-uvf
Revision history for this message
Kees Cook (kees) wrote :

Reassigning to me, lirc is in "main".

Changed in lirc:
assignee: motu-uvf → keescook
Revision history for this message
Kees Cook (kees) wrote :

Approved via email by Mithrandir. (And now uploaded.)

Changed in lirc:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments