magics++ 2.30.0-5 source package in Ubuntu

Changelog

magics++ (2.30.0-5) unstable; urgency=medium

  * Add Breaks: libmagplus3. Thanks to Andreas Beckmann.
    Closes: #859915.

 -- Alastair McKinstry <email address hidden>  Sun, 09 Apr 2017 15:44:52 +0100

Upload details

Uploaded by:
Alastair McKinstry on 2017-04-10
Uploaded to:
Sid
Original maintainer:
Alastair McKinstry
Architectures:
any all
Section:
utils
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
magics++_2.30.0-5.dsc 2.7 KiB 3a07223d92bbb36b9650b2b74469c445f0d3f8fdc83903410a82dd888a4edb0a
magics++_2.30.0.orig.tar.xz 22.0 MiB ae0a66321828222ccabdbf7c7856a03147af2199e0d89326b0d2875f5c219d62
magics++_2.30.0-5.debian.tar.xz 35.2 KiB fafc2cb3ae485d0d57139e404808c63ef092c0d6dffdf8d1fe100853b6d58b08

Available diffs

No changes file available.

Binary packages built by this source

libmagics++-data: Data files needed for magics++ library

 Magics++ is the latest generation of the ECMWF's Meteorological plotting
 software MAGICS. Although completely redesigned in C++, it is intended to be
 as backwards-compatible as possible with the Fortran interface.
 .
 This package contains data expected by the magics++ library.

libmagics++-dev: Development files for ECMWF plotting software MAGICS++

 Magics++ is the latest generation of the ECMWF's Meteorological plotting
 software MAGICS. Although completely redesigned in C++, it is intended to be
 as backwards-compatible as possible with the Fortran interface.
 Besides its programming interfaces (Fortran and C), Magics++ offers MagML,
 a plot description language based on XML aimed at automatic web production.
 .
 This package includes the header files and static libraries needed to build
 against libmagics++.

libmagics++-metview-dev: Libraries needed for building MetView

 Magics++ is the latest generation of the ECMWF's Meteorological plotting
 software MAGICS. Although completely redesigned in C++, it is intended to be
 as backwards-compatible as possible with the Fortran interface.
 .
 This package includes the header files and static libraries needed to build
 metview against magics++.

libmagplus3v5: ECMWF meteorological plotting software library

 Magics++ is the latest generation of the ECMWF's Meteorological plotting
 software MAGICS. Although completely redesigned in C++, it is intended to be
 as backwards-compatible as possible with the Fortran interface.
 Besides its programming interfaces (Fortran and C), Magics++ offers MagML,
 a plot description language based on XML aimed at automatic web production.
 .
 The library supports the plotting of contours, wind fields, observations,
 satellite images, symbols, text, axis and graphs (including boxplots).
 .
 Data fields to be plotted may be presented in various formats,
 for instance GRIB 1 and 2 code data, Gaussian grid, regularly spaced grid
 and fitted data. Input data can also be in BUFR and NetCDF format
 or retrieved from an ODB database.
 .
 The produced meteorological plots can be saved in various formats,
 such as PostScript, EPS, PDF, GIF, PNG, SVG and KML.

libmagplus3v5-dbgsym: Debug symbols for libmagplus3v5
magics++: Executables for the magics++ library

 Magics++ is the latest generation of the ECMWF's Meteorological plotting
 software MAGICS. Although completely redesigned in C++, it is intended to be
 as backwards-compatible as possible with the Fortran interface.
 Besides its programming interfaces (Fortran and C), Magics++ offers MagML,
 a plot description language based on XML aimed at automatic web production.
 .
 This package contains the MagcML binary that may be used with magics++.

magics++-dbgsym: Debug symbols for magics++
python-magics++: python support for Magics++

 Magics++ is the latest generation of the ECMWF's Meteorological plotting
 software MAGICS. Although completely redesigned in C++, it is intended to be
 as backwards-compatible as possible with the Fortran interface.
 .
 This package provides python support for the magics++ library.

python-magics++-dbgsym: Debug symbols for python-magics++
python3-magics++: Python3 support for Magics++

 Magics++ is the latest generation of the ECMWF's Meteorological plotting
 software MAGICS. Although completely redesigned in C++, it is intended to be
 as backwards-compatible as possible with the Fortran interface.
 .
 This package provides Python3 support for the magics++ library.

python3-magics++-dbgsym: Debug symbols for python3-magics++