Change log for newsbeuter package in Ubuntu

138 of 38 results
Published in xenial-updates on 2020-10-07
Published in xenial-security on 2020-10-07
newsbeuter (2.9-3ubuntu0.1) xenial-security; urgency=medium

  * SECURITY UPDATE: Remote code execution vulnerabilities
    - debian/patches/23-fix-RCE-on-bookmark.patch: Fix a RCE vulnerability on
      the bookmark command.
    - debian/patches/25-fix-RCE-in-podbeuter.patch: Work around shell code in
      podcast names.
    - CVE-2017-12904
    - CVE-2017-14500
  * SECURITY UPDATE: Other fixes
    - debian/patches/01-typos.patch: Fix a few typos
    - debian/patches/02-new-issue-tracker.patch: Change the docs to reference
      the new issue tracker.
    - debian/patches/04-cache-deletion-with-one-feed.patch: Fixes a bug that
      deleted the cache if there is one feed configured.
    - debian/patches/07-json-object-get.patch: Replace deprecated function
      calls.
    - debian/patches/08-feeds-marked-unread.patch: Fix a bug that marked posts
      unread.
    - debian/patches/09-config-parser-off-by-one.patch: Don't fail if 3
      arguments are passed to highlight.
    - debian/patches/10-a2x-warnings.patch: Fix a2x warning when generating
      the manpages.
    - debian/patches/11-query-feed-tokenization.patch: Fix age filter for
      query feeds not being parsed properly.
    - debian/patches/12-highlight-article-priority.patch: Fix highlight-article
      not working with unread items.
    - debian/patches/13-dont-include-compilation-time.patch: Using __DATE__ or
      __TIME__ breaks reproducible builds.
    - debian/patches/14-handle-urls-files-lacking-eol.patch: Properly handle
      urls files that lack the EOL character at the end.
    - debian/patches/15-dont-skip-ignored.patch: Fix a bug that skipped items
      while checking against ignore rules.
    - debian/patches/16-fix-invalid-pointers.patch: Fix a use after free in the
      rss parser.
    - debian/patches/17-dont-ignore-self-closing-tags.patch: Don't ignore self
      closing HTML break elements.
    - debian/patches/18-ssl-verify.patch: Add a config option to control SSL
      verification.
    - debian/patches/19-clean-doc.patch: Clean the docs before compiling.
    - debian/patches/20-prevent-http-header-reset.patch: Fix authentication
      issues when using external APIs.
    - debian/patches/21-parse-h5-h6-html-headers.patch: Fix h5 and h6 html
      headers not being handled.
    - debian/patches/22-use-pkg-config-to-search-for-ncursesw.patch: Use
      pkg-config to search for ncursesw.
    - debian/patches/24-link-binaries-order.patch: Link binaries in the same
      order to avoid random reproducability failures.
    - debian/patches/101-macro-example.patch: Fix a mistake in an example
      macro.
    - debian/patches/102-color-config-example.patch: Use the actual color
      commands in the docs to improve readablility.
    - debian/patches/201-german-l10n-revision.patch: Revised german
      translation.

 -- Paulo Flabiano Smorigo <email address hidden>  Mon, 05 Oct 2020 18:50:18 +0000
Deleted in eoan-release on 2019-08-12 (Reason: (From Debian) RoM; abandoned upstream; actively maintaine...)
Deleted in eoan-proposed on 2019-08-12 (Reason: moved to release)
newsbeuter (2.9-8ubuntu2) eoan; urgency=medium

  * debian/patches/size_t-gcc.patch
    - cherry-pick upstream fix for new json-c (from forked newsboat package)
      - this one fixes a 32bit type mismatch that might become a real issue
        when gcc defaults to 9.

 -- Gianfranco Costamagna <email address hidden>  Mon, 01 Jul 2019 09:01:05 +0200
Superseded in eoan-proposed on 2019-07-01
newsbeuter (2.9-8ubuntu1) eoan; urgency=medium

  * debian/patches/a21139043efb3b875f3d76cddf6bf90f5cf7642c.patch:
    - cherry-pick upstream fix for new json-c (from forked newsboat package)

 -- Gianfranco Costamagna <email address hidden>  Mon, 01 Jul 2019 08:38:19 +0200
Superseded in cosmic-release on 2018-05-05
Deleted in cosmic-proposed on 2018-05-06 (Reason: moved to release)
newsbeuter (2.9-7build1) cosmic; urgency=medium

  * No-change rebuild for ncurses soname changes.

 -- Matthias Klose <email address hidden>  Thu, 03 May 2018 15:20:21 +0000

Available diffs

Superseded in eoan-release on 2019-07-05
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Deleted in cosmic-proposed on 2020-07-14 (Reason: moved to release)
newsbeuter (2.9-8) unstable; urgency=medium

  * Added NEWS entry about newsboat fork
  * d/control: Recommend newsboat

 -- Nikos Tsipinakis <email address hidden>  Tue, 27 Mar 2018 18:03:01 +0300

Available diffs

Obsolete in zesty-updates on 2018-06-22
Obsolete in zesty-security on 2018-06-22
newsbeuter (2.9-5+deb9u2build0.17.04.1) zesty-security; urgency=medium

  * fake sync from Debian

Superseded in cosmic-release on 2018-05-04
Published in bionic-release on 2017-11-02
Deleted in bionic-proposed (Reason: moved to release)
newsbeuter (2.9-7) unstable; urgency=high

  * Fix CVE-2017-14500 (Closes: #876004)
  * Update copyright year
  * Bump standards to 4.0.1
   + Updated copyright-format URL to https as per policy 4.0.0
  * Dropped version contraint in libstfl-dev dependency (No older versions in
    the archive

 -- Nikos Tsipinakis <email address hidden>  Sun, 17 Sep 2017 22:28:04 +0300

Available diffs

Superseded in zesty-updates on 2017-10-03
Superseded in zesty-security on 2017-10-03
newsbeuter (2.9-5+deb9u1build0.17.04.1) zesty-security; urgency=medium

  * fake sync from Debian

Superseded in bionic-release on 2017-11-02
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed on 2020-07-10 (Reason: moved to release)
newsbeuter (2.9-6) unstable; urgency=high

  * Fix RCE vulnerability on bookmark (CVE-2017-12904)
  * Use pkg-config to test for ncursesw. Closes: #850734
  * Link binaries deterministically in order to build reproducibly
  * debian/patches
   + Update DEP-3 headers

 -- Nikos Tsipinakis <email address hidden>  Thu, 12 Jan 2017 19:05:54 +0200

Available diffs

Superseded in artful-release on 2017-08-18
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
newsbeuter (2.9-5) unstable; urgency=medium

  * Refreshed patches.
  * Remove unnecessary code in d/rules.
  * Add doc-base registration for the docs.
  * Use dh_installdocs to install the contrib directory.
  Added patches:
  * 21-parse-h5-h6-html-headers.patch: Fix h5 and h6 html elements not being
    parsed correctly.

 -- Nikos Tsipinakis <email address hidden>  Tue, 27 Dec 2016 09:15:53 +0200

Available diffs

Superseded in zesty-release on 2016-12-28
Deleted in zesty-proposed on 2016-12-29 (Reason: moved to release)
newsbeuter (2.9-4) unstable; urgency=medium

  * debian/patches:
   + 01-typos.patch: Fix typos.
   + 02-new-issue-tracker.patch: Update docs to reference the new issue tracker.
   + Rename podbeuter-segfault-fix -> 03-podbeuter-segfault-fix.patch
   + 04-cache-deletion-with-one-feed.patch: Fix a bug deleting the cache if
   there's only one feed in the urls file.
   + Rename fix-memory-leak -> 05-fix-memory-leak.patch
   + Rename fix-highlight -> 06-fix-highlight.patch
   + 07-json-object-get.patch: Replace deprecated json_object_get calls.
   + 08-feeds-marked-unread.patch: Fix a bug that occasionally marks entire
   feeds unread.
   + 09-config-parser-off-by-one.patch: Fix an off-by-one error in the
   configparser sometimes breaking the highlight option.
   + 10-a2x-warnings.patch: Fix a2x warnings when compiling the documentation.
   + 11-query-feed-tokenization.patch: Fix ranges in query feeds.
   + 12-highlight-article-priority.patch: Fix priority of highlight-article so
   it works with unread items.
   + 13-dont-include-compilation-time.patch: Don't use __DATE__ and __TIME__ to
   allow for reproducible builds.
   + 14-handle-url-files-lacking-eol.patch: Fix newsbeuter not properly handling
   urls file without an EOL character at the end.
   + 15-dont-skip-ignored.patch: Don't skip items while applying ignore rules.
   + 16-fix-invalid-pointers.patch: Fix a use after free in the rss parser.
   + 17-dont-ignore-self-closing-tags.patch: Don't ignore self closing tags in
   the HTML parser.
   + 18-ssl-verify.patch: Newsbeuter's behaviour was to skip all SSL certificate
   verification, this patch enables verification by default and adds an
   ssl-verify option to disable it if required.
   + 19-clean-doc.patch: Uncomment clean-doc target and set it as a prerequisite
   to the clean target.
   + 20-prevent-http-header-reset.patch: Fix a bug that reset the HTTP headers
   breaking remote APIs.
   + doc/101-macro-example.patch: Fix incorrect example macro in the docs.
   + doc/102-color-config-example.patch: Show the actual commands in the default
   colour config example.
   + l10n/201-german-l10n-revision.patch: Revise the German translation.
   + Rename translation-fix.patch -> l10n/202-translation-fix.patch
  * debian/rules
   + Rebuild the docs before compiling.
   + Copy the entire contrib/ directory to usr/share/doc/newsbeuter, not just a
   few files.
  * debian/control
    + Add Build-Deps required to build the docs: asciidoc, libxml2-utils,
    xsltproc, docbook-xml, docbook-xsl
  * Bump standards to 3.9.8

 -- Nikos Tsipinakis <email address hidden>  Fri, 28 Oct 2016 11:30:36 +0300

Available diffs

Superseded in zesty-release on 2016-11-06
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
newsbeuter (2.9-3build1) yakkety; urgency=medium

  * Rebuild against libjson-c3.

 -- Gianfranco Costamagna <email address hidden>  Thu, 28 Apr 2016 00:18:53 +0200

Available diffs

Superseded in yakkety-release on 2016-05-05
Published in xenial-release on 2016-04-03
Deleted in xenial-proposed (Reason: moved to release)
newsbeuter (2.9-3) unstable; urgency=medium

  * Fix memory leak. (Closes: #776728)
  * Migrate to debhelper.
  * Update homepage and watch file to use SSL.
  * Added current maintainer to the copyright file.

 -- Nikos Tsipinakis <email address hidden>  Sat, 02 Apr 2016 13:57:34 +0300
Superseded in xenial-release on 2016-04-03
Deleted in xenial-proposed on 2016-04-05 (Reason: moved to release)
newsbeuter (2.9-0ubuntu1) xenial; urgency=medium

  * New upstream release.
  * d/p/memleak_fix.patch:
    - Backport commit to fix a leak when feeds were refreshed.

 -- Unit 193 <email address hidden>  Fri, 04 Dec 2015 16:52:03 -0500

Available diffs

Superseded in xenial-release on 2016-01-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
newsbeuter (2.8-2) unstable; urgency=low


  * Add missing copyright statements for filter/Parser.frame,
    filter/Scanner.frame, and test/lemon.h (Closes: #760269).
  * Add version to GPL path in copyright file.

 -- Nico Golde <email address hidden>  Tue, 02 Sep 2014 12:15:52 +0200

Available diffs

Superseded in vivid-release on 2014-10-27
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
newsbeuter (2.7-1build1) utopic; urgency=high

  * No change rebuild against gnutls28.
 -- Dimitri John Ledkov <email address hidden>   Fri, 15 Aug 2014 23:09:40 +0100

Available diffs

Superseded in utopic-release on 2014-08-15
Published in trusty-release on 2013-10-23
Deleted in trusty-proposed (Reason: moved to release)
newsbeuter (2.7-1) unstable; urgency=low


  * New upstream release.

 -- Nico Golde <email address hidden>  Mon, 02 Sep 2013 14:23:27 +0200

Available diffs

Superseded in trusty-release on 2013-10-23
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
newsbeuter (2.6-1) unstable; urgency=low


  * New upstream release.
  * Bump standards version, no changes required.
  * Remove fix_gcc-4.7_ftbfs.patch, included upstream.
  * Update fix_json_boolean_include.patch.
  * Bump compat level to 9, adjust debhelper dependency.
  * Hardening: switch to dpkg-dev >= 1.16.1~ and use buildflags.mk.


 -- Nico Golde <email address hidden>  Wed, 20 Mar 2013 20:28:55 +0100

Available diffs

Superseded in raring-release on 2013-03-28
Obsolete in quantal-release on 2015-04-24
newsbeuter (2.5-3) unstable; urgency=low


  * Bump standards version, no changes required.
  * Fix FTBFS issue due to json's switch from boolean to json_bool
    (Closes: #689225).
  * Build with hardening options.

 -- Nico Golde <email address hidden>  Sun, 30 Sep 2012 17:51:06 +0200

Available diffs

Superseded in quantal-release on 2012-10-01
newsbeuter (2.5-2) unstable; urgency=low


  * Fix build errors with gcc-4.7 (Closes: #667296).
  * Bump standards version.

 -- Nico Golde <email address hidden>  Mon, 07 May 2012 21:27:20 +0200
Superseded in quantal-release on 2012-05-23
newsbeuter (2.5-1ubuntu1) quantal; urgency=low

  * Apply patch from Debian bug #667296 (provided by Nico Golde) to fix FTBFS
    with gcc-4.7.
 -- Michael Bienia <email address hidden>   Tue, 01 May 2012 16:52:58 +0200
Superseded in quantal-release on 2012-05-01
newsbeuter (2.5-1) unstable; urgency=low


  * New upstream release (Closes: #655981).
  * Add libjson0-dev to the build dependencies.
  * Bump standards version.
  * debian/rules: add build-arch and build-indep
    targets as required by polics section 4.9.

 -- Nico Golde <email address hidden>  Sun, 15 Jan 2012 21:32:53 +0100

Available diffs

Superseded in quantal-release on 2012-04-30
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
newsbeuter (2.4-1) unstable; urgency=low

  * New upstream release.
  * Bump standards version, no changes needed.
 -- ALEFHAHMEEMDAL ALEFLAMMEEMHAHMEEMWAWDALYEH (Ahmed El-Mahmoudy) <email address hidden>   Tue, 01 Feb 2011 23:41:47 +0100

Available diffs

Superseded in natty-release on 2011-02-04
newsbeuter (2.3-1) unstable; urgency=low

  * New upstream release.
  * Switch to dpkg-source 3.0 (quilt) format
  * Adjust years in debian/copyright.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  15 Oct 2010 09:48:04 +0000

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
newsbeuter (2.2-2) unstable; urgency=low

  * Do not cleanup deleted items uppon quitting so they will be
    reloaded and marked as new next time (Closes: #574665).

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
newsbeuter (2.1-1) unstable; urgency=low

  * New upstream release
    - fix rss title parsing (Closes: #526612).
    - fix FTBFS on kFreeBSD (Closes: #543591).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  21 Dec 2009 10:44:04 +0000

Available diffs

Superseded in lucid-release on 2009-12-21
Obsolete in karmic-release on 2013-03-04
newsbeuter (2.0-1) unstable; urgency=low

  * New upstream release.
    - Remove dependeny on mrss and nxml and add libxml2, newsbeuter
      now comes with its own parser.
    - Remove debian/patches and quilt dependency.
  * Bump to policy 3.8.1, no changes needed.
  * debian/copyright: adjust years.
  * Remove dh_clean -k call as it is deprecated -> dh_prep.
  * Change newsbeuter homepage, it now has an official one.
  * Fix watch file url, new upstream code location.
  * Add bookmark-scuttle.sh to installed contrib files.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 12:05:30 +0100

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
newsbeuter (1.3-1) unstable; urgency=low

  * New upstream release
    - switched to smart pointers, should fix all remaining segfaults (Closes: #498377).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  06 Dec 2008 22:02:43 +0000

Available diffs

Superseded in jaunty-release on 2008-12-06
newsbeuter (1.2-1) unstable; urgency=low

  * New upstream release.
    - Fix incomplete quoting fix for article URLs by replacing '
      with the proper encoding in hex (Closes: #497495).
  * Update rss_parser.cpp part of the use_system-wide-libs for the
    new download-timeout option.

Available diffs

Obsolete in hardy-updates on 2015-04-24
Obsolete in hardy-security on 2015-04-24
newsbeuter (0.7-1ubuntu0.1) hardy-security; urgency=low

  * SECURITY UPDATE: arbitrary code execution via crafted item URLS.
    - src/view.cpp: Escape single quotes in item URLs. Fixes arbitrary
      code execution. Patch from Debian.
    - References:
      + CVE-2008-3907

 -- William Grant <email address hidden>   Sat, 27 Sep 2008 11:01:24 +1000

Available diffs

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
newsbeuter (0.9.1-1+lenny3) testing-security; urgency=high

  * Non-maintainer upload by the Security Team.
  * Fix regression introduced with latest patch, only append the
    escaped URL once.

Available diffs

Superseded in intrepid-release on 2008-09-27
newsbeuter (0.9.1-1) unstable; urgency=low

  * New upstream release.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  16 May 2008 09:48:22 +0100
Superseded in intrepid-release on 2008-05-16
newsbeuter (0.9-1) unstable; urgency=low

  * New upstream release.
    - Fix problem displaying titles when using zh_CN.UTF-8
      locale (Closes: #471434).
  * Add default configuration to set sensible-browser as browser and
    add dirs file to create /etc/newsbeuter (Closes: #470833).
  * remove libnxml-depends and libmrss-depends calls in rules and
    related dependency lines in control since they are not needed
    anymore (Closes: #467201).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  03 May 2008 11:19:48 +0100
Superseded in intrepid-release on 2008-05-03
newsbeuter (0.8.2-1) unstable; urgency=low

  * New upstream release.

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
newsbeuter (0.7-1) unstable; urgency=low

  * New upstream release.
    - numbering of URLs not inconsistent anymore (Closes: #439170).
  * New release makes previously introduced patches obsolete so
    dpatch stuff and patches/ removed.

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
newsbeuter (0.4-2) unstable; urgency=low

  * Added example config file, thanks to Gregor Herrmann (Closes: #423083).
    Next upstream release will ship an example file.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  11 May 2007 08:05:27 +0100
Superseded in gutsy-release on 2007-05-11
newsbeuter (0.4-1) unstable; urgency=low

  * New upstream release.
  * Removed dpatch dependency and patch for header inclusion,
    included upstream.
  * Changed Build-Dependencies to nxml >= 0.17.2 and mrss >= 0.17.1.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  09 May 2007 14:00:40 +0100
Superseded in gutsy-release on 2007-05-09
newsbeuter (0.3-6) unstable; urgency=low

  * Recompile to fix broken ABI change of libmrss (Closes: #420340).

138 of 38 results