Change log for node-jsdom package in Ubuntu

110 of 10 results
Published in hirsute-proposed on 2021-01-13
node-jsdom (16.4.0+~cs77.17.35-3) unstable; urgency=medium

  * Team upload
  * Add ctype=nodejs to component(s)
  * Render node-request optional (Closes: #958697)
  * Update build dependencies: replace node-typescript-types by
    node-types-node (Closes: #979810)

 -- Xavier Guimard <email address hidden>  Wed, 13 Jan 2021 08:46:06 +0100
Published in hirsute-release on 2020-11-28
Deleted in hirsute-proposed (Reason: moved to Release)
node-jsdom (16.4.0+~cs77.17.35-2) unstable; urgency=medium

  * Team upload
  * Fix .npmignore file

 -- Xavier Guimard <email address hidden>  Thu, 26 Nov 2020 13:32:49 +0100
Superseded in hirsute-proposed on 2020-11-26
node-jsdom (16.4.0+~cs77.17.35-1) unstable; urgency=medium

  * Team upload
  * Embed @types/jsdom and repack
  * Add break against node-typescript-types <20201122~
  * Fix build according to recent @types/* changes

 -- Xavier Guimard <email address hidden>  Sun, 22 Nov 2020 09:50:43 +0100
Superseded in hirsute-release on 2020-11-28
Deleted in hirsute-proposed on 2020-11-29 (Reason: moved to Release)
node-jsdom (16.4.0+~cs61.15.30-2) unstable; urgency=medium

  * Team upload
  * Fix copyright (Closes: #733676, really closed by 16.2.2)

 -- Xavier Guimard <email address hidden>  Thu, 19 Nov 2020 12:59:06 +0100
Superseded in hirsute-release on 2020-11-20
Deleted in hirsute-proposed on 2020-11-21 (Reason: moved to Release)
node-jsdom (16.4.0+~cs61.15.30-1) unstable; urgency=medium

  * Team upload

  [ Julien Puydt ]
  * Bump std-vers to 4.5.1.
  * Ship parse5's TypeScript definitions (Closes: #968968).

  [ Xavier Guimard ]
  * Bump debhelper compatibility level to 13
  * Use dh-sequence-nodejs
  * Embed @types/parse5 as component and repack

 -- Xavier Guimard <email address hidden>  Wed, 18 Nov 2020 22:32:36 +0100
Superseded in hirsute-release on 2020-11-19
Published in groovy-release on 2020-10-06
Deleted in groovy-proposed (Reason: moved to Release)
node-jsdom (16.4.0+~cs56.14.27-1) unstable; urgency=medium

  * Team upload

  [ Debian Janitor ]
  * Use correct machine-readable copyright file URI.
  * Set field Upstream-Name in debian/copyright.

  [ Xavier Guimard ]
  * New upstream version 16.4.0+~cs56.14.27
    really: 16.4.0+~1.0.0+~2.0.0+~10.2.1+~2.0.1+~2.0.1+~1.0.0+~2.2.0+~6.0.1+~
            1.0.9+~5.0.1+~2.0.2+~3.2.4+~1.0.2+~2.0.0+~1.0.5+~2.3.0+~8.3.0+~
            3.0.0+~2.2.0
  * Embed files downloaded during build (JSON data)
  * Update build
  * Update lintian overrides

 -- Xavier Guimard <email address hidden>  Mon, 05 Oct 2020 14:15:42 +0200
Superseded in groovy-proposed on 2020-10-06
node-jsdom (16.2.2+~cs56.12.24-1) unstable; urgency=medium

  * Team upload
  * Replace old get-orig-source target by File-Excluded field
  * Add upstream/metadata
  * Add minimal test based on pkg-js-tools
  * Bump debhelper compatibility level to 12
  * Add "Rules-Requires-Root: no"
  * Change section to javascript
  * Change priority to optional
  * Declare compliance with policy 4.5.0
  * Use pkg-js-tools auto install
  * New upstream version 16.2.2+dfsg (Closes: #842023)
  * Fix metadata
  * Embed components: browser-process-hrtime, data-urls, decimaljs,
    domexception, html-encoding-sniffer, is-potential-custom-element-name,
    nwsapi, parse5, request-promise-native, saxes, symbol-tree, tr46,
    w3c-hr-time, w3c-xmlserializer, whatwg-encoding, whatwg-mimetype,
    whatwg-url, xml-name-validator, xmlchars (Closes: #743151)
  * Embed waka, webidl2 and webidl2 for build only
  * Add lintian overrides
  * Update build
  * Update dependencies
  * Update copyright
  * Update VCS fields to salsa

 -- Xavier Guimard <email address hidden>  Fri, 10 Jul 2020 15:05:26 +0200
Deleted in zesty-proposed on 2017-03-10 (Reason: unsatisfiable dep on removed node-contextify; Debian bug ...)
node-jsdom (0.8.10+dfsg1-2) unstable; urgency=medium

  * Team upload.
  * Enable autopkgtest

  [ W. Martin Borgert ]
  * Corrected/added dependencies. See #742347 (node-cssstyle) and #743151
    (node-htmlparser2, node-nwmatcher).

  [ Dmitry Smirnov ]
  * add gbp.conf

 -- Pirate Praveen <email address hidden>  Tue, 25 Oct 2016 12:01:33 +0530
Deleted in yakkety-proposed (Reason: Obsolete, to be removed from Debian; Debian bug #802101)
Deleted in yakkety-release (Reason: Depends on obsolete node-contextify)
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-12-31
Deleted in trusty-proposed (Reason: moved to release)
node-jsdom (0.8.10+dfsg1-1) unstable; urgency=low


  * Team upload.
  * New upstream release.
  * Bump Standards to 3.9.5.
  * Updated VCS links to canonical form.
  * Removed obsolete "override_dh_fixperms".
  * "debian/watch" to check Github for releases.
  * Updated "00-dont_require_package-json.patch".
  * Minor get-orig-source DFSG-repackaging corrections.

  [ David Paleino ]
  * Update debian/copyright
  * Bump dependency on node-contextify (>= 0.1)

 -- Dmitry Smirnov <email address hidden>  Tue, 31 Dec 2013 08:57:57 +1100

Available diffs

Superseded in trusty-release on 2013-12-31
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
node-jsdom (0.2.10+dfsg1-1) unstable; urgency=low


  * New upstream version

 -- David Paleino <email address hidden>  Sat, 31 Dec 2011 12:06:18 +0100
110 of 10 results