Change log for nvidia-graphics-drivers-177 package in Ubuntu

117 of 17 results
Obsolete in intrepid-updates on 2013-02-20
Deleted in intrepid-proposed on 2013-02-27 (Reason: moved to -updates)
nvidia-graphics-drivers-177 (177.82-0ubuntu0.1) intrepid-proposed; urgency=low

  * Add driver 177.82 (LP: #297543):
    *  Added support for the following new GPUs:
       o Quadro NVS 450
       o Quadro FX 370 LP
       o Quadro FX 5800
       o Quadro FX 4800
       o Quadro FX 470
       o Quadro CX
    * Fixed a problem on recent mobile GPUs that caused a power management resume from S3 to take 30+ seconds.
    * Fixed a problem with hotkey switching on some recent mobile GPUs.
    * Fixed an image corruption issue seen in FireFox 3.
  * Make it conflict with driver 180
  * Make it easier to add the support for new flavours in nvidia-glx-VER.preinst
  * Switch to DKMS patching system (in debian/rules) so as to have different
    patches for different kernel versions
  * Add debian.binary/patches/NVIDIA-177.82_2.6.28.patch to ensure compatibility
    with 2.6.28 kernels (LP: #303107)

 -- Alberto Milone (tseliot) <email address hidden>   Sun, 30 Nov 2008 18:23:09 +0100
Deleted in jaunty-release on 2009-02-02 (Reason: upstream dropped support, replaced with -180)
nvidia-graphics-drivers-177 (177.82-0ubuntu2) jaunty; urgency=low

  * Add debian.binary/patches/NVIDIA-177.82_2.6.28.patch to ensure compatibility
    with 2.6.28 kernels (LP: #303107)

 -- Alberto Milone (tseliot) <email address hidden>   Mon, 01 Dec 2008 18:08:53 +0100
Superseded in jaunty-release on 2008-12-03
nvidia-graphics-drivers-177 (177.82-0ubuntu1) jaunty; urgency=low

  * Add driver 177.82 (LP: #297543):
    *  Added support for the following new GPUs:
       o Quadro NVS 450
       o Quadro FX 370 LP
       o Quadro FX 5800
       o Quadro FX 4800
       o Quadro FX 470
       o Quadro CX
    * Fixed a problem on recent mobile GPUs that caused a power management resume from S3 to take 30+ seconds.
    * Fixed a problem with hotkey switching on some recent mobile GPUs.
    * Fixed an image corruption issue seen in FireFox 3.
  * Make it conflict with driver 180
  * Make it easier to add the support for new flavours in nvidia-glx-VER.preinst
  * Switch to DKMS patching system (in debian/rules) so as to have different
    patches for different kernel versions

 -- Alberto Milone (tseliot) <email address hidden>   Sun, 30 Nov 2008 18:23:09 +0100
Superseded in jaunty-release on 2008-12-01
Superseded in intrepid-proposed on 2008-12-07
nvidia-graphics-drivers-177 (177.80-0ubuntu3) intrepid-proposed; urgency=low

  * Add diversions on /usr/lib/libGL.so.1, /usr/lib/libGL.so.1.2,
    /usr/lib/xorg/modules/extensions/libglx.so without checking their existence in
    Ubuntu 32 bit too (LP: #287470)
  * Remove quotation marks from the SOURCES varialble in
    nvidia-VER-kernel-source.postinst

 -- Alberto Milone (tseliot) <email address hidden>   Sun, 02 Nov 2008 13:24:19 +0100
Superseded in jaunty-release on 2008-11-07
Obsolete in intrepid-release on 2013-02-20
nvidia-graphics-drivers-177 (177.80-0ubuntu2) intrepid; urgency=low

  * Test the existence of the dkms folder in
    nvidia-177-kernel-source.postinst

 -- Alberto Milone (tseliot) <email address hidden>   Mon, 13 Oct 2008 17:38:24 +0200

Available diffs

Superseded in intrepid-release on 2008-10-15
nvidia-graphics-drivers-177 (177.80-0ubuntu1) intrepid; urgency=low

  * Add driver 177.80 (LP: #275098):
    * Added support for the following new GPUs:
      o GeForce GTX 260
      o GeForce GTX 280
      o GeForce 9800 GTX+
      o GeForce 9800 GT
      o GeForce 9700M GTS
      o GeForce 9500 GT
      o GeForce 8100P
      o nForce 780a SLI
      o nForce 750a SLI
      o Quadro FX 770M
      o Quadro NVS 160M
      o Quadro NVS 150M
    * Improved support for RENDER masks, as well as RENDER repeating
      modes and transformations, for video memory pixmaps.
    * Added accelerated support for RENDER convolution filters for
      video memory pixmaps on GeForce 8, 9 and GTX GPUs.
    * Improved support for RENDER operations with the same source
      and destination; this should performance in some situations,
      e.g. when dragging Plasma applets in KDE4.
    * Improved GPU video memory management coordination between the
      NVIDIA X driver and OpenGL implementation; this should improve
      performance with e.g. the KDE4 OpenGL compositing manager.
    * Added an 'AllowSHMPixmaps' X configuration option, which can
      be used to prevent applications from using shared memory
      pixmaps; the latter may cause some optimizations in the NVIDIA
      X driver to be disabled.
    * Fixed a text rendering performance regression that affected
      GeForce 6 and 7 series GPUs.
    * Fixed a regression that caused the 'Auto' SLI X option setting
      to not enable SLI.
    * Fixed a bug that caused system hangs when using the NV-CONTROL
      interface to change GPU clock frequencies.
    * Added support for DisplayPort display devices (including 30-bit
      devices).
    * Resolved various stability problems on GeForce 8, 9 and GTX
      GPUs, as well as some GeForce 6 and 7 PCI-E GPUs.
    * Fixed a bug that resulted in GPU errors when changing the
      TwinView display configuration while using Compiz.
    * Further improved the error recovery paths taken in case of GPU
      command stream corruption.
    * Updated mode validation, in cases when no EDID is detected,
      such that 1024x768 @ 60Hz and 800x600 @ 60Hz are allowed,
      rather than just 640x480 @ 60Hz.
    * Removed an old workaround that caused incorrect Xinerama
      information to be reported after enabling a second TwinView
      display.
    * Fixed corruption when using SLI in SFR mode with OpenGL-based
      composite managers.
    * Fixed the subpicture component order reported by the NVIDIA X
      driver's XvMC implementation.
    * Added a workaround for broken EDIDs provided by some Acer
      AL1512 monitors.
    * Fixed a bug that caused GLXBadDrawable errors to be generated
      when running more than one OpenGL application with anti-aliasing
      enabled on GeForce 6 and 7 GPUs, e.g. wine.
    * Fixed a problem that could result in IRQs being disabled on some
      multi-GPU SMP configurations.
    * Worked around cache flushing problems (on some Linux kernels)
      that caused corruption and stability problems.
    * Added experimental support for PCI-E MSI.
    * Fixed a bug that resulted in AGP FW/SBA settings and overrides
      being applied incorrectly when using the Linux kernel's AGP GART
      driver.
    * Improved compatibility with recent Linux 2.6 kernels.
    * Updated the X driver to consider /sys/class/power_supply when
      determining the AC power state.

 -- Alberto Milone (tseliot) <email address hidden>   Wed, 08 Oct 2008 11:08:21 +0200
Superseded in intrepid-release on 2008-10-08
nvidia-graphics-drivers-177 (177.76-0ubuntu1) intrepid; urgency=low

  * Add driver 177.76 (LP: #272572):
     * Added support for the following new GPUs:
       o GeForce 9500 GT
     * Fixed a bug that caused GPU errors when applications used
       the X RENDER extension's repeating modes in conjunction
       with color-index overlays or rotation on GeForce 7 series
       and older GPUs.
     * Fixed a bug that caused system hangs when using the
       NV-CONTROL interface to change GPU clock frequencies.
     * Fixed a text rendering performance regression on GeForce 7
       series and older GPUs when InitialPixmapPlacement is set
       to 2.
     * Updated mode validation, in cases when no EDID is detected,
       such that 1024x768 @60Hz and 800x600 @ 60Hz are allowed,
       rather than just 640x480 @ 60Hz.
     * Improved power management support.
     * Improved compatibility with recent Linux 2.6 kernels.
     * Fixed a regression that caused the 'Auto' SLI X option
       setting to not enable SLI.
     * Added a workaround for broken EDIDs provided by some Acer
       AL1512 monitors.
  * Fix (LP: #262027) Make sure to remove (in
    nvidia-177-kernel-source.postinst) any directory which
    was not removed because of bug 261816

 -- Alberto Milone (tseliot) <email address hidden>   Mon, 22 Sep 2008 12:28:45 +0200
Superseded in intrepid-release on 2008-09-22
nvidia-graphics-drivers-177 (177.70-0ubuntu2) intrepid; urgency=low

  * nvidia-graphics-drivers-173_173.14.12-1-0ubuntu2_source.changes

 -- Bryce Harrington <email address hidden>   Thu, 11 Sep 2008 18:14:07 -0700

Available diffs

Superseded in intrepid-release on 2008-09-12
nvidia-graphics-drivers-177 (177.70-0ubuntu1) intrepid; urgency=low

  * Add driver 178.70:
     * Added support for the following new GPUs:
       o GeForce 9800 GTX+
       o GeForce 9800 GT
       o GeForce 8100P
       o nForce 780a SLI
       o nForce 750a SLI
       o Quadro FX 770M
       o Quadro NVS 160M
       o Quadro NVS 150M
     * Improved support for RENDER operations with the same source
       and destination; this should enhance performance in
       some situations, e.g. when dragging Plasma applets in KDE4.
     * Fixed a text rendering performance regression that affected
       GeForce 6 and 7 series GPUs.
     * Fixed a regression that caused text to be missing or
       corrupt on GeForce 6 and 7 series GPUs.
     * Fixed a regression responsible for false negatives during
       SLI video bridge detection attempts after X server
       restarts.
     * Fixed a bug that resulted in AGP FW/SBA settings and overrides
       being applied incorrectly when using the Linux kernel's
       AGP GART driver.
     * Fixed a bug that caused initialization of the builtin AGP
       GART driver (NvAGP) to fail.
  * Fix (LP: #261816) Replace "remove" with "remove|upgrade" in the
    case loop in nvidia-177-kernel-source.prerm so that older versions
    of the drivers are removed in case of upgrade

 -- Alberto Milone (tseliot) <email address hidden>   Thu, 28 Aug 2008 22:22:50 +0200
Superseded in intrepid-release on 2008-08-29
nvidia-graphics-drivers-177 (177.68-0ubuntu1) intrepid; urgency=low

  * Add driver 177.67:
     * Added support for the GeForce 9700M GTS.
     * Improved GPU video memory management coordination between the
       NVIDIA X driver and OpenGL implementation; this should
       improve performance with e.g. the KDE4 OpenGL compositing
       manager.
     * Fixed a RENDER corruption bug on GeForce 6 and 7 GPUs.
     * Fixed a bug that caused GLXBadDrawable errors to be generated
       when running more than one OpenGL application with
       anti-aliasing enabled on GeForce 6 and 7 GPUs, e.g. wine.
     * Fixed a bug that caused GPU errors when killing the X server
       while an OpenGL application is running.
     * Fixed a bug on GeForce 8, 9 and GTX GPUs that caused dynamic
       display configuration to fail on GPUs not currently
       driving an X screen.
  * Fix (LP: #254969) Make nvidia-glx-VER conflict with xorg-driver-fglrx

 -- Alberto Milone (tseliot) <email address hidden>   Fri, 22 Aug 2008 10:57:32 +0200
Superseded in intrepid-release on 2008-08-22
nvidia-graphics-drivers-177 (177.67-0ubuntu1) intrepid; urgency=low

  * Fix (LP: #254444) Remove pound from link in nvidia-glx-177-dev.links.in
  * Fix (LP: #259105) Add missing link to usr/lib/libXvMCNVIDIA.so.#VERSION# in
    usr/lib/libXvMCNVIDIA.so
  * Add driver 177.67:
     * Added support for the following new GPUs:
       o GeForce GTX 260
       o GeForce GTX 280
     * Improved support for RENDER masks, as well as RENDER repeating modes and
       transformations, for video memory pixmaps.
     * Added accelerated support for RENDER convolution filters for video memory
       pixmaps on GeForce 8, 9 and GTX GPUs.
     * Added an 'AllowSHMPixmaps' X configuration option, which can be used to prevent
       applications from using shared memory pixmaps; the latter may cause some
       optimizations in the NVIDIA X driver to be disabled.
     * Added support for DisplayPort display devices (including 30-bit devices).
     * Resolved various stability problems on GeForce 8, 9 and GTX GPUs, as well as
       some GeForce 6 and 7 PCI-E GPUs.
     * Fixed a bug that resulted in GPU errors when changing the TwinView display
       configuration while using Compiz.
     * Further improved the error recovery paths taken in case of GPU command stream
       corruption.
     * Removed an old workaround that caused incorrect fake Xinerama information to be
       reported after enabling a second TwinView display.
     * Fixed the subpicture component order reported by the NVIDIA X driver's XvMC
       implementation.
     * Fixed a problem that could result in IRQs being disabled on some multi-GPU SMP
       configurations.
     * Worked around cache flushing problems (on some Linux kernels) that caused
       corruption and stability problems.
     * Added experimental support for PCI-E MSI.
     * Improved compatibility with recent Linux 2.6 kernels.

 -- Alberto Milone (tseliot) <email address hidden>   Wed, 20 Aug 2008 10:35:05 +0200
Superseded in intrepid-release on 2008-08-20
nvidia-graphics-drivers-177 (177.13-0ubuntu8) intrepid; urgency=low

  * Make sure that the installers are executable in the debian/rules
  * Don't test the existence of libGL.so, libGL.so.1, libGL.so.1.2 in /usr/lib32
    when adding a diversion on them in the preinst. This will make sure that NVIDIA's
    libGL.so.xx will win against the one in ia32-libs [amd64]
  * Remove diversions of libGL.so in the preinst added by nvidia-glx-VER and add
    a new diversion of the file to /usr/lib32/nvidia/libGL.so.xlibmesa [amd64]
  * Remove diversion of libGL.so in the postrm.in [amd64]
  * Remove dependency on ia32-libs [amd64]
  * Fix (LP: #247984) make sure that nvidia-glx-177 doesn't conflict with ia32-libs

 -- Alberto Milone (tseliot) <email address hidden>   Sat, 09 Aug 2008 11:46:47 +0200
Superseded in intrepid-release on 2008-08-10
Superseded in intrepid-release on 2008-07-22
nvidia-graphics-drivers-177 (177.13-0ubuntu7) intrepid; urgency=low

  * Make sure that no file is installed to /etc/default

 -- Alberto Milone (tseliot) <email address hidden>   Thu, 17 Jul 2008 22:09:18 +0200

Available diffs

Superseded in intrepid-release on 2008-07-18
nvidia-graphics-drivers-177 (177.13-0ubuntu6) intrepid; urgency=low

  * Fix (LP: #247984) Add dependency on ia32-libs for amd64
  * Add the name of the package to the modalias list

 -- Alberto Milone (tseliot) <email address hidden>   Sun, 13 Jul 2008 20:36:26 +0200

Available diffs

Superseded in intrepid-release on 2008-07-14
nvidia-graphics-drivers-177 (177.13-0ubuntu5) intrepid; urgency=low

  * Fix (LP: #247527) depend on linux-headers-generic | linux-headers rather
    than on linux-headers

 -- Alberto Milone (tseliot) <email address hidden>   Fri, 11 Jul 2008 15:17:53 +0200
Superseded in intrepid-release on 2008-07-11
Superseded in intrepid-release on 2008-07-10
nvidia-graphics-drivers-177 (177.13-0ubuntu4) intrepid; urgency=low

  * Remove reference to the init file from -dev.postinst
  * Don't copy kernel.o.x86_64 to nvidia-kernel-source manually

 -- Alberto Milone (tseliot) <email address hidden>   Thu, 10 Jul 2008 10:43:03 +0200

Available diffs

Superseded in intrepid-release on 2008-07-10
Superseded in intrepid-release on 2008-07-10
nvidia-graphics-drivers-177 (177.13-0ubuntu3) intrepid; urgency=low

  * Recommends nvidia-settings instead of Suggests nvidia-settings
  * Put the icon for nvidia-settings in /usr/share/pixmaps

 -- Alberto Milone (tseliot) <email address hidden>   Tue, 08 Jul 2008 18:50:23 +0200

Available diffs

117 of 17 results