openldap 2.4.31-1+nmu2ubuntu12.3 source package in Ubuntu

Changelog

openldap (2.4.31-1+nmu2ubuntu12.3) vivid-security; urgency=medium

  * SECURITY UPDATE: denial of service via crafted BER data
    - debian/patches/CVE-2015-6908.patch: remove obsolete assert in
      libraries/liblber/io.c.
    - CVE-2015-6908
  * SECURITY UPDATE: user impersonation via incorrect default permissions
    - debian/slapd.init.ldif: disallow modifying one's own entry by
      default.
    - CVE-2014-9713

 -- Marc Deslauriers <email address hidden>  Mon, 14 Sep 2015 10:28:32 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2015-09-15
Uploaded to:
Vivid
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
net
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
openldap_2.4.31.orig.tar.gz 4.5 MiB dff60c1044021217ab97a7bdda5a7016015f042db0fbfd566d52abb266d19239
openldap_2.4.31-1+nmu2ubuntu12.3.diff.gz 172.5 KiB 314f874e4dbb5e24a9a6e0c4df23a2d0ae59fb5a7272b96b8cec0b29a80a2160
openldap_2.4.31-1+nmu2ubuntu12.3.dsc 2.9 KiB d3cafe44d3be6d79f6ba5451f6d9d4578726bb1ed5a10d71345786780c041997

View changes file

Binary packages built by this source

ldap-utils: No summary available for ldap-utils in ubuntu vivid.

No description available for ldap-utils in ubuntu vivid.

ldap-utils-dbgsym: No summary available for ldap-utils-dbgsym in ubuntu vivid.

No description available for ldap-utils-dbgsym in ubuntu vivid.

libldap-2.4-2: No summary available for libldap-2.4-2 in ubuntu vivid.

No description available for libldap-2.4-2 in ubuntu vivid.

libldap-2.4-2-dbg: No summary available for libldap-2.4-2-dbg in ubuntu vivid.

No description available for libldap-2.4-2-dbg in ubuntu vivid.

libldap-2.4-2-dbgsym: No summary available for libldap-2.4-2-dbgsym in ubuntu vivid.

No description available for libldap-2.4-2-dbgsym in ubuntu vivid.

libldap2-dev: No summary available for libldap2-dev in ubuntu vivid.

No description available for libldap2-dev in ubuntu vivid.

libldap2-dev-dbgsym: No summary available for libldap2-dev-dbgsym in ubuntu vivid.

No description available for libldap2-dev-dbgsym in ubuntu vivid.

slapd: No summary available for slapd in ubuntu vivid.

No description available for slapd in ubuntu vivid.

slapd-dbg: No summary available for slapd-dbg in ubuntu vivid.

No description available for slapd-dbg in ubuntu vivid.

slapd-dbgsym: No summary available for slapd-dbgsym in ubuntu vivid.

No description available for slapd-dbgsym in ubuntu vivid.

slapd-smbk5pwd: No summary available for slapd-smbk5pwd in ubuntu vivid.

No description available for slapd-smbk5pwd in ubuntu vivid.

slapd-smbk5pwd-dbgsym: No summary available for slapd-smbk5pwd-dbgsym in ubuntu vivid.

No description available for slapd-smbk5pwd-dbgsym in ubuntu vivid.