Ubuntu

“openssl” 0.9.8o-5ubuntu1.5 source package in Ubuntu

Changelog

openssl (0.9.8o-5ubuntu1.5) natty-security; urgency=low

  * SECURITY UPDATE: incomplete fix for CVE-2012-2110
    - debian/patches/CVE-2012-2131.patch: also verify 'len' in BUF_MEM_grow
      and BUF_MEM_grow_clean is non-negative
    - CVE-2012-2131
  * debian/patches/CVE-2012-2110b.patch: Use correct error code in
    BUF_MEM_grow_clean()
 -- Jamie Strandboge <email address hidden>   Tue, 24 Apr 2012 08:14:16 -0500

Upload details

Uploaded by:
Jamie Strandboge on 2012-04-24
Uploaded to:
Natty
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
any
Section:
utils
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
openssl_0.9.8o.orig.tar.gz 3.6 MiB 63ddc5116488985e820075e65fbe6aa4
openssl_0.9.8o-5ubuntu1.5.debian.tar.gz 100.6 KiB 6fe4f21f6ae10d27646d5028a25e3af4
openssl_0.9.8o-5ubuntu1.5.dsc 2.1 KiB 0d3c2521621700d07b17d96a9664a186

Binary packages built by this source

libcrypto0.9.8-udeb: No summary available for libcrypto0.9.8-udeb in ubuntu natty.

No description available for libcrypto0.9.8-udeb in ubuntu natty.

libssl-dev: No summary available for libssl-dev in ubuntu natty.

No description available for libssl-dev in ubuntu natty.

libssl0.9.8: No summary available for libssl0.9.8 in ubuntu natty.

No description available for libssl0.9.8 in ubuntu natty.

libssl0.9.8-dbg: No summary available for libssl0.9.8-dbg in ubuntu natty.

No description available for libssl0.9.8-dbg in ubuntu natty.

libssl0.9.8-udeb: No summary available for libssl0.9.8-udeb in ubuntu natty.

No description available for libssl0.9.8-udeb in ubuntu natty.

openssl: No summary available for openssl in ubuntu natty.

No description available for openssl in ubuntu natty.

openssl-doc: No summary available for openssl-doc in ubuntu natty.

No description available for openssl-doc in ubuntu natty.