Ubuntu

“openssl” 1.0.1-4ubuntu5.11 source package in Ubuntu

Changelog

openssl (1.0.1-4ubuntu5.11) precise-security; urgency=low

  * SECURITY UPDATE: denial of service via invalid TLS handshake
    - debian/patches/CVE-2013-4353.patch: handle no new cipher setup in
      ssl/s3_both.c.
    - CVE-2013-4353
  * SECURITY UPDATE: denial of service via incorrect data structure
    - debian/patches/CVE-2013-6449.patch: check for handshake digests in
      ssl/s3_both.c,ssl/s3_pkt.c,ssl/t1_enc.c, use proper version in
      ssl/s3_lib.c.
    - CVE-2013-6449
  * SECURITY UPDATE: denial of service via DTLS retransmission
    - debian/patches/CVE-2013-6450.patch: fix DTLS retransmission in
      crypto/evp/digest.c,ssl/d1_both.c,ssl/s3_pkt.c,ssl/s3_srvr.c,
      ssl/ssl_locl.h,ssl/t1_enc.c.
    - CVE-2013-6450
  * debian/patches/no_default_rdrand.patch: Don't use rdrand engine as
    default unless explicitly requested.
 -- Marc Deslauriers <email address hidden>   Wed, 08 Jan 2014 14:59:50 -0500

Upload details

Uploaded by:
Marc Deslauriers on 2014-01-08
Uploaded to:
Precise
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
any all
Section:
utils
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
openssl_1.0.1.orig.tar.gz 4.2 MiB 134f168bc2a8333f19f81d684841710b
openssl_1.0.1-4ubuntu5.11.debian.tar.gz 129.4 KiB 6c9c13b4cde4bc0f57685bb173885bf1
openssl_1.0.1-4ubuntu5.11.dsc 2.3 KiB 57d03c9eaf4a1c5a4cbb450a82c45d4f

Binary packages built by this source

libcrypto1.0.0-udeb: crypto shared library - udeb

 libcrypto shared library.
 .
 Do not install it on a normal system.

libssl-dev: SSL development libraries, header files and documentation

 libssl and libcrypto development libraries, header files and manpages.
 .
 It is part of the OpenSSL implementation of SSL.

libssl-doc: SSL development documentation documentation

 libssl and libcrypto manpages and demo files.
 .
 It is part of the OpenSSL implementation of SSL.

libssl1.0.0: SSL shared libraries

 libssl and libcrypto shared libraries needed by programs like
 apache-ssl, telnet-ssl and openssh.
 .
 It is part of the OpenSSL implementation of SSL.

libssl1.0.0-dbg: Symbol tables for libssl and libcrypto

 This package is part of the OpenSSL implementation of SSL.

libssl1.0.0-udeb: ssl shared library - udeb

 libssl shared library.
 .
 Do not install it on a normal system.

openssl: Secure Socket Layer (SSL) binary and related cryptographic tools

 This package contains the openssl binary and related tools.
 .
 It is part of the OpenSSL implementation of SSL.
 .
 You need it to perform certain cryptographic actions like:
  - Creation of RSA, DH and DSA key parameters;
  - Creation of X.509 certificates, CSRs and CRLs;
  - Calculation of message digests;
  - Encryption and decryption with ciphers;
  - SSL/TLS client and server tests;
  - Handling of S/MIME signed or encrypted mail.