Ubuntu

“openssl” 1.0.1c-3ubuntu2.5 source package in Ubuntu

Changelog

openssl (1.0.1c-3ubuntu2.5) quantal-security; urgency=low

  * SECURITY UPDATE: Disable compression to avoid CRIME systemwide
    (LP: #1187195)
    - CVE-2012-4929
    - debian/patches/openssl-1.0.1e-env-zlib.patch: disable default use of
      zlib to compress SSL/TLS unless the environment variable
      OPENSSL_DEFAULT_ZLIB is set in the environment during library
      initialization.
    - Introduced to assist with programs not yet updated to provide their own
      controls on compression, such as Postfix
    - http://pkgs.fedoraproject.org/cgit/openssl.git/plain/openssl-1.0.1e-env-zlib.patch
 -- Seth Arnold <email address hidden>   Mon, 03 Jun 2013 18:13:33 -0700

Upload details

Uploaded by:
Seth Arnold on 2013-06-04
Uploaded to:
Quantal
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
any all
Section:
utils
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
openssl_1.0.1c.orig.tar.gz 4.3 MiB ae412727c8c15b67880aef7bd2999b2e
openssl_1.0.1c-3ubuntu2.5.debian.tar.gz 120.7 KiB 93fd9ccf897cbaf94f796ab42ee5f61a
openssl_1.0.1c-3ubuntu2.5.dsc 2.0 KiB c7bb53bab2d077a54674a6423e3da3c4

Binary packages built by this source

libcrypto1.0.0-udeb: crypto shared library - udeb

 libcrypto shared library.
 .
 Do not install it on a normal system.

libssl-dev: SSL development libraries, header files and documentation

 libssl and libcrypto development libraries, header files and manpages.
 .
 It is part of the OpenSSL implementation of SSL.

libssl-doc: SSL development documentation documentation

 libssl and libcrypto manpages and demo files.
 .
 It is part of the OpenSSL implementation of SSL.

libssl1.0.0: SSL shared libraries

 libssl and libcrypto shared libraries needed by programs like
 apache-ssl, telnet-ssl and openssh.
 .
 It is part of the OpenSSL implementation of SSL.

libssl1.0.0-dbg: Symbol tables for libssl and libcrypto

 This package is part of the OpenSSL implementation of SSL.

libssl1.0.0-udeb: ssl shared library - udeb

 libssl shared library.
 .
 Do not install it on a normal system.

openssl: Secure Socket Layer (SSL) binary and related cryptographic tools

 This package contains the openssl binary and related tools.
 .
 It is part of the OpenSSL implementation of SSL.
 .
 You need it to perform certain cryptographic actions like:
  - Creation of RSA, DH and DSA key parameters;
  - Creation of X.509 certificates, CSRs and CRLs;
  - Calculation of message digests;
  - Encryption and decryption with ciphers;
  - SSL/TLS client and server tests;
  - Handling of S/MIME signed or encrypted mail.