opie 2.40~dfsg-0ubuntu1.9.04.1 source package in Ubuntu

Changelog

opie (2.40~dfsg-0ubuntu1.9.04.1) jaunty-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    off-by-one
    - libopie/readrec.c: use strncpy so we don't overflow principal.
    - http://security.freebsd.org/patches/SA-10:05/opie.patch
    - CVE-2010-1938
  * libopie/newseed.c: fix snprintf's length argument so opiepasswd will
    generate valid seeds. (LP: #569292)
 -- Marc Deslauriers <email address hidden>   Tue, 08 Jun 2010 11:19:07 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2010-06-08
Uploaded to:
Jaunty
Original maintainer:
Ubuntu Development Team
Architectures:
any
Section:
admin
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
opie_2.40~dfsg.orig.tar.gz 170.7 KiB 9911cc68f911518d3794686dfe7375ea426760f0fdf09500bac7138e1ed6a0da
opie_2.40~dfsg-0ubuntu1.9.04.1.diff.gz 9.2 KiB 6c12c0981c3faaa2092c4c277a90a018051e42350bb0fd8dd41717c5bef98e01
opie_2.40~dfsg-0ubuntu1.9.04.1.dsc 1.1 KiB f2aaab605fa0a7e44ea2fb5e9a93e8ed7ff99b7fc2d1cd90298cbfdcf1e22a8e

View changes file

Binary packages built by this source

libopie-dev: No summary available for libopie-dev in ubuntu jaunty.

No description available for libopie-dev in ubuntu jaunty.

opie-client: No summary available for opie-client in ubuntu jaunty.

No description available for opie-client in ubuntu jaunty.

opie-server: No summary available for opie-server in ubuntu jaunty.

No description available for opie-server in ubuntu jaunty.