[Edgy] pppoeconf prints useless error message, doesn't do anything

Bug #54383 reported by Alex Mauer on 2006-07-28
62
Affects Status Importance Assigned to Milestone
pppoeconf (Ubuntu)
High
Adrien Cunin

Bug Description

When I try to run pppoeconf it asks for admin privileges and then says:

$ pppoeconf
glibtop: This machine has 1 CPUs, 1 are being monitored.
This option is not available. Please see --help for all possible usages.

That's great. I'm glad it has 1 cpu. What option is not available?

$ pppoeconf --help
glibtop: This machine has 1 CPUs, 1 are being monitored.
This option is not available. Please see --help for all possible usages.

....right.

Revision history for this message
Andreas Simon (andreas-w-simon) wrote :

I get the same with pppoeconf 1.10ubuntu2 (edgy), only the glibtop message is missing here (under KDE):

$ sudo pppoeconf
This option is not available. Please see --help for all possible usages.
$ sudo pppoeconf --help
This option is not available. Please see --help for all possible usages.

Changed in pppoeconf:
status: Unconfirmed → Confirmed
Revision history for this message
Mike Hore (mike-hore) wrote :

I got the same thing, though again without the glibtop line. I'm on an iMac G5 Revision A.

I initially filed a bug (# 58174) but I'm withdrawing that since it's the same as this one.

But hey, this was reported in JULY!! Is anybody listening????

Cheers, Mike.

Revision history for this message
Butter (stefanbutterling) wrote :

Same problem here.

$ sudo pppoeconf
This option is not available. Please see --help for all possible usages.

Edgy Eft Knot 2(31.08.06)

Revision history for this message
Mike Hore (mike-hore) wrote :

Why is this bug continuing to be ignored? Can we escalate it somehow?
It's a total show-stopper for me.

-- Mike.

Revision history for this message
Andreas Simon (andreas-w-simon) wrote :

I had a look at the script /usr/sbin/pppoeconf and the reason why it doesn't work is that the zenity support is broken (zenity is an app to show GUI dialogs).

Commenting out lines 22,23,24 makes pppoeconf work again here. I suspect everyone here for whom this script fails has zenity installed. If zenity is not installed pppoeconf will use whiptail or Xdialog for it's dialogs.

To fix this pppoeconf should be merged with Debian Unstable's pppoeconf 1.11 which has this (among some other things) fixed.

Revision history for this message
Mike Hore (mike-hore) wrote :

>I had a look at the script /usr/sbin/pppoeconf and the reason why it >doesn't work is that the zenity support is broken (zenity is an app to show >GUI dialogs).

>Commenting out lines 22,23,24 makes pppoeconf work again here. I >suspect everyone here for whom this script fails has zenity installed. If >zenity is not installed pppoeconf will use whiptail or Xdialog for it's >dialogs.

Thanks Andreas, that got pppoeconf to come up with a basic dialog on my system. But no joy after that...

It sees my eth0 connection, I accept that, but then after flashing a couple of brief "Timeout waiting for PADO packets" or something like that, I get:
"Sorry, I scanned 1 interface, but the Access Concentrator of your provider did not respond. Please check your network and modem cables. [which are OK, since when I'm on OSX I'm properly connected]
Another reason for the scan failure may also be another running pppoe process which controls the modem [I very much doubt this is the problem]

I don't know much about networking, so I have no idea what this message means. When I run the Network Administration tool the connections pane is empty, and there's no "add" button. The help says to use the "add" button...

So basically I'm still stuck.

-- Mike.

Revision history for this message
Kurt Kraut (kurtkraut) wrote : This should be fixed quick

Hi,

PPPoE authentication is used widely in Brazil. Is the most common way of configuring internet access. In order to have brazilians helping on testing Edgy, it should be fixed asap.

My ISP alone has 400.000 clients country-wide, all of them using PPPoE with bridge ADSL external modems. Sum that to other ISPs and just imagine the amount... there will be more people with theses settings that whole population of some european contries, all of them again, unable to help testing Edgy.

Revision history for this message
x (xk2c-deactivatedaccount) wrote :

I had the same problem others experienced with pppoe with desktop edgy knot2 cd.

($ sudo pppoeconf
This option is not available. Please see --help for all possible usages.)

After that i installed knot2 with the alternate cd and pppoeconf ran really smooth. In fact i think it´s even better then in dapper.

So what needs to be checked is if this problem also persits after installing with the desktop cd to distinguish if this is a pppoeconf bug or an desktop cd bug.

Revision history for this message
xjluo (xjluo) wrote :

I have installed Edgy Eft Knot2 alternate cd on my iBook G4 and found the same bug. According to Andreas Simon's opinion, I commented line 22,23,24 which makes pppoeconf work now.

Revision history for this message
Miguel Ruiz (mruiz) wrote :

I had the same error; I include an image...

This package is very important for people that only have an ADSL connection. Now I haven't internet connection...

Revision history for this message
Miguel Ruiz (mruiz) wrote :

I had this problem with Ubuntu Edgy - Knot 3.

Revision history for this message
Mike Hore (mike-hore) wrote :

Hi, I just got back from 2 weeks away to find that we're up to Knot 3 but this issue still isn't fixed -- is anybody listening or not? This bug is serious -- it prevents internet connection!
-- Mike.

Revision history for this message
Mike Hore (mike-hore) wrote :

Hi again -- well I now find I CAN connect to the internet -- I was still getting the message I detailed on the 4th, but when I tried ping it worked, and going into Firefox and looking up a site it Just Worked. The only thing I did was
sudo ifup eth0
so maybe that was the key to it.
Firefox still gets lost in the weeds when I try to go to most sites, but it sometimes works, and ping always works, so basically I have an internet connection and the other problems must be a separate issue.

-- Mike.

Revision history for this message
Mike Hore (mike-hore) wrote :

I notice that bug 60230 has been filed, which is really the same as this one, but the message gives more specific detail about the underlying cause. Therefore I won't touch the bug reports myself but just note this here for those following this one.
-- Mike.

Revision history for this message
Felix Braun (felix-braun) wrote :

This patch fixes pppoeconf. To apply it, download and call:

    user@localhost$ sudo patch <pppoeconf-fix-zenity.patch

Changed in pppoeconf:
importance: Untriaged → High
Revision history for this message
jmdennis (jmdennis) wrote :

I never got the message but I did upgrade from the 3 update to what ever updates existed. After doing this I can not connect to the internet even with the sudo ifup eth0. It is quite annoying to not be able to get on the internet. Like some one else I can get on using OS 10.4.8 so I know the problem is with pppoe and not my dsl modem.

Revision history for this message
Richard O. Hunt (r-o-hunt) wrote :

Mabe this is too late to help but I had the same problem. My fix was to launch Synaptic Package Manager and do a search for Zenity. When I found the package had been installed I marked it for removal. After that i could open terminal and sudo pppoeconf, entered my password and it configured my DSL connection without a hitch.

Revision history for this message
Andre Noel (andrenoel) wrote :

Same problem here.

$ sudo pppoeconf
This option is not available. Please see --help for all possible usages.

$ sudo pppoeconf --help
This option is not available. Please see --help for all possible usages.

Edgy Eft Beta (18.10.2006)

Revision history for this message
Vo Dai Chuyen (vdchuyen) wrote : Re: [Bug 54383] Re: [Edgy] pppoeconf prints useless error message, doesn't do anything

Yeah, that's exactly the problem to me. Hope you guys can fix soon.

On 10/18/06, Andre Noel <email address hidden> wrote:
>
> Same problem here.
>
> $ sudo pppoeconf
> This option is not available. Please see --help for all possible usages.
>
> $ sudo pppoeconf --help
> This option is not available. Please see --help for all possible usages.
>
> Edgy Eft Beta (18.10.2006)
>
> --
> [Edgy] pppoeconf prints useless error message, doesn't do anything
> https://launchpad.net/bugs/54383
>

--
Key fingerprint = 1BE8 64AA AC4B 776B 31DA 89DE E8AA 4087 E69B 65C2

Revision history for this message
Andreas Simon (andreas-w-simon) wrote :

Felix, there is a problem with gdialog which your patch from comment #15 enables. I am able to configure everything when using gdialog, but there is no way to cancel it. Pressing 'cancel', or escape, nothing helps. I would just disable the GUI dialog completly. But this is someone's else decision.

Revision history for this message
Felix Braun (felix-braun) wrote :

The Cancel-button is not supposed to cancel the script. It just means that the question posed in the dialog is answered negatively. I.e. instead of "Cancel" the button really should read "No".

The problem with zenity (gdialog is just a wrapper script) is that there is no way to achieve that. So the real fix would be to implement a --yesno option for zenity (shouldn't be too difficult).

For a short term fix, I agree that the best solution is to disable the GUI version entirely and drop back to ncurses.

What solution does upstream take (you mention in comment #5 that Debian fixes this particular bug.

Revision history for this message
Vo Dai Chuyen (vdchuyen) wrote :

I've used the GUI version on Elive 0.5 and it works. May be back to ncurses
is a good solution at the moment.

On 10/19/06, Felix Braun <email address hidden> wrote:
>
> The Cancel-button is not supposed to cancel the script. It just means
> that the question posed in the dialog is answered negatively. I.e.
> instead of "Cancel" the button really should read "No".
>
> The problem with zenity (gdialog is just a wrapper script) is that there
> is no way to achieve that. So the real fix would be to implement a
> --yesno option for zenity (shouldn't be too difficult).
>
> For a short term fix, I agree that the best solution is to disable the
> GUI version entirely and drop back to ncurses.
>
> What solution does upstream take (you mention in comment #5 that Debian
> fixes this particular bug.
>
> --
> [Edgy] pppoeconf prints useless error message, doesn't do anything
> https://launchpad.net/bugs/54383
>

--
Key fingerprint = 1BE8 64AA AC4B 776B 31DA 89DE E8AA 4087 E69B 65C2

Revision history for this message
Andreas Simon (andreas-w-simon) wrote :

Debian removed the zenity option and did not replace it with something else:

# IMPORTANT: Do not use gdialog unless it has been fixed!
DIALOG=whiptail

# Set up (X)dialog - added by Fabian Franz <email address hidden>
XDIALOG_HIGH_DIALOG_COMPAT=1
export XDIALOG_HIGH_DIALOG_COMPAT
if [ -n "$DISPLAY" ] && [ -x /usr/bin/Xdialog ] ; then
  DIALOG="Xdialog"
  X11="-X"
fi

Revision history for this message
VLK (valentyn) wrote :

There's only one week until Ubuntu 6.10 release, but the problem still exists! Please, fix the bug, or it wont let many people to get to the Internet, which is the necessary condition to be able to use Ubuntu!

Revision history for this message
Adrien Cunin (adri2000) wrote :

The easiest fix for this annoying problem is to sync from Debian.
From pppoeconf 1.11 changelog : "remove broken support of zenity".
Ubuntu change in 1.10 imported : "Import patch from Ubuntu (1.10ubuntu2 version)".
The problem is that pppoeconf 1.12 (the latest in Debian) doesn't build in an edgy pbuilder.
I managed to make it build by editing the debian/rules.
I will see how it is possible to upload a fixed package.

Revision history for this message
Adrien Cunin (adri2000) wrote :

Sorry, I didn't read an important word in the error message : "ignored". In fact it builds fine, no problem.
Anyway, it seems not possible to upload pppoeconf 1.12 at this point of the development cycle, because of the number of changes.
I will try to create a patch to remove zenity support and attach a debdiff.

Revision history for this message
Adrien Cunin (adri2000) wrote :

Here is the debdiff, I will also attach the .deb.
Please test the .deb and confirm it fixes the bug, then someone will hopefully upload it.

Changed in pppoeconf:
assignee: nobody → adri2000
status: Confirmed → In Progress
Revision history for this message
Adrien Cunin (adri2000) wrote :
Revision history for this message
Andreas Simon (andreas-w-simon) wrote :

Adri2000, yes of course your patch fixed this.

Revision history for this message
Kurt Kraut (kurtkraut) wrote : The patch works

Hi,

I would like to confirm that the patch solves the problem. Please, upload it asap. Without this fix, plenty of people won't be able to connect to internet after upgrading to Edgy. They won't be able even to ask for help.

Revision history for this message
Adrien Cunin (adri2000) wrote :

Kamion gave his ack (on #ubuntu-devel):
<Kamion> Adri2000: your patch is fine; please get a member of ubuntu-core-dev to upload ASAP

I will try to get it uploaded tomorrow.

Revision history for this message
Adrien Cunin (adri2000) wrote :

Uploaded. Thanks to Gloubiboulga :)

Changed in pppoeconf:
status: In Progress → Fix Released
Revision history for this message
x (xk2c-deactivatedaccount) wrote :

from here also thanks. ;)

both Adri2000 and Gloubiboulga

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers