Ubuntu

“python-keystoneclient” 1:0.2.3-0ubuntu2.2 source package in Ubuntu

Changelog

python-keystoneclient (1:0.2.3-0ubuntu2.2) raring-security; urgency=low

  * SECURITY UPDATE: fix auth_token middleware neglects to check expiry of
    signed token when using PKI
    - debian/patches/CVE-2013-2104.patch: explicitly check the expiry on the
      tokens, and reject tokens that have expired. Also update test data
    - fix-v3-with-uuid-and-memcache-expiring.patch: required for above
    - CVE-2013-2104
    - LP: #1179615
  * debian/patches/fix-testsuite-with-sbuild.patch: adjust testsuite to work
    with modern sbuild
  * debian/patches/fix-testsuite-for-2038-problem.patch: Adjust json example
    cert data to use 2037 instead of 2112 and regenerate the certs
 -- Jamie Strandboge <email address hidden>   Thu, 30 May 2013 21:40:36 -0500

Upload details

Uploaded by:
Jamie Strandboge on 2013-05-31
Uploaded to:
Raring
Original maintainer:
Chuck Short
Component:
main
Architectures:
all
Section:
python
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Raring updates on 2013-06-03 main python
Raring security on 2013-06-03 main python

Builds

Raring: [FULLYBUILT] i386

Downloads

File Size MD5 Checksum
python-keystoneclient_0.2.3.orig.tar.gz 191.7 KiB ad6fcbdd0e4cb239d315155bdbe9337c
python-keystoneclient_0.2.3-0ubuntu2.2.debian.tar.gz 38.9 KiB ede6e57b95f183b82c79e0bd2eb299df
python-keystoneclient_0.2.3-0ubuntu2.2.dsc 2.1 KiB 89d63e776321384516e97d9c24d39cf9

Binary packages built by this source

python-keystoneclient: Client library for OpenStack Identity API

 This is a client for the OpenStack Identity API. There's a Python API
 (the ``keystoneclient`` module), and a command-line script (``keystone``).