python3-defaults 3.5.1-3 source package in Ubuntu

Changelog

python3-defaults (3.5.1-3) unstable; urgency=medium

  * Drop build dependency on python3.4.
  * Bump standards and debhelper versions.

 -- Matthias Klose <email address hidden>  Mon, 21 Mar 2016 12:58:34 +0100

Upload details

Uploaded by:
Matthias Klose on 2016-03-23
Uploaded to:
Sid
Original maintainer:
Matthias Klose
Architectures:
any all
Section:
python
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Xenial release on 2016-03-25 main python

Downloads

File Size SHA-256 Checksum
python3-defaults_3.5.1-3.dsc 2.7 KiB e1da92b6e0a03c096ad1442b2ee9ea00ea7f8f02a5f8ce59bc3a75db276e8556
python3-defaults_3.5.1-3.tar.gz 902.5 KiB 8d1284430b77775d4cea62a33b0685e0523b8dfa2ebcc092d382af5cb5b4f237

No changes file available.

Binary packages built by this source

idle3: IDE for Python using Tkinter (default version)

 IDLE is an Integrated Development Environment for Python.
 IDLE is written using Tkinter and therefore quite platform-independent.
 .
 This package is a dependency package, which depends on Debian's default
 Python 3 version (currently v3.5).

libpython3-all-dbg: No summary available for libpython3-all-dbg in ubuntu yakkety.

No description available for libpython3-all-dbg in ubuntu yakkety.

libpython3-all-dev: package depending on all supported Python 3 development packages

 The package currently depends on libpython3.5-dev, in the
 future, dependencies on jython (Python for a JVM) and ironpython (Python
 for Mono) may be added.
 .
 This package is a dependency package used as a build dependency for other
 packages to avoid hardcoded dependencies on specific Python 3 development
 packages.

libpython3-dbg: debug build of the Python 3 Interpreter (version 3.5)

 Python 3 interpreter configured with --pydebug. Dynamically loaded modules
 are searched in /usr/lib/python3.5/lib-dynload/debug first.

libpython3-dev: No summary available for libpython3-dev in ubuntu yakkety.

No description available for libpython3-dev in ubuntu yakkety.

libpython3-stdlib: interactive high-level object-oriented language (default python3 version)

 Python, the high-level, interactive object oriented language,
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package is a dependency package, which depends on Debian's default
 Python 3 version (currently v3.5).

python3: interactive high-level object-oriented language (default python3 version)

 Python, the high-level, interactive object oriented language,
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package is a dependency package, which depends on Debian's default
 Python 3 version (currently v3.5).

python3-all: No summary available for python3-all in ubuntu yakkety.

No description available for python3-all in ubuntu yakkety.

python3-all-dbg: package depending on all supported Python 3 debugging packages

 The package currently depends on python3.5-dbg, in the
 future, dependencies on jython (Python for a JVM) and ironpython (Python
 for Mono) may be added.
 .
 This package is a dependency package used as a build dependency for other
 packages to avoid hardcoded dependencies on specific Python 3 debug packages.

python3-all-dev: package depending on all supported Python 3 development packages

 The package currently depends on python3.5-dev, in the
 future, dependencies on jython (Python for a JVM) and ironpython (Python
 for Mono) may be added.
 .
 This package is a dependency package used as a build dependency for other
 packages to avoid hardcoded dependencies on specific Python 3 development
 packages.

python3-dbg: No summary available for python3-dbg in ubuntu yakkety.

No description available for python3-dbg in ubuntu yakkety.

python3-dev: No summary available for python3-dev in ubuntu yakkety.

No description available for python3-dev in ubuntu yakkety.

python3-doc: documentation for the high-level object-oriented language Python 3

 This is the official set of documentation for the interactive high-level
 object-oriented language Python 3 (v3.5). All documents are provided
 in HTML format, some in info format. The package consists of nine documents:
 .
   * Tutorial
   * Python Library Reference
   * Macintosh Module Reference
   * Python Language Reference
   * Extending and Embedding Python
   * Python/C API Reference
   * Installing Python Modules
   * Documenting Python
   * Distributing Python Modules
 .
 This package is a dependency package, which depends on Debian's default
 Python 3 version (currently v3.5).

python3-examples: No summary available for python3-examples in ubuntu yakkety.

No description available for python3-examples in ubuntu yakkety.

python3-minimal: minimal subset of the Python language (default python3 version)

 This package contains the interpreter and some essential modules. It's used
 in the boot process for some basic tasks.
 See /usr/share/doc/python3.5-minimal/README.Debian for a list of the modules
 contained in this package.

python3-venv: pyvenv-3 binary for python3 (default python3 version)

 Python, the high-level, interactive object oriented language,
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package is a dependency package, which depends on Debian's default
 Python 3 version (currently v3.5).