python3.6 3.6.8-1~18.04.3 source package in Ubuntu

Changelog

python3.6 (3.6.8-1~18.04.3) bionic-security; urgency=medium

  * SECURITY UPDATE: incorrect email address parsing
    - debian/patches/CVE-2019-16056.patch: don't parse domains containing @
      in Lib/email/_header_value_parser.py, Lib/email/_parseaddr.py,
      Lib/test/test_email/test__header_value_parser.py,
      Lib/test/test_email/test_email.py.
    - CVE-2019-16056
  * SECURITY UPDATE: XSS in documentation XML-RPC server
    - debian/patches/CVE-2019-16935.patch: escape the server_title in
      Lib/xmlrpc/server.py, Lib/test/test_docxmlrpc.py.
    - CVE-2019-16935

 -- Marc Deslauriers <email address hidden>  Mon, 07 Oct 2019 08:59:55 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2019-10-07
Uploaded to:
Bionic
Original maintainer:
Matthias Klose
Architectures:
any all
Section:
python
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Bionic security on 2019-10-09 main misc

Downloads

File Size SHA-256 Checksum
python3.6_3.6.8.orig.tar.xz 16.4 MiB 35446241e995773b1bed7d196f4b624dadcadc8429f26282e756b2fb8a351193
python3.6_3.6.8-1~18.04.3.debian.tar.xz 214.4 KiB 471019002d17b33edfa6e4dd4a18b22b9602ab39d87077ac94886f7243b6ad94
python3.6_3.6.8-1~18.04.3.dsc 3.4 KiB e2c90a908ea841a600b86b48e2972614acbf3f599ade8fe820cb6ee2451ff9ce

View changes file

Binary packages built by this source

idle-python3.6: IDE for Python (v3.6) using Tkinter

 IDLE is an Integrated Development Environment for Python (v3.6).
 IDLE is written using Tkinter and therefore quite platform-independent.

libpython3.6: Shared Python runtime library (version 3.6)

 Python is a high-level, interactive, object-oriented language. Its 3.6 version
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package contains the shared runtime library, normally not needed
 for programs using the statically linked interpreter.

libpython3.6-dbg: Debug Build of the Python Interpreter (version 3.6)

 The package holds two things:
 .
 - Extensions for a Python interpreter configured with --pydebug.
 - Debug information for standard python extensions.
 .
 See the README.debug for more information.

libpython3.6-dev: Header files and a static library for Python (v3.6)

 Header files, a static library and development tools for building
 Python (v3.6) modules, extending the Python interpreter or embedding
 Python (v3.6) in applications.
 .
 Maintainers of Python packages should read README.maintainers.
 .
 This package contains development files. It is normally not
 used on it's own, but as a dependency of python3.6-dev.

libpython3.6-minimal: Minimal subset of the Python language (version 3.6)

 This package contains some essential modules. It is normally not
 used on it's own, but as a dependency of python3.6-minimal.

libpython3.6-stdlib: Interactive high-level object-oriented language (standard library, version 3.6)

 Python is a high-level, interactive, object-oriented language. Its 3.6 version
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package contains Python 3.6's standard library. It is normally not
 used on its own, but as a dependency of python3.6.

libpython3.6-testsuite: Testsuite for the Python standard library (v3.6)

 The complete testsuite for the Python standard library. Note that
 a subset is found in the libpython3.6-stdlib package, which should
 be enough for other packages to use (please do not build-depend
 on this package, but file a bug report to include additional
 testsuite files in the libpython3.6-stdlib package).

python3.6: Interactive high-level object-oriented language (version 3.6)

 Python is a high-level, interactive, object-oriented language. Its 3.6 version
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.

python3.6-dbg: Debug Build of the Python Interpreter (version 3.6)

 The package holds two things:
 .
 - A Python interpreter configured with --pydebug. Dynamically loaded modules
   are searched as <foo>_d.so first. Third party extensions need a separate
   build to be used by this interpreter.
 - Debug information for standard python interpreter and extensions.
 .
 See the README.debug for more information.

python3.6-dev: Header files and a static library for Python (v3.6)

 Header files, a static library and development tools for building
 Python (v3.6) modules, extending the Python interpreter or embedding
 Python (v3.6) in applications.
 .
 Maintainers of Python packages should read README.maintainers.

python3.6-doc: Documentation for the high-level object-oriented language Python (v3.6)

 These is the official set of documentation for the interactive high-level
 object-oriented language Python (v3.6). All documents are provided
 in HTML format. The package consists of ten documents:
 .
   * What's New in Python3.6
   * Tutorial
   * Python Library Reference
   * Macintosh Module Reference
   * Python Language Reference
   * Extending and Embedding Python
   * Python/C API Reference
   * Installing Python Modules
   * Documenting Python
   * Distributing Python Modules

python3.6-examples: Examples for the Python language (v3.6)

 Examples, Demos and Tools for Python (v3.6). These are files included in
 the upstream Python distribution (v3.6).

python3.6-minimal: Minimal subset of the Python language (version 3.6)

 This package contains the interpreter and some essential modules. It can
 be used in the boot process for some basic tasks.
 See /usr/share/doc/python3.6-minimal/README.Debian for a list of the modules
 contained in this package.

python3.6-venv: Interactive high-level object-oriented language (pyvenv binary, version 3.6)

 Python is a high-level, interactive, object-oriented language. Its 3.6 version
 includes an extensive class library with lots of goodies for
 network programming, system administration, sounds and graphics.
 .
 This package contains the pyvenv-3.6 binary.