Ubuntu

unexpectedly died

Reported by Rihards on 2006-11-11
8
Affects Status Importance Assigned to Milestone
qucs (Ubuntu)
Undecided
Unassigned

Bug Description

tried to change switch atributes

Rihards (rihards-kazainis) wrote :
William Grant (wgrant) wrote :

It works for me... Which version of Ubuntu do you have, and can you give a set of steps required to reproduce the issue?

Changed in qucs:
status: Unconfirmed → Needs Info
Rafael Ávila Coya (ravila-edu) wrote :

In my case, I tried about 5 times to reproduce (both in Gnome (Ubuntu 6.10) and KDE (kubuntu 6.10)) the example we have in help. That is a beginners example of a circuit with a voltage source of 1Volt and to resistances in series (one of 50 and the other of 100V). You want to find out the value in between the resistances (about 0.7Volts). You go to simulations, then drag "tabular" simulation, double clic on divider (I don't know the exact name in the english environment, as I use the spanish version), then "aply" and after half a second the whole application exits unexpectedly.

I attach the bug report

Charles JOUBERT (ckrounch) wrote :

This bugs is perhaps related to this one :
http://sourceforge.net/mailarchive/forum.php?thread_name=42957.128.178.193.179.1172267794.squirrel%40www-mail.magbio.ens.fr&forum_name=qucs-help

In both cases, the bug (crash or invalid data) arises after the diagram dialog is called and the OK button clicked.

I experimented the same problem as described in the link above. With the help of Stefan Jahn (leader of the qucs project), I tracked down the bug, and it has to do with an unforeseen call to setlocale in /usr/lib/libscim (called from Qt) which changes LC_NUMERIC from "C" to the platfrom language ("FR_fr" in my case).
The problem is that the data files are not correctly read after the change (hence the <invalid> label for the axes, and perhaps crashes in soe cases ?).

Note that the bug appears only if the decimal separator (configured by LC_NUMERIC/LC_ALL) is different from a point (a coma infrench an in other countries).

I join a patch against qucs-0.0.11 which cleared the problem for me. Note it's a "quick and dirty" solution. /usr/lib/libscim sould probably not change the locales during its initialization.

Charles JOUBERT (ckrounch) wrote :

I also join a backtrace obtained with GDB during the setlocale call.

JJL (buggerone) wrote :

In case this is related to the locale problem, a workaround is to change the LC_NUMERIC before starting qucs.

For exemple start it with this command line :
LC_NUMERIC=C qucs

Launchpad Janitor (janitor) wrote :

[Expired for qucs (Ubuntu) because there has been no activity for 60 days.]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers