Change log for rmpi package in Ubuntu

140 of 40 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-06-26
Deleted in groovy-proposed (Reason: moved to Release)
rmpi (0.6-9-1build1) groovy; urgency=medium

  * No-change rebuild against r-api-4.0

 -- Graham Inggs <email address hidden>  Sat, 30 May 2020 10:40:08 +0000
Superseded in groovy-release on 2020-06-26
Published in focal-release on 2019-10-18
Obsolete in eoan-release on 2020-12-29
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed (Reason: moved to release)
rmpi (0.6-9-1) unstable; urgency=medium

  * New upstream release

 -- Dirk Eddelbuettel <email address hidden>  Tue, 13 Nov 2018 06:03:20 -0600

Available diffs

Superseded in disco-release on 2018-11-23
Deleted in disco-proposed on 2018-11-24 (Reason: moved to release)
rmpi (0.6-8-1) unstable; urgency=medium

  * New upstream release
  
  * debian/control: Set Build-Depends: to current R version
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Mon, 12 Nov 2018 10:17:08 -0600
Superseded in disco-release on 2018-11-13
Obsolete in cosmic-release on 2020-07-13
Deleted in cosmic-proposed on 2020-07-13 (Reason: moved to release)
rmpi (0.6-7-1build2) cosmic; urgency=medium

  * No-change rebuild against r-api-3.5

 -- Graham Inggs <email address hidden>  Fri, 01 Jun 2018 09:33:37 +0000
Superseded in cosmic-proposed on 2018-06-01
rmpi (0.6-7-1build1) cosmic; urgency=medium

  * No-change rebuild for dune openmpi soname change.

 -- Matthias Klose <email address hidden>  Sun, 13 May 2018 17:03:42 +0000
Deleted in cosmic-release on 2018-06-21 (Reason: remove rmpi from the release pocket, removing the entangl...)
Deleted in cosmic-proposed on 2018-06-21 (Reason: moved to release)
rmpi (0.6-7-1) unstable; urgency=medium

  * New upstream release
  
  * debian/control: Set Build-Depends: to current R version
  * debian/control: Set Standards-Version: to current version 
  * debian/control: Add Vcs-Browser: and Vcs-Git:
  * debian/compat: Increase level to 9
  * debian/control: Switch from cdbs to dh-r
  * debian/rules: Idem

 -- Dirk Eddelbuettel <email address hidden>  Wed, 11 Apr 2018 12:53:01 -0500
Superseded in cosmic-release on 2018-05-05
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed (Reason: moved to release)
rmpi (0.6-6-4build1) artful; urgency=medium

  * No-change rebuild to pick up r-api-3.4

 -- Graham Inggs <email address hidden>  Wed, 27 Sep 2017 10:03:45 +0000
Superseded in artful-release on 2017-10-03
Deleted in artful-proposed on 2017-10-04 (Reason: moved to release)
rmpi (0.6-6-4) unstable; urgency=medium

  * src/Rmpi.c: Also explicitly check for libmpi.so.20 as dlopen() is
    required with some flags to resolve linking		(Closes: #861748)

 -- Dirk Eddelbuettel <email address hidden>  Sat, 06 May 2017 14:45:22 -0500

Available diffs

Superseded in artful-release on 2017-05-25
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
rmpi (0.6-6-3) unstable; urgency=medium

  * configure.ac: Rewritten in terms of pkg-config
  * debian/control: Added pkg-config to Build-Depends

 -- Dirk Eddelbuettel <email address hidden>  Fri, 06 Jan 2017 07:17:27 -0600
Superseded in zesty-proposed on 2017-01-06
rmpi (0.6-6-2) unstable; urgency=medium

  * configure.ac: Add a new location for mpi.h to account for updated
    layout in Open MPI 2.0; will send upstream too 	(Closes: #850336)
  * configure: Updated accordingly

 -- Dirk Eddelbuettel <email address hidden>  Thu, 05 Jan 2017 19:59:00 -0600
Superseded in zesty-release on 2017-01-06
Deleted in zesty-proposed on 2017-01-08 (Reason: moved to release)
rmpi (0.6-6-1build1) zesty; urgency=medium

  * No-change rebuild against libopenmpi2

 -- Steve Langasek <email address hidden>  Sat, 22 Oct 2016 01:53:30 +0000
Superseded in zesty-release on 2016-10-27
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
rmpi (0.6-6-1) unstable; urgency=medium

  * New upstream release
 
  * debian/control: Set Build-Depends: to current R version
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Sat, 25 Jun 2016 07:43:11 -0500
Superseded in yakkety-release on 2016-06-26
Published in xenial-release on 2016-02-15
Deleted in xenial-proposed (Reason: moved to release)
rmpi (0.6-5-1build2) xenial; urgency=medium

  * No-change rebuild for openmpi on s390x.

 -- Matthias Klose <email address hidden>  Sat, 06 Feb 2016 19:52:50 +0000
Superseded in xenial-proposed on 2016-02-06
rmpi (0.6-5-1build1) xenial; urgency=medium

  * No-change rebuild for openmpi transition.

 -- Matthias Klose <email address hidden>  Mon, 01 Feb 2016 11:39:20 +0000
Superseded in xenial-release on 2016-02-15
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-22 (Reason: moved to release)
rmpi (0.6-5-1) unstable; urgency=low


  * New upstream release

 -- Dirk Eddelbuettel <email address hidden>  Wed, 21 May 2014 06:52:16 -0500

Available diffs

Superseded in utopic-release on 2014-05-22
Deleted in utopic-proposed on 2014-05-23 (Reason: moved to release)
rmpi (0.6-4-1) unstable; urgency=low


  * New upstream release
  
  * debian/control: Set Build-Depends: to current R version

 -- Dirk Eddelbuettel <email address hidden>  Sat, 17 May 2014 06:48:06 -0500
Superseded in utopic-release on 2014-05-18
Deleted in utopic-proposed on 2014-05-19 (Reason: moved to release)
rmpi (0.6-3-2build1) utopic; urgency=medium

  * No-change rebuild to drop mpich dependency on arm64.
 -- Logan Rosen <email address hidden>   Fri, 02 May 2014 11:25:52 -0400
Superseded in utopic-proposed on 2014-05-02
rmpi (0.6-3-2) unstable; urgency=low


  * src/Rmpi.c: Applied patch from Don Armstrong to check for libmpi.so.0
    and libmpi.so.1 which has been forwarded upstream	(Closes: #741297)

  * debian/control: Set Build-Depends: to current R version
  * debian/control: Set Standards-Version: to current version 
  
 -- Dirk Eddelbuettel <email address hidden>  Tue, 25 Mar 2014 06:16:15 -0500
Superseded in utopic-release on 2014-05-13
Published in trusty-release on 2013-12-17
Deleted in trusty-proposed (Reason: moved to release)
rmpi (0.6-3-1build1) trusty; urgency=medium

  * No-change rebuild for libopenmpi1.3 -> libopenmpi1.6 transition.
 -- Logan Rosen <email address hidden>   Mon, 16 Dec 2013 00:24:34 -0500
Superseded in trusty-release on 2013-12-17
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
rmpi (0.6-3-1) unstable; urgency=low


  * New upstream release
  
  * debian/control: Set Build-Depends: to current R version 
  
  * (Re-)building with R 3.0.0 (beta)

 -- Dirk Eddelbuettel <email address hidden>  Tue, 26 Mar 2013 14:37:20 -0500

Available diffs

Superseded in saucy-release on 2013-04-30
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
rmpi (0.6-1-1) unstable; urgency=low


  * New upstream release

 -- Dirk Eddelbuettel <email address hidden>  Mon, 20 Aug 2012 05:18:07 -0500

Available diffs

Superseded in raring-release on 2012-10-30
Obsolete in quantal-release on 2015-04-24
rmpi (0.5-9-3) unstable; urgency=low


  * configure.ac: Modified to cope with MPICH2 which should help with
    architectures which cannot provide OpenMPI

  * debian/control: Set Build-Depends: to current R version
  * debian/control: Change Depends to ${R:Depends}
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Tue, 15 May 2012 16:13:17 -0500

Available diffs

Superseded in quantal-release on 2012-05-24
Published in precise-release on 2011-11-11
rmpi (0.5-9-2) unstable; urgency=low

  * Rebuilt for R 2.14.0 so that a default NAMESPACE file is created

  * debian/control: Set (Build-)Depends: to current R version
  * debian/control: Set Standards-Version: to current version
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  11 Nov 2011 09:27:53 +0000

Available diffs

Superseded in precise-release on 2011-11-11
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
rmpi (0.5-9-1) unstable; urgency=low

  * New upstream release
  
  * debian/control: Set (Build-)Depends: to current R version
  * debian/control: Set Standards-Version: to current version 
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  03 Dec 2010 16:48:16 +0000

Available diffs

Superseded in natty-release on 2010-12-03
Obsolete in maverick-release on 2013-03-05
rmpi (0.5-8-2) unstable; urgency=low

  * debian/rules: Pass extra argument '--no-test-load' to R CMD INSTALL 
    as we would need an MPI env. to load Rmpi		(Closes: #584353)
  
  * debian/control: Set (Build-)Depends: to current R version
  * debian/control: Set Standards-Version: to current version 
  
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  05 Jun 2010 11:30:38 +0100

Available diffs

Superseded in maverick-release on 2010-06-05
Obsolete in lucid-release on 2016-10-26
rmpi (0.5-8-1) unstable; urgency=low

  * New upstream release

  * debian/control: Set (Build-)Depends: to current R version
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  02 Feb 2010 00:00:37 +0000

Available diffs

Superseded in lucid-release on 2010-02-02
rmpi (0.5-7-4) unstable; urgency=low

  * Rebuilt for R 2.10.0 to work with new R-internal help file conversion

  * debian/control: Set (Build-)Depends: to current R version
  * debian/control: Set Standards-Version: to current version 
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  30 Nov 2009 23:46:42 +0000

Available diffs

Superseded in lucid-release on 2009-12-01
Obsolete in karmic-release on 2013-03-04
rmpi (0.5-7-3build2) karmic; urgency=low

  * Rebuild for the OpenMPI transition.

 -- Luca Falavigna <email address hidden>   Mon, 08 Jun 2009 23:39:48 +0200

Available diffs

Superseded in karmic-release on 2009-06-09
rmpi (0.5-7-3) unstable; urgency=low

  * debian/control: Corrected typo and set Depends: to mpi-default-bin

Available diffs

Superseded in karmic-release on 2009-06-04
rmpi (0.5-7-1) unstable; urgency=low

  * New upstream release

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
rmpi (0.5-6-1) unstable; urgency=low

  * New upstream release

  * debian/control: (Build-)Depends: updated to r-base-dev (>= 2.8.0)
  * debian/control: Standards-Version: upgradeded to current version
  

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  06 Dec 2008 22:02:47 +0000

Available diffs

Superseded in jaunty-release on 2008-12-06
Obsolete in intrepid-release on 2013-02-20
rmpi (0.5-5-2) unstable; urgency=low

  * debian/control: Set versioned Build-Depends on libopenmpi-dev (>= 1.2.4-5)

  * configure.ac, configure: Patched to also search in /usr/lib/openmpi
    for include/mpi.h and libraries; patch sent upstream; will be in next
    (upstream) release 0.5-6  				(Closes: #456851)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 02:24:45 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
rmpi (0.5-5-1) unstable; urgency=low

  * New upstream release

  * debian/control: Split (Build-)Depends: on MPI libraries: 
    	libopenmpi-dev [i386 amd64 alpha ia64 powerpc sparc], 
  	lam4-dev [!i386 !amd64 !alpha !ia64 !powerpc !sparc]  
    in other words we use LAM as the fallback where Open MPI is not avilable

  * Built with R 2.6.0, so setting (Build-)Depends: to 
    'r-base-(core|dev) >= 2.6.0' to prevent move to testing before R 2.6.0

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  27 Oct 2007 22:24:34 +0100
Superseded in hardy-release on 2007-10-27
rmpi (0.5-4-2) unstable; urgency=low

  * src/Rmpi.c: Patch suggested by upstream to silence the (erraneous)
    Open MPI 'osc pt2pt' warning message
  
  * debian/control: Add 'openmpi-bin' to Depends: as the mpirun (aka 
    orterun) frontend is needed

Superseded in hardy-release on 2007-10-24
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
rmpi (0.5-3-1) unstable; urgency=low

  * New upstream release
  
  * debian/rules: Simplified to cdbs-based one-liner sourcing r-cran.mk 
  * debian/control: Build-Depends: updated to r-base-dev (>= 2.4.0)
  * debian/control: Standards-Version: upgradeded to 3.7.2

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  08 Nov 2006 17:38:01 +0000
Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
rmpi (0.5-2-1) unstable; urgency=low

  * New upstream release

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Jun 2006 15:30:43 +0100
Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
rmpi (0.5-1-1) unstable; urgency=low


  * New upstream release

  * debian/post{inst,rm}: Really no longer call R to update html index

 -- Dirk Eddelbuettel <email address hidden>  Thu,  5 Jan 2006 20:54:37 -0600
Superseded in dapper-release on 2006-01-31
rmpi (0.5-0-1) unstable; urgency=low


  * New upstream release

  * debian/watch: Updated regular expression
  * debian/post{inst,rm}: No longer call R to update html index

 -- Dirk Eddelbuettel <email address hidden>  Mon, 28 Nov 2005 20:35:21 -0600
Obsolete in breezy-release on 2008-03-25
rmpi (0.4.9-1build1) breezy; urgency=low


  * Rebuild for unmet dependencies

 -- Andrew Mitchell <email address hidden>  Sat, 27 Aug 2005 02:00:36 +1200
Obsolete in hoary-release on 2008-03-19
rmpi (0.4.8-2) unstable; urgency=low


  * Rebuilt under R 2.0.0
  * debian/control: Updated Build-Depends: and Depends: accordingly
  * debian/post{inst,rm}: Only run build-help.pl if R is installed
  * debian/watch: Added watch file
  * debian/control: Added Suggests: r-cran-rsprng

 -- Dirk Eddelbuettel <email address hidden>  Fri,  8 Oct 2004 20:23:16 -0500
140 of 40 results