ruby2.5 2.5.3-3ubuntu1 source package in Ubuntu

Changelog

ruby2.5 (2.5.3-3ubuntu1) disco; urgency=medium

  * Merge with Debian unstable (LP: #1806694). Remaining changes:
    - d/p/1dfc377ae3b174b043d3f0ed36de57b0296b34d0.patch: Cherrypick
      upstream commit to fix session resumption with TLS 1.3.
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch
  * Dropped changes
    - various backports for better openssl support (formerly undocumented in
      changelog, but upstream now)
      + d/p/0002-no-ID-cache-in-Init-functions.patch
      + d/p/0003-search-winsock-libraries-explicitly.patch
      + d/p/0004-openssl-search-winsock.patch
      + d/p/0007-openssl_missing.h-constified.patch
      + d/p/0008-reduce-LibreSSL-warnings.patch
      + d/p/0009-openssl-sync-with-upstream-repository.patch
    - SECURITY UPDATE: Name equality check CVE-2018-16395 (in upstream)
    - SECURITY UPDATE: Tainted flags not propagted CVE-2018-16396 (in upstream)
    - 0012-test-time-tzdata-2018f.patch: Adjust tz tests for new tzdata.

ruby2.5 (2.5.3-3) unstable; urgency=medium

  * arm64: also skip TestBugReporter#test_bug_reporter_add, which also fails~
    4% of the time.
  * mipsel: fix location of skiplist for OpenSSL::TestSSL, from TestSSL.rb to
    OpenSSL/TestSSL.rb.
  * Remove skiplist for OpenSSL::TestSSL on all architectures. It was in the
    wrong place to begin with.
  * Fix location of skiplist for Rinda-related tests.

ruby2.5 (2.5.3-2) unstable; urgency=medium

  * arm64: skip TestRubyOptions#test_segv_loaded_features, fails ~3% of the
    time
  * mipsel: skip OpenSSL::TestSSL tests that frequently timeout on the Debian
    buildds
    - test_dh_callback
    - test_get_ephemeral_key
    - test_post_connect_check_with_anon_ciphers

ruby2.5 (2.5.3-1) unstable; urgency=medium

  * New upstream version 2.5.3
    - Includes fix for CVE-2018-16396, "Tainted flags are not propagated in
      Array#pack and String#unpack with some directives" (Closes: #911920)
  * Refresh patches:
    - Dropped 0009-merge-changes-in-ruby-openssl-v2.1.1.patch, already applied
      upstream.
  * Add tzdata to Build-Depends (Closes: #911717)
  * Cherry-pick upstream commmit with update to tests due to changes in tzdata
    2018f (Closes: #913181)
  * Update gemspec reproducibility patch to also make new default gems fiddle
    and ipaddr reproducible. (Closes: #898051)
  * debian/rules: don't install created.rid file produced by rdoc to make
    build reproducible. This file is used by rdoc to decide when to update
    documentation when in use in interactive settings, and containing a
    timestamp is one of its functions. Is is not necessary for a binary
    package, though, because the included documentation will never need to be
    updated in-place.

 -- Christian Ehrhardt <email address hidden>  Tue, 04 Dec 2018 15:40:55 +0100

Upload details

Uploaded by:
Christian Ehrhardt  on 2018-12-05
Uploaded to:
Disco
Original maintainer:
Ubuntu Developers
Architectures:
any all
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Disco release on 2018-12-06 main misc

Downloads

File Size SHA-256 Checksum
ruby2.5_2.5.3.orig.tar.xz 9.7 MiB 4953ab3299b6feaec99f4fa1507f3b276951f4c1c99aa435b8e0b1b4afe38302
ruby2.5_2.5.3-3ubuntu1.debian.tar.xz 117.2 KiB a4f22177ef641e9eaf0a9e9d06886a48e4b85978627a5ce5f506a72dbb7223c1
ruby2.5_2.5.3-3ubuntu1.dsc 2.5 KiB d73ec81c174d79f658916e9e5d2bec87346df64cbd9f0e4ce00364bbc285d6b8

Available diffs

View changes file

Binary packages built by this source

libruby2.5: Libraries necessary to run Ruby 2.5

 Ruby is the interpreted scripting language for quick and easy
 object-oriented programming. It has many features to process text
 files and to do system management tasks (as in perl). It is simple,
 straight-forward, and extensible.
 .
 This package includes the 'libruby-2.5' library, necessary to run Ruby 2.5.
 (API version 2.5.0)

libruby2.5-dbgsym: debug symbols for libruby2.5
ruby2.5: Interpreter of object-oriented scripting language Ruby

 Ruby is the interpreted scripting language for quick and easy
 object-oriented programming. It has many features to process text
 files and to do system management tasks (as in perl). It is simple,
 straight-forward, and extensible.
 .
 In the name of this package, `2.5' indicates the Ruby library compatibility
 version. This package currently provides the `2.5.x' branch of Ruby.

ruby2.5-dbgsym: debug symbols for ruby2.5
ruby2.5-dev: Header files for compiling extension modules for the Ruby 2.5

 Ruby is the interpreted scripting language for quick and easy
 object-oriented programming. It has many features to process text
 files and to do system management tasks (as in perl). It is simple,
 straight-forward, and extensible.
 .
 This package contains the header files and the mkmf library, necessary
 to make extension library for Ruby 2.5. It is also required to build
 many gems.

ruby2.5-doc: Documentation for Ruby 2.5

 Ruby is the interpreted scripting language for quick and easy
 object-oriented programming. It has many features to process text
 files and to do system management tasks (as in perl). It is simple,
 straight-forward, and extensible.
 .
 This package contains the autogenerated documentation for Ruby 2.5.